Даны два натуральных числа?

Информатика | 5 - 9 классы

Даны два натуральных числа.

Выяснить в каком из них сумма цифр больше.

(Определить функцию для расчета суммы цифр натурального числа).

Ответить на вопрос
Ответы (1)
Kukanastya 21 нояб. 2020 г., 04:16:21

Var a, b : integer ;

function sum(c : integer) : integer ;

var s : string ; i, r : integer ;

begin r : = 0 ; s : = inttostr(c) ; for i : = 1 to length(s) do r : = r + strtoint(s[i]) ; result : = r ;

end ;

begin readln(a, b) ; if (sum(a) > ; sum(b)) then writeln('A > ; B') else if (sum(a) = sum(b)) then writeln('A = B') else writeln('A < ; B') ;

end.

I ♥ functions : ).

Neka200 9 авг. 2020 г., 08:35:35 | 10 - 11 классы

Дано натуральное четырехзначное число n?

Дано натуральное четырехзначное число n.

Найти сумму его цифр.

Nshaposhnik 29 мар. 2020 г., 18:01:36 | 5 - 9 классы

Дано натуральное число : − найти сумму цифр этого числа ; − верно ли, что число начинается и заканчивается одной и той же цифрой?

Дано натуральное число : − найти сумму цифр этого числа ; − верно ли, что число начинается и заканчивается одной и той же цифрой.

28071997 14 февр. 2020 г., 08:49:37 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Верно ли, что сумма его цифр больше 10?

Paskal.

Drashchiker 21 февр. 2020 г., 23:43:56 | 5 - 9 классы

Дано натуральное число n?

Дано натуральное число n.

Найти сумму первой и последней цифры этого числа.

CamKo 22 мар. 2020 г., 10:05:22 | 5 - 9 классы

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа?

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа!

Polyagrig 9 февр. 2020 г., 09:02:45 | 5 - 9 классы

Дано четырехзначное натуральное число?

Дано четырехзначное натуральное число.

Определить является ли сумма первой и последней цифр кратной 3 Паскаль.

Eqorqeiko 11 мар. 2020 г., 07:55:46 | 10 - 11 классы

Код программы в PASCAL, СРОЧНО?

Код программы в PASCAL, СРОЧНО!

Условие : Вводятся 3 натуральных числа.

Найти сумму цифр каждого из них (создать функцию для нахождения суммы цифр произвольного натурального числа).

Brownsoks 19 дек. 2020 г., 23:26:36 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Определить сумму его цифр, больших 5.

Vipaybashev1 16 окт. 2020 г., 18:36:21 | 5 - 9 классы

Дано натуральное число n?

Дано натуральное число n.

Определить : a) Количество цифр в этом числе ; б)Сумму его цифр ; в)Первую цифру числа n ;

121redto 31 дек. 2020 г., 03:21:42 | 5 - 9 классы

Дано натуральному число?

Дано натуральному число.

Верно ли, что сумма его цифр не меньше 10?

На этой странице вы найдете ответ на вопрос Даны два натуральных числа?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.