Срочно?

Информатика | 5 - 9 классы

Срочно!

Написать в Pascal ABC Дано N чисел.

Найти самое большое число, на которое делятся все N чисел.

Входные данные В первой строке дано число N.

Во второй строке даны через пробел N чисел (1 < ; = N < ; = 1000).

Выходные данные Выведите искомое число.

Ответить на вопрос
Ответы (1)
АлинаМостакова 26 сент. 2020 г., 18:44:05

Var a : array of integer ; i, n, x, digit : integer ; b1, b2 : boolean ;

begin

readln(n) ;

setlength(a, n) ;

for i : = 0 to n - 1 do readln(a[i]) ;

b1 : = true ;

x : = 1 ;

digit : = x ;

while b1 do begin if b2 then digit : = x ; inc(x) ; b2 : = true ; for i : = 0 to n - 1 do begin if (abs(a[i]) < ; x) and (a[i] < ; > ; 0) then begin b1 : = false ; break ; end else if a[i] mod x < ; > ; 0 then begin b2 : = false ; break ; end end ;

end ;

write(digit) ;

end.

Doroshenko2002 5 февр. 2020 г., 23:51:13 | 10 - 11 классы

Помогите написать программу на PascalABCNET Дано сначала число n, а затем n натуральных чисел, не превосходящих 100?

Помогите написать программу на PascalABCNET Дано сначала число n, а затем n натуральных чисел, не превосходящих 100.

Выведите на экран в порядке возрастания только те из них, которые встречаются в данной последовательности ровно один раз.

ВХОДНЫЕ ДАННЫЕ В первой строке вводится одно число n — натуральное, не превосходящее 10000.

Во второй строке вводятся n натуральных чисел, не превосходящих 100.

ВЫХОДНЫЕ ДАННЫЕ Выведите в порядке возрастания те из них, которые встречаются в последовательности ровно один раз.

Oskoklkovaalyona 18 мар. 2020 г., 11:21:10 | 5 - 9 классы

Определите, чему будет равна сумма всех целых чисел от единицы до заданного числа N?

Определите, чему будет равна сумма всех целых чисел от единицы до заданного числа N.

Входные данные Первая строка содержит целое число N (1 < ; = N < ; = 100).

Выходные данные Выведите одно целое число — сумму чисел от 1 до N.

PFK 25 авг. 2020 г., 16:21:55 | 5 - 9 классы

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N?

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

Формат входных данных Задано единственное число N.

Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Virus1420 1 окт. 2020 г., 07:10:54 | 5 - 9 классы

Вычислите сумму данных N натуральных чисел?

Вычислите сумму данных N натуральных чисел.

Входные данные Вводится число N, а затем N чисел, сумму которых необходимо вычислить.

Выходные данные Выведите единственное число - сумму введенных чисел.

В Pascal ABC.

Ilililililil 19 окт. 2020 г., 06:29:49 | 5 - 9 классы

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ?

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ!

25баллов Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

Входные данные Задано единственное целое число N Выходные данные Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Примеры входные данные 15 выходные данные 1 4 9.

Eslandaadiyeva 17 мая 2020 г., 17:19:06 | 5 - 9 классы

Нужно составить программу в Pascal ABC с использованием цикла?

Нужно составить программу в Pascal ABC с использованием цикла.

Условие : Вычислите сумму данных N натуральных чисел.

Входные данные Вводится число N, а затем N чисел, сумму которых необходимо вычислить.

Выходные данные Выведите единственное число - сумму введенных чисел.

Fokin05 29 апр. 2020 г., 09:31:01 | 10 - 11 классы

Дано сначала число n, а затем n натуральных чисел, не превосходящих 100?

Дано сначала число n, а затем n натуральных чисел, не превосходящих 100.

Выведите на экран в порядке возрастания только те из них, которые встречаются в данной последовательности ровно один раз.

ВХОДНЫЕ ДАННЫЕ В первой строке вводится одно число n — натуральное, не превосходящее 10000.

Во второй строке вводятся n натуральных чисел, не превосходящих 100.

ВЫХОДНЫЕ ДАННЫЕ Выведите в порядке возрастания те из них, которые встречаются в последовательности ровно один раз.

Nataelyut 3 мар. 2020 г., 00:05:17 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется вывести только неотрицательные числа.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести все неотрицательные числа в том же порядке, в каком они расположены во входном файле.

Дмитрий394 22 сент. 2020 г., 11:37:36 | 10 - 11 классы

Найдите потерянное число?

Найдите потерянное число.

Вам даны все целые число от 1 до N + 1, кроме одного.

Найдите отсутствующее число.

Формат входных данных : в первой строке входных данных записано целое число N (1< ; = N< ; = 100, 000).

Во второй строке через пробел даны N целых чисел в диапазоне от 1 до N + 1.

Oklubkova 10 дек. 2020 г., 09:26:25 | 5 - 9 классы

Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел?

Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел.

Входные данные

Входная строка содержит 5 целых чисел, разделённых пробелами.

Выходные данные

В первой строке нужно вывести минимальное из введённых чисел, во второй строке – максимальное.

Примеры

входные данные

1 2 3 4 5

выходные данные

1

5

На паскале.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Срочно?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.