Вася загадал число от 1 до N?

Информатика | 5 - 9 классы

Вася загадал число от 1 до N.

За какое наименьшее количество вопросов (на которые Вася отвечает "да" или "нет") Петя может угадать Васино число?

Входные данные Вводится одно число N Выходные данные Выведите наименьшее количество вопросов, которого гарантированно хватит Пете, чтобы угадать Васино число.

Примеры входные данные 5 выходные данные 3.

Ответить на вопрос
Ответы (1)
Неведимка 30 нояб. 2020 г., 19:49:02

Var n, k : integer ;

begin

write('n = ') ;

readln(n) ;

k : = trunc(ln(n - 1) / ln(2)) + 1 ;

writeln('k = ', k) ;

end.

Пример :

n = 5

k = 3.

Www1955 6 дек. 2020 г., 22:51:23 | 5 - 9 классы

Даны два натуральных числа n и m?

Даны два натуральных числа n и m.

Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число.

Входные данные Вводятся два числа.

Выходные данные Выведите ответ на задачу.

(Примеры : входные данные - 2, 8.

Выходные - 1).

P. S.

Решить надо в Паскаль АБЦ!

Halmetova2000 3 мар. 2020 г., 05:26:02 | 5 - 9 классы

Решить в Паскаль АБЦ?

Решить в Паскаль АБЦ!

Даны два натуральных числа n и m.

Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число.

"Входные данные" Вводятся два числа.

"Выходные данные" Выведите ответ на задачу.

(Примеры : входные - 2, 8.

Выходные - 1).

DimaDey 13 февр. 2020 г., 02:59:01 | 5 - 9 классы

Выведите число, поданное на ввод?

Выведите число, поданное на ввод.

ВХОДНЫЕ ДАННЫЕ Одно целое положительное число, не превышающее 1000.

Одно целое положительное число, не превышающее 1000.

ВЫХОДНЫЕ ДАННЫЕ Выведите то же самое число.

На языке С.

Ммутыл 16 нояб. 2020 г., 15:25:50 | 5 - 9 классы

ПРОШУ ПОМОГИТЕ ОЧЕНЬ СРОЧНО Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 < ; = x < ; = 30000)?

ПРОШУ ПОМОГИТЕ ОЧЕНЬ СРОЧНО Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 < ; = x < ; = 30000).

Входные данные Вводится натуральное число x.

Выходные данные Выведите наименьший делитель числа x, отличный от 1.

Примеры входные данные 2 выходные данные 2 входные данные 6 выходные данные 2.

Irenaz 29 мар. 2020 г., 08:01:21 | 5 - 9 классы

Задача №334?

Задача №334.

Остаток Входные данные Вводятся 4 числа : a, b, c и d.

Выходные данные Выведите все числа на отрезке от a до b, дающие остаток c при делении на d.

Если таких чисел не существует, то ничего выводить не нужно.

Примеры входные данные 2 5 0 2 выходные данные 2 4 входные данные 2 7 9 14 выходные данные.

Букава 5 июн. 2020 г., 07:46:55 | 5 - 9 классы

Входные данные Вводятся целые числа a и b?

Входные данные Вводятся целые числа a и b.

Гарантируется, что a не превосходит b.

Выходные данные Выведите все числа на отрезке от a до b, являющиеся полными квадратами.

Если таких чисел нет, то ничего выводить не нужно.

Примеры входные данные 1 1 выходные данные 1 входные данные 2 8 выходные данные 4 Заранее спасибо.

Misha13Misha13 11 июн. 2020 г., 14:04:04 | 5 - 9 классы

Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд?

Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд.

Количество минут и секунд при необходимости дополняются до двузначного числа нулями.

С начала суток прошло n секунд.

Выведите, что покажут часы.

Входные данные Вводится целое число n.

Выходные данные Выведите ответ на задачу, соблюдая требуемый формат.

Примеры Входные данные 3602 Выходные данные 1 : 00 : 02 Входные данные 129700 Выходные данные 12 : 01 : 40.

Викуляsv 12 янв. 2020 г., 08:29:06 | 5 - 9 классы

Входные данные Вводятся целые числа a и b?

Входные данные Вводятся целые числа a и b.

Гарантируется, что a не превосходит b.

Выходные данные Выведите все числа на отрезке от a до b, являющиеся полными квадратами.

Если таких чисел нет, то ничего выводить не нужно.

Примеры входные данные 1 1 выходные данные 1 входные данные 2 8 выходные данные 4 Заранее спасибо.

Saiaanowa 4 окт. 2020 г., 13:20:39 | 5 - 9 классы

Дано двузначное число?

Дано двузначное число.

Найдите число десятков в нем.

Входные данные Вводится двухзначное число.

Выходные данные Выведите ответ на задачу.

Akolesova2002 30 нояб. 2020 г., 01:46:11 | 5 - 9 классы

Дано натуральное число N?

Дано натуральное число N.

Напишите функцию (Pascal), вычисляющую сумму цифр числа N.

Входные данные

Задано единственное число N

Выходные данные

Необходимо вывести сумму цифр числа N.

Примеры

входные данные

12

выходные данные

3

ПРОГРАММА БЫЛА, НО ВВОДИЛ 12 И ВЫВОДИЛ ВМЕСТО 3, 0.

Вы перешли к вопросу Вася загадал число от 1 до N?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.