Задача №334?

Информатика | 5 - 9 классы

Задача №334.

Остаток Входные данные Вводятся 4 числа : a, b, c и d.

Выходные данные Выведите все числа на отрезке от a до b, дающие остаток c при делении на d.

Если таких чисел не существует, то ничего выводить не нужно.

Примеры входные данные 2 5 0 2 выходные данные 2 4 входные данные 2 7 9 14 выходные данные.

Ответить на вопрос
Ответы (1)
BeMkA26 29 мар. 2020 г., 08:01:22

Var

a, b, c, d, x : integer ;

begin

read(a, b, c, d) ;

for x : = a to b do

if x mod d = c then

write(x, ' ') ;

end.

Www1955 6 дек. 2020 г., 22:51:23 | 5 - 9 классы

Даны два натуральных числа n и m?

Даны два натуральных числа n и m.

Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число.

Входные данные Вводятся два числа.

Выходные данные Выведите ответ на задачу.

(Примеры : входные данные - 2, 8.

Выходные - 1).

P. S.

Решить надо в Паскаль АБЦ!

Halmetova2000 3 мар. 2020 г., 05:26:02 | 5 - 9 классы

Решить в Паскаль АБЦ?

Решить в Паскаль АБЦ!

Даны два натуральных числа n и m.

Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число.

"Входные данные" Вводятся два числа.

"Выходные данные" Выведите ответ на задачу.

(Примеры : входные - 2, 8.

Выходные - 1).

12345270 11 нояб. 2020 г., 17:01:29 | 5 - 9 классы

Написать на Паскале Остаток Входные данные Вводятся 4 числа : a, b, c и d?

Написать на Паскале Остаток Входные данные Вводятся 4 числа : a, b, c и d.

Выходные данные Выведите все числа на отрезке от a до b, дающие остаток c при делении на d.

Если таких чисел не существует, то ничего выводить не нужно.

Примеры входные данные 2 5 0 2 выходные данные 2 4 входные данные 2 7 9 14.

Ммутыл 16 нояб. 2020 г., 15:25:50 | 5 - 9 классы

ПРОШУ ПОМОГИТЕ ОЧЕНЬ СРОЧНО Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 < ; = x < ; = 30000)?

ПРОШУ ПОМОГИТЕ ОЧЕНЬ СРОЧНО Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 < ; = x < ; = 30000).

Входные данные Вводится натуральное число x.

Выходные данные Выведите наименьший делитель числа x, отличный от 1.

Примеры входные данные 2 выходные данные 2 входные данные 6 выходные данные 2.

Pishtshalnikova 12 янв. 2020 г., 05:54:27 | 10 - 11 классы

За день машина проезжает n километров?

За день машина проезжает n километров.

Сколько дней нужно, чтобы проехать маршрут длиной m километров?

При решении этой задачи нельзя пользоваться условной инструкцией if и циклами.

Входные данные Программа получает на вход числа n и m.

Выходные данные Выведите ответ на задачу.

Примеры входные данные 700 750 выходные данные 2 входные данные 700 2100 выходные данные 3.

Букава 5 июн. 2020 г., 07:46:55 | 5 - 9 классы

Входные данные Вводятся целые числа a и b?

Входные данные Вводятся целые числа a и b.

Гарантируется, что a не превосходит b.

Выходные данные Выведите все числа на отрезке от a до b, являющиеся полными квадратами.

Если таких чисел нет, то ничего выводить не нужно.

Примеры входные данные 1 1 выходные данные 1 входные данные 2 8 выходные данные 4 Заранее спасибо.

ХоРОшИСткАмбоу1 7 сент. 2020 г., 10:11:25 | 5 - 9 классы

Проверьте, есть ли среди данных N чисел нули?

Проверьте, есть ли среди данных N чисел нули.

Входные данные Вводится число N, а затем N чисел.

Выходные данные Выведите YES, если среди введенных чисел есть хотя бы один нуль, или NO в противном случае.

Примеры входные данные 3 4 19 14 выходные данные NOПроверьте, есть ли среди данных N чисел нули.

Входные данные Вводится число N, а затем N чисел.

Выходные данные Выведите YES, если среди введенных чисел есть хотя бы один нуль, или NO в противном случае.

Примеры входные данные 3 4 19 14 выходные данные NO Выполнять на python 3.

3 Очень нада.

Delkup 2 сент. 2020 г., 23:37:51 | 5 - 9 классы

Напишите программу, которая считывает два целых числа a и b и выводит наибольшее значение из них?

Напишите программу, которая считывает два целых числа a и b и выводит наибольшее значение из них.

Числа — целые от 1 до 1000.

При решении задачи можно пользоваться только целочисленными арифметическими операциями + , - , * , / / , %, = .

Нельзя пользоваться нелинейными конструкциями : ветвлениями, циклами, функциями вычисления модуля, извлечения квадратного корня.

Использование функции max запрещено!

Входные данные Вводятся два целых числа a и b.

Выходные данные Выведите ответ на задачу.

Примеры входные данные 8 5 выходные данные 8 входные данные 5 8 выходные данные 8 входные данные 5 5 выходные данные 5 Заранее спасибо.

: - ).

Викуляsv 12 янв. 2020 г., 08:29:06 | 5 - 9 классы

Входные данные Вводятся целые числа a и b?

Входные данные Вводятся целые числа a и b.

Гарантируется, что a не превосходит b.

Выходные данные Выведите все числа на отрезке от a до b, являющиеся полными квадратами.

Если таких чисел нет, то ничего выводить не нужно.

Примеры входные данные 1 1 выходные данные 1 входные данные 2 8 выходные данные 4 Заранее спасибо.

Saiaanowa 4 окт. 2020 г., 13:20:39 | 5 - 9 классы

Дано двузначное число?

Дано двузначное число.

Найдите число десятков в нем.

Входные данные Вводится двухзначное число.

Выходные данные Выведите ответ на задачу.

На этой странице находится вопрос Задача №334?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.