Входные данные Вводятся целые числа a и b?

Информатика | 5 - 9 классы

Входные данные Вводятся целые числа a и b.

Гарантируется, что a не превосходит b.

Выходные данные Выведите все числа на отрезке от a до b, являющиеся полными квадратами.

Если таких чисел нет, то ничего выводить не нужно.

Примеры входные данные 1 1 выходные данные 1 входные данные 2 8 выходные данные 4 Заранее спасибо.

Ответить на вопрос
Ответы (1)
Машакомарова1 5 июн. 2020 г., 07:46:57

Program kvadrat ;

uses crt ;

var i, a, b : longint ;

begin

write('a = ') ; readln(a) ;

write('b = ') ; readln(b) ;

for i : = a to b do if trunc(sqrt(i)) * trunc(sqrt(i)) = i then writeln(i) ;

end.

Аленка6666 12 февр. 2020 г., 11:23:57 | 5 - 9 классы

PascalВыведите все числа на отрезке от a до b, являющиеся полными квадратами?

Pascal

Выведите все числа на отрезке от a до b, являющиеся полными квадратами.

Примеры :

Входные данные

1

5

Выходные данные

1 4.

Halmetova2000 3 мар. 2020 г., 05:26:02 | 5 - 9 классы

Решить в Паскаль АБЦ?

Решить в Паскаль АБЦ!

Даны два натуральных числа n и m.

Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число.

"Входные данные" Вводятся два числа.

"Выходные данные" Выведите ответ на задачу.

(Примеры : входные - 2, 8.

Выходные - 1).

12345270 11 нояб. 2020 г., 17:01:29 | 5 - 9 классы

Написать на Паскале Остаток Входные данные Вводятся 4 числа : a, b, c и d?

Написать на Паскале Остаток Входные данные Вводятся 4 числа : a, b, c и d.

Выходные данные Выведите все числа на отрезке от a до b, дающие остаток c при делении на d.

Если таких чисел не существует, то ничего выводить не нужно.

Примеры входные данные 2 5 0 2 выходные данные 2 4 входные данные 2 7 9 14.

Ilililililil 19 окт. 2020 г., 06:29:49 | 5 - 9 классы

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ?

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ!

25баллов Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

Входные данные Задано единственное целое число N Выходные данные Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Примеры входные данные 15 выходные данные 1 4 9.

Irenaz 29 мар. 2020 г., 08:01:21 | 5 - 9 классы

Задача №334?

Задача №334.

Остаток Входные данные Вводятся 4 числа : a, b, c и d.

Выходные данные Выведите все числа на отрезке от a до b, дающие остаток c при делении на d.

Если таких чисел не существует, то ничего выводить не нужно.

Примеры входные данные 2 5 0 2 выходные данные 2 4 входные данные 2 7 9 14 выходные данные.

Данька83 4 февр. 2020 г., 09:02:50 | 5 - 9 классы

Программирование на C + + Входные данные Вводятся целые числа a и b?

Программирование на C + + Входные данные Вводятся целые числа a и b.

Гарантируется, что a не превосходит b.

Выходные данные Выведите все числа на отрезке от a до b, являющиеся полными квадратами.

Если таких чисел нет, то ничего выводить не нужно.

Yoana 18 апр. 2020 г., 07:29:21 | 5 - 9 классы

Помогите с программированием на C + + Входные данные Вводятся целые числа a и b?

Помогите с программированием на C + + Входные данные Вводятся целые числа a и b.

Гарантируется, что a не превосходит b Выходные данные Выведите (через пробел) все четные числа от a до b (включительно).

Delkup 2 сент. 2020 г., 23:37:51 | 5 - 9 классы

Напишите программу, которая считывает два целых числа a и b и выводит наибольшее значение из них?

Напишите программу, которая считывает два целых числа a и b и выводит наибольшее значение из них.

Числа — целые от 1 до 1000.

При решении задачи можно пользоваться только целочисленными арифметическими операциями + , - , * , / / , %, = .

Нельзя пользоваться нелинейными конструкциями : ветвлениями, циклами, функциями вычисления модуля, извлечения квадратного корня.

Использование функции max запрещено!

Входные данные Вводятся два целых числа a и b.

Выходные данные Выведите ответ на задачу.

Примеры входные данные 8 5 выходные данные 8 входные данные 5 8 выходные данные 8 входные данные 5 5 выходные данные 5 Заранее спасибо.

: - ).

Викуляsv 12 янв. 2020 г., 08:29:06 | 5 - 9 классы

Входные данные Вводятся целые числа a и b?

Входные данные Вводятся целые числа a и b.

Гарантируется, что a не превосходит b.

Выходные данные Выведите все числа на отрезке от a до b, являющиеся полными квадратами.

Если таких чисел нет, то ничего выводить не нужно.

Примеры входные данные 1 1 выходные данные 1 входные данные 2 8 выходные данные 4 Заранее спасибо.

Saiaanowa 4 окт. 2020 г., 13:20:39 | 5 - 9 классы

Дано двузначное число?

Дано двузначное число.

Найдите число десятков в нем.

Входные данные Вводится двухзначное число.

Выходные данные Выведите ответ на задачу.

На этой странице сайта вы найдете ответы на вопрос Входные данные Вводятся целые числа a и b?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.