Если введенное с клавиатуры число (не равное нулю) положительно вычислить его квадрат, а если отрицательно - умножить его на 2?

Информатика | 5 - 9 классы

Если введенное с клавиатуры число (не равное нулю) положительно вычислить его квадрат, а если отрицательно - умножить его на 2.

Ответить на вопрос
Ответы (1)
Markesh 25 нояб. 2020 г., 14:07:32

Var

a, b : Integer ;

Begin Writeln('Введите число - ') ; Readln(a) ; if(a> ; 0) then b : = a * a else if (a< ; 0) then b : = a * 2 ; Writeln('Ответ : ', b) ;

End.

Vibornova 16 мар. 2020 г., 18:39:46 | 5 - 9 классы

Написать программу, которая выводит сумму квадратов пяти целых положительных чисел Числа (как положительные, так и отрицательные) вводятся с клавиатуры?

Написать программу, которая выводит сумму квадратов пяти целых положительных чисел Числа (как положительные, так и отрицательные) вводятся с клавиатуры.

Димке 10 окт. 2020 г., 03:51:27 | 10 - 11 классы

Написать программу : c клавиатуры последовательно вводятся числа, пока не введут 0?

Написать программу : c клавиатуры последовательно вводятся числа, пока не введут 0.

Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.

Ketrin1rudenko 26 мая 2020 г., 06:46:44 | 10 - 11 классы

С клавиатуры вводится число n под корнем?

С клавиатуры вводится число n под корнем.

Если это число больше нуля, то найти его квадратные корни.

Если число отрицательное, то возвести его в квадрат.

Sweetkate1 16 июн. 2020 г., 08:12:55 | 5 - 9 классы

Найти произведение цифр целого положительного числа, введенного с клавиатуры?

Найти произведение цифр целого положительного числа, введенного с клавиатуры.

Rayhana2015 28 апр. 2020 г., 05:00:10 | 1 - 4 классы

Написать программу которая введенные с клавиатуры отрицательные числа удваивает и прибавляет 5 а положительные оставляет без изменения?

Написать программу которая введенные с клавиатуры отрицательные числа удваивает и прибавляет 5 а положительные оставляет без изменения.

BaNeK34 5 июл. 2020 г., 20:53:00 | 5 - 9 классы

Написать программу на алгоритмическом языке программирования для вычисления минимального отрицательного числа и максимального положительного числа из 15 чисел введенных с клавиатуры(Язык с + + )?

Написать программу на алгоритмическом языке программирования для вычисления минимального отрицательного числа и максимального положительного числа из 15 чисел введенных с клавиатуры(Язык с + + ).

2635112476 19 дек. 2020 г., 18:05:33 | 5 - 9 классы

Pascal ABCЗадача 1составить программу которая запрашивает целое число не равное нулю сообщает положительное они или отрицательное и при этом положительное число уменьшает в 2 раза, отрицательные возво?

Pascal ABC

Задача 1

составить программу которая запрашивает целое число не равное нулю сообщает положительное они или отрицательное и при этом положительное число уменьшает в 2 раза, отрицательные возводит в квадрат .

Задача 2

составить программу , которая определяет является ли введенное число нечетным и выводит на экран сообщение да или нет .

Pee006 15 июн. 2020 г., 00:10:56 | 5 - 9 классы

Среди n введенных с клавиатуры чисел, найти сумму положительных и произведение отрицательных чисел?

Среди n введенных с клавиатуры чисел, найти сумму положительных и произведение отрицательных чисел.

Aida201 1 авг. 2020 г., 15:23:32 | 5 - 9 классы

Как создать программу которая из трех чисел, введенных с клавиатуры, возводит в квадрат положительные, а отрицательные оставляет без изменения в паскале?

Как создать программу которая из трех чисел, введенных с клавиатуры, возводит в квадрат положительные, а отрицательные оставляет без изменения в паскале?

Sona10082000 7 июл. 2020 г., 09:39:03 | 5 - 9 классы

Напишите программу в Pascal , которая из трех введенных с клавиатуры чисел возводит в квадрат положительные, а отрицательные оставляет без изменения?

Напишите программу в Pascal , которая из трех введенных с клавиатуры чисел возводит в квадрат положительные, а отрицательные оставляет без изменения.

Если вам необходимо получить ответ на вопрос Если введенное с клавиатуры число (не равное нулю) положительно вычислить его квадрат, а если отрицательно - умножить его на 2?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.