Написать программу : c клавиатуры последовательно вводятся числа, пока не введут 0?

Информатика | 10 - 11 классы

Написать программу : c клавиатуры последовательно вводятся числа, пока не введут 0.

Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.

Ответить на вопрос
Ответы (1)
Шехватова 10 окт. 2020 г., 03:51:33

Var x, otrc, poloz : integer ;

begin

repeat

write('Введите число : ') ;

readln(x) ;

if x > ; 0 then inc(poloz) ;

if x < ; 0 then inc(otrc) ;

until x = 0 ;

writeln('Количество положительных чисел : ', poloz) ;

writeln('Количество отрицательных чисел : ', otrc) ;

end.

Zarechnev03 31 мая 2020 г., 23:07:23 | 10 - 11 классы

Вводить с клавиатуры 10 целых чисел, выдать на экран количество положительных чисел, количество отрицательных , количество нулевых?

Вводить с клавиатуры 10 целых чисел, выдать на экран количество положительных чисел, количество отрицательных , количество нулевых.

Ekaterina472 22 авг. 2020 г., 05:36:51 | 5 - 9 классы

С клавиатуры ввели 10 чисел положительных и отрицательных?

С клавиатуры ввели 10 чисел положительных и отрицательных.

Необходимо вывести на экран сумму всех положительных чисел.

Vibornova 16 мар. 2020 г., 18:39:46 | 5 - 9 классы

Написать программу, которая выводит сумму квадратов пяти целых положительных чисел Числа (как положительные, так и отрицательные) вводятся с клавиатуры?

Написать программу, которая выводит сумму квадратов пяти целых положительных чисел Числа (как положительные, так и отрицательные) вводятся с клавиатуры.

Tmiezhieninaru 30 сент. 2020 г., 23:43:56 | 5 - 9 классы

ЯЗЫК QBASIC ?

ЯЗЫК QBASIC !

Решите задачи, используя цикл while - wend 1.

Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры.

2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).

Витанка 8 окт. 2020 г., 13:52:58 | 10 - 11 классы

С клавиатуры вводятся целые числа?

С клавиатуры вводятся целые числа.

Признаком конца ввода чисел является 0.

Изменить знак отрицательных чисел на положительный.

Результаты вывести на экран.

Dasha999922 2 сент. 2020 г., 16:30:56 | 5 - 9 классы

Написать программу в паскаль?

Написать программу в паскаль.

Из всех двузначных чисел вывести на экран те из них, сумма цифр которых равна А.

(А вводится с клавиатуры).

Алияюнусовп03072006 22 янв. 2020 г., 21:12:55 | 5 - 9 классы

2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна)?

2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).

Танген 22 июл. 2020 г., 08:38:44 | 10 - 11 классы

С клавиатуры вводятся числа (положительные и отрицательные) и последовательно суммируются их модули?

С клавиатуры вводятся числа (положительные и отрицательные) и последовательно суммируются их модули.

Найти количество введенных чисел, когда их сумма превысила 100.

На языке Паскаль пожалуйста пожалуйста, срочно!

0004191487 12 апр. 2020 г., 10:33:31 | 10 - 11 классы

Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности не ограничена)?

Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности не ограничена).

Программа Delphi Заранее благодарю!

Alina0606 22 дек. 2020 г., 02:52:07 | 10 - 11 классы

С клавиатуры вводится некоторое количество положительных чисел, результатом конца ввода является любое отрицательное число?

С клавиатуры вводится некоторое количество положительных чисел, результатом конца ввода является любое отрицательное число.

Найти и вывести на экране все числа кратные 3.

На этой странице сайта вы найдете ответы на вопрос Написать программу : c клавиатуры последовательно вводятся числа, пока не введут 0?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.