Дан массив В размером 7 элементов, элементы вводятся с клавиатуры : а)найти произведение всех элементов массива б)заменить все положительные элементы на их кубы Помогите, пожалуйста, составить програм?

Информатика | 5 - 9 классы

Дан массив В размером 7 элементов, элементы вводятся с клавиатуры : а)найти произведение всех элементов массива б)заменить все положительные элементы на их кубы Помогите, пожалуйста, составить программы, на языке Паскаль.

Ответить на вопрос
Ответы (1)
Aleksiula047 2 окт. 2020 г., 20:22:16

/ / PascalABC.

NET 3.

1, сборка 1213 от 04.

04. 2016

begin var b : = ReadArrReal('Введите 7 чисел : ', 7) ; / / Первая задача Writeln('Их произведение равно ', b.

Aggregate(1.

0, (x, y) - > ; x * y)) ; / / Вторая задача b.

Select(x - > ; x> ; 0?

X * x * x : x).

Println

end.

Тестовое решение :

Введите 7 чисел : 3 - 5 2 4 - 2 - 3 1

Их произведение равно - 720

27 - 5 8 64 - 2 - 3 1.

Zenks 10 мар. 2020 г., 02:56:58 | 10 - 11 классы

Найди все четные по значению элементы массива?

Найди все четные по значению элементы массива.

Вывести на экран значение элементов и их индекс.

Ввод элементов массива с клавиатуры.

Программа пишется на языке Паскаль.

AlinaDoloman 21 янв. 2020 г., 06:28:16 | 5 - 9 классы

Массив из 10 элементов вводится с клавиатуры?

Массив из 10 элементов вводится с клавиатуры.

Составить программу расчёта среднего арифметического любых двух элементов массива (номера элементов вводятся с клавиатуры).

Кубишка 18 июл. 2020 г., 12:57:53 | 10 - 11 классы

В массиве подсчитать : сумму чётных элементов?

В массиве подсчитать : сумму чётных элементов.

(Элементов массива : 7.

Массив вводится с клавиатуры).

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

Vika19973 10 февр. 2020 г., 04:51:12 | 10 - 11 классы

Pascal ABC?

Pascal ABC.

Написать программу, которая находит сумму четных элементов массива произвольного размера (размер и элементы массива вводятся с клавиатуры).

Pretty36220 6 июл. 2020 г., 05:08:43 | 5 - 9 классы

Задача?

Задача.

Массив А вводится с клавиатуры.

Сформировать новый массив В , состоящий из положительных элементов массива А.

Размер произвольный.

Yytffed 16 окт. 2020 г., 13:57:24 | 10 - 11 классы

Информатика?

Информатика.

Массивы Массив A вводится с клавиатуры.

Сформировать новый массив B, состоящий из чётны элементов массива А.

Элементы вводятся с клавиатуры.

Размер произвольный.

Iri4241 22 авг. 2020 г., 20:03:43 | 10 - 11 классы

Помогите решить на паскале?

Помогите решить на паскале.

Дан массив, в котором 10 элементов, составить программу для вывода его элемента массива по его индексу.

Артур1254 10 окт. 2020 г., 22:10:16 | 5 - 9 классы

Написать программу на языке Паскаль, где пользователь вводит с клавиатуры 99 элементов массива, а программа рассчитывает сумму значений элементом при условии четности индекса элемента и значения этого?

Написать программу на языке Паскаль, где пользователь вводит с клавиатуры 99 элементов массива, а программа рассчитывает сумму значений элементом при условии четности индекса элемента и значения этого элемента.

Leopoldtv 13 нояб. 2020 г., 08:53:33 | 5 - 9 классы

Написать программу на языке Паскаль, где пользователь вводит с клавиатуры 99 элементов массива, а программа рассчитывает сумму значений элементом при условии четности индекса элемента и значения этого?

Написать программу на языке Паскаль, где пользователь вводит с клавиатуры 99 элементов массива, а программа рассчитывает сумму значений элементом при условии четности индекса элемента и значения этого элемента.

Вы зашли на страницу вопроса Дан массив В размером 7 элементов, элементы вводятся с клавиатуры : а)найти произведение всех элементов массива б)заменить все положительные элементы на их кубы Помогите, пожалуйста, составить програм?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.