Дан массив заданный случайным образом?

Информатика | 5 - 9 классы

Дан массив заданный случайным образом.

Найти s и p элементов, кратных 3 - ём и положительных, кол - во всех остальных.

Ответить на вопрос
Ответы (1)
Olga30032002 7 дек. 2020 г., 07:36:18

Const

n = 10 ;

var a : array[1.

N] of integer ;

s, p, k, i : integer ;

begin

s : = 0 ;

p : = 1 ;

randomize ;

for i : = 1 to n do begin

a[i] : = Random(100) ;

if (a[i]> ; 0) and (a[i] mod 3 = 0) then k : = k + 1 ;

p : = p * a[i] ;

s : = s + a[i] ;

write(a[i], ' ')

end ;

writeln('Сумма = ', s) ;

writeln('Произведение = ', p) ;

writeln('Количество положительных и кратных 3 - м = ', k) ;

end.

Jmjmjmjmj500 27 февр. 2020 г., 16:12:32 | 10 - 11 классы

Дан массив натуральных чисел ?

Дан массив натуральных чисел .

Найти сумму элементов , кратных заданному К.

Седдааа 7 апр. 2020 г., 01:01:43 | 5 - 9 классы

Дан массив состоящий из 10 элементов заполнить массив целых чисел найти сумму, количество элементов положительных и кратных три?

Дан массив состоящий из 10 элементов заполнить массив целых чисел найти сумму, количество элементов положительных и кратных три.

Polina1386 17 июн. 2020 г., 20:42:40 | 5 - 9 классы

Дан массив из 25 элементов, заполненный случайным образом, из указанного промежутка ( - 10 ; 10)?

Дан массив из 25 элементов, заполненный случайным образом, из указанного промежутка ( - 10 ; 10).

Найти а кол - во элементов кратных 3 и сумму положительных элементов.

Написать на паскале.

Sashulya20 15 апр. 2020 г., 18:20:05 | 5 - 9 классы

Дан массив натуральных чисел, заполненный случайными числами?

Дан массив натуральных чисел, заполненный случайными числами.

Найти произведение элементов кратных 3.

Fmak 8 апр. 2020 г., 21:04:44 | 5 - 9 классы

Задача на паскале?

Задача на паскале.

Задан массив А размерности N случайным образом.

Найти :

1) произведение отрицательных элементов

2) количество элементов, кратных 3.

Баха11 27 апр. 2020 г., 12:56:09 | 10 - 11 классы

Дан массив а(15), сформированный случайным образом на промежутке [ - 25 ; 45]?

Дан массив а(15), сформированный случайным образом на промежутке [ - 25 ; 45].

Найти сумму положительных элементов массива а.

Напишите программу на паскале.

Lo19 17 февр. 2020 г., 05:41:49 | 10 - 11 классы

Дан массив целых чисел (n = 30), зап?

Дан массив целых чисел (n = 30), зап.

Случайным образом числами из пром - ка [ - 20 ; 60] : 1)найти удвоенную сумму положительных элементов массива ; 2)найти сумму положительных элементов, кратных 3.

Tyncherova 8 нояб. 2020 г., 09:00:35 | 5 - 9 классы

Дан массив А(15)?

Дан массив А(15).

Его элементы задаются случайным образом от - 35 до 50.

Найти сумму и среднее значение отрицательных эл - тов, сумму и кол - во положительных эл - тов.

Решить всё в паскале.

Kisakissa 21 сент. 2020 г., 22:51:59 | 5 - 9 классы

Дан массив, заданный датчиком случайных чисел в интервале [ - 100 ; 170]?

Дан массив, заданный датчиком случайных чисел в интервале [ - 100 ; 170].

Найдите все положительные элементы массива, среди положительных значений найти наименьшее.

ХЕЛЬП.

Nikolyanikitin 2 февр. 2020 г., 16:36:16 | 5 - 9 классы

Срочно?

Срочно!

1. Дан массив, состоящий из 15 элементов.

Элементы вводятся случайным образом.

Найти количество элементов, кратных 3.

(промежуток от 10 до 30) 2.

Дан массив, состоящий из 10 элементов.

Элементы вводятся случайным образом из промежутка от [ - 10, + 10].

Найти количество элементов, которые четны и положительны {используем в условии связку и = and} в виде программы для Паскаля!

На этой странице находится вопрос Дан массив заданный случайным образом?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.