Дан массив А(15)?

Информатика | 5 - 9 классы

Дан массив А(15).

Его элементы задаются случайным образом от - 35 до 50.

Найти сумму и среднее значение отрицательных эл - тов, сумму и кол - во положительных эл - тов.

Решить всё в паскале.

Ответить на вопрос
Ответы (1)
Klevan 8 нояб. 2020 г., 09:00:42

/ / PascalABC.

NET 3.

1, сборка 1250 от 28.

05. 2016

begin var a : = ArrRandom(15, - 35, 50) ; a.

Println ; Writeln('Сумма отр.

= ', a.

Where(x - > ; x< ; 0).

Sum, ', ср.

Арифм.

Отр = ', a.

Where(x - > ; x< ; 0).

Average : 0 : 5) ; Writeln('Сумма пол.

= ', a.

Where(x - > ; x> ; 0).

Sum, ', кол - во пол.

= ', a.

Where(x - > ; x< ; 0).

Count)

end.

Тестовое решение

13 9 18 - 29 - 33 7 41 - 15 - 2 10 7 - 32 13 16 - 1

Сумма отр.

= - 112, ср.

Арифм.

Отр = - 18.

66667

Сумма пол.

= 134, кол - во пол.

= 6.

Jorjiya 21 дек. 2020 г., 13:54:33 | 10 - 11 классы

Даны 5 чисел, найти сумму и кол - во положительных и произведение и кол - во отрицательных?

Даны 5 чисел, найти сумму и кол - во положительных и произведение и кол - во отрицательных.

Polina1386 17 июн. 2020 г., 20:42:40 | 5 - 9 классы

Дан массив из 25 элементов, заполненный случайным образом, из указанного промежутка ( - 10 ; 10)?

Дан массив из 25 элементов, заполненный случайным образом, из указанного промежутка ( - 10 ; 10).

Найти а кол - во элементов кратных 3 и сумму положительных элементов.

Написать на паскале.

АрПлон 5 апр. 2020 г., 19:49:59 | 5 - 9 классы

Заполнить массив положительными и отрицательными числами на интервале от - 40 до 40 и найти сумму отрицательных чисел, случайным элементом под элементом 25?

Заполнить массив положительными и отрицательными числами на интервале от - 40 до 40 и найти сумму отрицательных чисел, случайным элементом под элементом 25.

Ммм000 24 сент. 2020 г., 15:14:27 | 5 - 9 классы

Дан одномерный массив А из 12 - ти элементов?

Дан одномерный массив А из 12 - ти элементов.

Найти суммы отрицательных элементов и суммы положительных элементов.

Fmak 8 апр. 2020 г., 21:04:44 | 5 - 9 классы

Задача на паскале?

Задача на паскале.

Задан массив А размерности N случайным образом.

Найти :

1) произведение отрицательных элементов

2) количество элементов, кратных 3.

Ksana1051 29 янв. 2020 г., 11:47:00 | 5 - 9 классы

Заполнить массив случайным образом и вывести на экран сумму нечетных элементов?

Заполнить массив случайным образом и вывести на экран сумму нечетных элементов.

В паскале).

Баха11 27 апр. 2020 г., 12:56:09 | 10 - 11 классы

Дан массив а(15), сформированный случайным образом на промежутке [ - 25 ; 45]?

Дан массив а(15), сформированный случайным образом на промежутке [ - 25 ; 45].

Найти сумму положительных элементов массива а.

Напишите программу на паскале.

Vika9501 7 дек. 2020 г., 07:36:14 | 5 - 9 классы

Дан массив заданный случайным образом?

Дан массив заданный случайным образом.

Найти s и p элементов, кратных 3 - ём и положительных, кол - во всех остальных.

G5р 7 окт. 2020 г., 15:21:24 | 10 - 11 классы

Дан двумерный массив 10х10, содержащий числа в интервале от - 10 до 10?

Дан двумерный массив 10х10, содержащий числа в интервале от - 10 до 10.

Вычислить отдельно сумму положительных и сумму отрицательных элементов.

Паскаль.

Karineasatryanka 31 авг. 2020 г., 03:26:15 | 10 - 11 классы

Для массива из 10 элементов (задан случайным образом на отрезке от - 10 до 10) найти сумму отрицательных по значению элементов, стоящих на нечетных местах?

Для массива из 10 элементов (задан случайным образом на отрезке от - 10 до 10) найти сумму отрицательных по значению элементов, стоящих на нечетных местах.

( Quick basic).

На этой странице сайта вы найдете ответы на вопрос Дан массив А(15)?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.