Дан массив из 25 элементов, заполненный случайным образом, из указанного промежутка ( - 10 ; 10)?

Информатика | 5 - 9 классы

Дан массив из 25 элементов, заполненный случайным образом, из указанного промежутка ( - 10 ; 10).

Найти а кол - во элементов кратных 3 и сумму положительных элементов.

Написать на паскале.

Ответить на вопрос
Ответы (1)
АнастасияЧудакова 17 июн. 2020 г., 20:42:44

Var a : array[1.

20]of integer ; i, s, k : integer ;

begin

write('massiv : ') ;

for i : = 1 to 20 do begin a[i] : = random(21) - 10 ; write(a[i], ' ') ; end ;

writeln ;

for i : = 1 to 20 do begin if a[i] mod 2 = 1 then k : = k + 1 ; if a[i]> ; 0 then s : = s + a[i] ; end ;

write('kratnih trem : ', k, ' summa polozhit : ', s) ;

end.

Ніка2015 4 апр. 2020 г., 06:42:29 | 10 - 11 классы

Дан массив целых чисел из 15 элементов, заполненный случайным образом числами из промежутка [ - 20, 50 ]?

Дан массив целых чисел из 15 элементов, заполненный случайным образом числами из промежутка [ - 20, 50 ].

Удалить из него все элементы, в записи которых есть цифра 5.

Вставить число k после всех элементов, кратных своему номеру (k вводится с клавиатуры).

Поменять местами первый положительный и последний отрицательный элементы.

Седдааа 7 апр. 2020 г., 01:01:43 | 5 - 9 классы

Дан массив состоящий из 10 элементов заполнить массив целых чисел найти сумму, количество элементов положительных и кратных три?

Дан массив состоящий из 10 элементов заполнить массив целых чисел найти сумму, количество элементов положительных и кратных три.

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

Sashulya20 15 апр. 2020 г., 18:20:05 | 5 - 9 классы

Дан массив натуральных чисел, заполненный случайными числами?

Дан массив натуральных чисел, заполненный случайными числами.

Найти произведение элементов кратных 3.

Баха11 27 апр. 2020 г., 12:56:09 | 10 - 11 классы

Дан массив а(15), сформированный случайным образом на промежутке [ - 25 ; 45]?

Дан массив а(15), сформированный случайным образом на промежутке [ - 25 ; 45].

Найти сумму положительных элементов массива а.

Напишите программу на паскале.

Lo19 17 февр. 2020 г., 05:41:49 | 10 - 11 классы

Дан массив целых чисел (n = 30), зап?

Дан массив целых чисел (n = 30), зап.

Случайным образом числами из пром - ка [ - 20 ; 60] : 1)найти удвоенную сумму положительных элементов массива ; 2)найти сумму положительных элементов, кратных 3.

Vika9501 7 дек. 2020 г., 07:36:14 | 5 - 9 классы

Дан массив заданный случайным образом?

Дан массив заданный случайным образом.

Найти s и p элементов, кратных 3 - ём и положительных, кол - во всех остальных.

Tyncherova 8 нояб. 2020 г., 09:00:35 | 5 - 9 классы

Дан массив А(15)?

Дан массив А(15).

Его элементы задаются случайным образом от - 35 до 50.

Найти сумму и среднее значение отрицательных эл - тов, сумму и кол - во положительных эл - тов.

Решить всё в паскале.

DianaKrav4enko 28 июл. 2020 г., 10:32:45 | 10 - 11 классы

Дан массив целых чисел (n = 25), заполненный случайным образом числами из промежутка [ - 10, 50] : 1) заменить максимальный элемент массива на среднее арифметическое значение этого массива ; 2) найти ?

Дан массив целых чисел (n = 25), заполненный случайным образом числами из промежутка [ - 10, 50] : 1) заменить максимальный элемент массива на среднее арифметическое значение этого массива ; 2) найти сумму положительных элементов, кратных 7.

Nikolyanikitin 2 февр. 2020 г., 16:36:16 | 5 - 9 классы

Срочно?

Срочно!

1. Дан массив, состоящий из 15 элементов.

Элементы вводятся случайным образом.

Найти количество элементов, кратных 3.

(промежуток от 10 до 30) 2.

Дан массив, состоящий из 10 элементов.

Элементы вводятся случайным образом из промежутка от [ - 10, + 10].

Найти количество элементов, которые четны и положительны {используем в условии связку и = and} в виде программы для Паскаля!

Вопрос Дан массив из 25 элементов, заполненный случайным образом, из указанного промежутка ( - 10 ; 10)?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.