Дан массив целых чисел (n = 30), зап?

Информатика | 10 - 11 классы

Дан массив целых чисел (n = 30), зап.

Случайным образом числами из пром - ка [ - 20 ; 60] : 1)найти удвоенную сумму положительных элементов массива ; 2)найти сумму положительных элементов, кратных 3.

Ответить на вопрос
Ответы (1)
Марьям42 17 февр. 2020 г., 05:41:51

/ / PascalABC.

NET 3.

1, сборка 1230 от 27.

04. 2016

begin var a : = ArrRandom(30, - 20, 60) ; a.

Println ; Writeln('Удвоенная сумма положительных ', (a.

Where(x - > ; x> ; 0).

Sum) * 2) ; Writeln('Сумма положительных, кратных 3 : ', a.

Where(x - > ; (x> ; 0) and (x mod 3 = 0)).

Sum)

end.

Тестовое решение

33 12 - 14 - 13 - 13 49 - 16 60 6 0 37 - 6 - 5 - 5 31 52 49 9 30 - 13 23 42 9 49 - 7 42 50 44 48 30

Удвоенная сумма положительных 1410

Сумма положительных, кратных 3 : 321.

Седдааа 7 апр. 2020 г., 01:01:43 | 5 - 9 классы

Дан массив состоящий из 10 элементов заполнить массив целых чисел найти сумму, количество элементов положительных и кратных три?

Дан массив состоящий из 10 элементов заполнить массив целых чисел найти сумму, количество элементов положительных и кратных три.

Aleksey2123 3 апр. 2020 г., 17:23:28 | 10 - 11 классы

В МАССИВЕ ИЗ 10 НАЙТИ СУММУ ПОЛОЖИТЕЛЬНЫХ ЧИСЕЛ, ОКАНЧИВАЮЩИХСЯ НА 4 ЭЛЕМЕНТЫ МАССИВА ЦЕЛЫЕ ЧИСЛА?

В МАССИВЕ ИЗ 10 НАЙТИ СУММУ ПОЛОЖИТЕЛЬНЫХ ЧИСЕЛ, ОКАНЧИВАЮЩИХСЯ НА 4 ЭЛЕМЕНТЫ МАССИВА ЦЕЛЫЕ ЧИСЛА.

5даг05 26 июл. 2020 г., 00:38:29 | 10 - 11 классы

Help?

Help!

Дан массив целых чисел, состоящий из 10 элементов.

Заполнить его с клавиатуры.

Найти : - Удвоенную сумму положительных элементов ; - Удалить все четные элементы массива.

Ntoniy10 30 мар. 2020 г., 04:29:04 | 10 - 11 классы

Дан массив целых чисел, состоящий из 10 элементов?

Дан массив целых чисел, состоящий из 10 элементов.

Заполнить его с клавиатуры.

Найти : - Удвоенную сумму положительных элементов ; - Вывести значения тех элементов, которые меньше заданного числа А кратны 3.

Odinokij2001 29 мая 2020 г., 12:37:44 | 5 - 9 классы

СРОЧНО?

СРОЧНО!

Дан цело численный массив .

Найти : КАЖДУЮ ОТДЕЛЬНО!

А) удвоенную сумму положительных элементов б)Коол - во элементов массива , значения которых больше заданного числа А(А - Склавиатуры) в)Кол - во тех элементов, значения которых положительны и не превосходят данного числа А (А - Склавиатуры).

23420 14 апр. 2020 г., 17:10:34 | 10 - 11 классы

Дан массив A (20) заполнить его случайными целыми числами из [ - 10 ; 20] вывести на экран найти минимальный элементы массива и сумму положительных чисел?

Дан массив A (20) заполнить его случайными целыми числами из [ - 10 ; 20] вывести на экран найти минимальный элементы массива и сумму положительных чисел.

Pinirob 14 дек. 2020 г., 08:01:44 | 10 - 11 классы

Сформировать одномерный массив из 10 целых элементов?

Сформировать одномерный массив из 10 целых элементов.

Найти сумму положительных и четных элементов массива.

Баха11 27 апр. 2020 г., 12:56:09 | 10 - 11 классы

Дан массив а(15), сформированный случайным образом на промежутке [ - 25 ; 45]?

Дан массив а(15), сформированный случайным образом на промежутке [ - 25 ; 45].

Найти сумму положительных элементов массива а.

Напишите программу на паскале.

DianaKrav4enko 28 июл. 2020 г., 10:32:45 | 10 - 11 классы

Дан массив целых чисел (n = 25), заполненный случайным образом числами из промежутка [ - 10, 50] : 1) заменить максимальный элемент массива на среднее арифметическое значение этого массива ; 2) найти ?

Дан массив целых чисел (n = 25), заполненный случайным образом числами из промежутка [ - 10, 50] : 1) заменить максимальный элемент массива на среднее арифметическое значение этого массива ; 2) найти сумму положительных элементов, кратных 7.

ZxDenxz225 4 февр. 2020 г., 10:24:08 | 10 - 11 классы

Дан массив целых чисел из 17 элементов?

Дан массив целых чисел из 17 элементов.

Определить частное от деления суммы положительных элементов массива на модуль суммы отрицательных элементов.

Вы зашли на страницу вопроса Дан массив целых чисел (n = 30), зап?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.