Написать программу в которой задано целое число n и выводится каждая его цифра в столбец?

Информатика | 5 - 9 классы

Написать программу в которой задано целое число n и выводится каждая его цифра в столбец.

На ABC.

Pascal.

Ответить на вопрос
Ответы (1)
Katyusha00 13 июн. 2020 г., 10:19:17

Var n, k : integer ;

begin

write('n = ') ; readln(n) ;

while n< ; > ; 0 do

begin

writeln(n mod 10) ;

n : = n div 10 ;

end ;

end.

Пример :

n = 12756

6

5

7

2

1.

ВладиславКуцак 1 апр. 2020 г., 20:19:44 | 10 - 11 классы

Pascal написать программу которая выводит все делители числа число вводится пользователем?

Pascal написать программу которая выводит все делители числа число вводится пользователем.

Aksimovich1986 20 авг. 2020 г., 12:43:30 | 5 - 9 классы

Найдите количество чётных цифр заданного числа по программе pascal?

Найдите количество чётных цифр заданного числа по программе pascal.

Winterbottom 13 июн. 2020 г., 22:55:51 | 5 - 9 классы

Дано целое число N?

Дано целое число N.

Составить программу нахождения количества цифр числа (Pascal ABC).

Evelinakotova 27 окт. 2020 г., 12:03:08 | 5 - 9 классы

Типы данных, условный оператор, операторы ввода / вывода, написать программу сложения 3 цифр, которые будут вводиться с клавиатуры?

Типы данных, условный оператор, операторы ввода / вывода, написать программу сложения 3 цифр, которые будут вводиться с клавиатуры.

(pascal abc).

SofArkadiu 12 нояб. 2020 г., 19:12:02 | 5 - 9 классы

PASCAL ABC, программа?

PASCAL ABC, программа!

Вводится целое положительное число.

Найти наименьшую нечетную цифру в числе.

Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр".

Sabrinakotsk1 27 сент. 2020 г., 00:02:27 | 5 - 9 классы

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC?

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу, которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.

Chernyshovaali 19 сент. 2020 г., 15:44:36 | 5 - 9 классы

Как на Pascal ABC написать программу, которая будет считать сумму цифр в числе, введенного с клавиатуры?

Как на Pascal ABC написать программу, которая будет считать сумму цифр в числе, введенного с клавиатуры?

Количество цифр в числе не известно!

Число целочисленное!

Желательно с объяснениями ( вне программы ).

Заранее спасибо!

Ivanushun12345 2 июл. 2020 г., 12:04:02 | 5 - 9 классы

Pascal ABC?

Pascal ABC.

Дано натуральное число "n".

Составьте программу которая выводит максимальную цифру этого числа.

Жранкель 28 февр. 2020 г., 01:03:04 | 5 - 9 классы

Составьте программу (в Pascal ABC), которая выводит на экран дату в рамке ?

Составьте программу (в Pascal ABC), которая выводит на экран дату в рамке :

Vksolopova 6 мар. 2020 г., 16:16:29 | 10 - 11 классы

Даны два целых двузначных числа?

Даны два целых двузначных числа.

Верное ли, что все цифры первого числа больше соответствующих цифр второго числа?

Написать программу для Pascal.

Вопрос Написать программу в которой задано целое число n и выводится каждая его цифра в столбец?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.