Как на Pascal ABC написать программу, которая будет считать сумму цифр в числе, введенного с клавиатуры?

Информатика | 5 - 9 классы

Как на Pascal ABC написать программу, которая будет считать сумму цифр в числе, введенного с клавиатуры?

Количество цифр в числе не известно!

Число целочисленное!

Желательно с объяснениями ( вне программы ).

Заранее спасибо!

Ответить на вопрос
Ответы (1)
Smersh1116 19 сент. 2020 г., 15:44:41

Var a, b, c, d : integer ;

begin

writeln('введите число') ; / / запрос числа

readln(a) ;

d : = a ; / / это для красоты

while (a< ; > ; 0) do begin / / пока мы не дойдём до последней цифры в числе делать следующее b : = a mod 10 ; / / берём последнюю цифру числа

c : = c + b ; / / находим сумму цифр a : = a div 10 ; / / убираем из данного числа последнюю цифру end ;

writeln('сумма цифр числа ', d, ' = ', c) ; / / вывод результата

end.

Ramazanovrifat 23 июн. 2020 г., 12:39:58 | 5 - 9 классы

Напишите программу, которая вычисляет сумму цифр введенного двухзначного числа?

Напишите программу, которая вычисляет сумму цифр введенного двухзначного числа.

(Pascal).

Live96 12 февр. 2020 г., 23:57:43 | 10 - 11 классы

Напишите программу, которая считает сумму цифр введенного числа(паскаль)?

Напишите программу, которая считает сумму цифр введенного числа(паскаль).

Izavov88 12 окт. 2020 г., 23:48:38 | 10 - 11 классы

Напишите программу, которая считает количество четных цифр введенного числа?

Напишите программу, которая считает количество четных цифр введенного числа.

Jyliakirillova 19 дек. 2020 г., 10:54:31 | 5 - 9 классы

Составьте программу для вычисления суммы цифр введенного с клавиатуры трехзначного натурального числа?

Составьте программу для вычисления суммы цифр введенного с клавиатуры трехзначного натурального числа.

Керим1 11 авг. 2020 г., 21:30:24 | 10 - 11 классы

Написать программу которая выводит все двузначные числа у которых сумма цифр равна числу введенных с клавиатуры?

Написать программу которая выводит все двузначные числа у которых сумма цифр равна числу введенных с клавиатуры.

Harper2307 3 мая 2020 г., 15:21:01 | 5 - 9 классы

Напишите программу которая считает количество четных цифр введенного числа в паскале?

Напишите программу которая считает количество четных цифр введенного числа в паскале.

Maxim887 11 нояб. 2020 г., 06:39:03 | 5 - 9 классы

Написать программу для Pascal?

Написать программу для Pascal.

Найти произведение цифр числа введенного с клавиатуры.

Skajaz504 18 дек. 2020 г., 12:27:37 | 5 - 9 классы

Составить программу определяющую сумму цифр во введенном с клавиатуры целом числе?

Составить программу определяющую сумму цифр во введенном с клавиатуры целом числе.

Kenzzo 24 нояб. 2020 г., 17:16:23 | 5 - 9 классы

Написать программу которая считает количество цифр в числе и их сумму?

Написать программу которая считает количество цифр в числе и их сумму.

Паскаль.

Число вводится с клавиатуры.

Super39 6 дек. 2020 г., 11:45:46 | 5 - 9 классы

Напишите программу, которая считает сумму цифр введенного числа(c + + )?

Напишите программу, которая считает сумму цифр введенного числа(c + + ).

Вы перешли к вопросу Как на Pascal ABC написать программу, которая будет считать сумму цифр в числе, введенного с клавиатуры?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.