Заполнить массив случайными числами (положительными и отрицательными) из произвольного диапазона?

Информатика | 10 - 11 классы

Заполнить массив случайными числами (положительными и отрицательными) из произвольного диапазона.

Вывести созданный массив на экран, расположив элементы в одну строку через пробелы.

Заменить все отрицательные элементы квадратом соответствующего индекса.

Ответить на вопрос
Ответы (1)
Natalipak75 3 мая 2020 г., 09:12:04

Var

i : integer ;

a : array [1.

10] of real ;

begin

randomize ;

for i : = 1 to 10 do

a[i] : = random(10, - 10) ;

writeln('Случайно сгенерированные

числа : ') ;

for i : = 1 to 10 do

write(a[i], ' ') ;

for i : = 1 to 10 do

if a[i]< ; 0 then a[i] : = a[i] * a[i] ;

writeln() ;

writeln() ;

writeln('Отрицательные эл.

Массива возведены в квадрат : ') ;

for i : = 1 to 10 do

write(a[i], ' ') ;

end.

Тестовое решение :

Kiborg37 21 апр. 2020 г., 07:15:44 | 10 - 11 классы

Заполнить массив случайными числами (положительными и отрицательными) из произвольного диапазона?

Заполнить массив случайными числами (положительными и отрицательными) из произвольного диапазона.

Вывести созданный массив на экран, расположив элементы в одну строку через пробелы.

Посчитать общее количество элементов, кратных 3 и нечетных элементов и вывести на экран.

Olegolegru 5 янв. 2020 г., 20:30:44 | 10 - 11 классы

Заполнить массив случайными числами из интервала [ - 50 ; 50] , вывести массив на экран, посчитать сумму отрицательных элементов?

Заполнить массив случайными числами из интервала [ - 50 ; 50] , вывести массив на экран, посчитать сумму отрицательных элементов.

АрПлон 5 апр. 2020 г., 19:49:59 | 5 - 9 классы

Заполнить массив положительными и отрицательными числами на интервале от - 40 до 40 и найти сумму отрицательных чисел, случайным элементом под элементом 25?

Заполнить массив положительными и отрицательными числами на интервале от - 40 до 40 и найти сумму отрицательных чисел, случайным элементом под элементом 25.

Vovik200321 22 апр. 2020 г., 08:27:34 | 10 - 11 классы

(пожалуйста помогите ) заполнить массив из 12 элементов случайными числами от - 20 до 10?

(пожалуйста помогите ) заполнить массив из 12 элементов случайными числами от - 20 до 10.

Вынести индексы отрицательных элементов.

МаксимШевкунов2004 18 нояб. 2020 г., 09:05:52 | 10 - 11 классы

1. Заполнить массив с клавиатуры целыми числами?

1. Заполнить массив с клавиатуры целыми числами.

Вывести элементы этого массива на экран.

(Добавить комментарии) 2.

Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса).

3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива.

4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных.

5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных.

6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами.

Вывести на экран исходный и новый массив.

7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы.

8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Tusha06 28 июн. 2020 г., 17:36:54 | 5 - 9 классы

Помогите, пожалуйста, СРОЧНО?

Помогите, пожалуйста, СРОЧНО!

Составить программу : Заполнить массив из 10 элементов с клавиатуры целыми положительными и отрицательными числами и вывести на экран в строчку только отрицательные числа.

Helz 21 июл. 2020 г., 13:49:40 | 10 - 11 классы

Дан массив из 50 чисел?

Дан массив из 50 чисел.

Заполните его случайными числами.

Вывести на экран сначала все положительные его элементы, а затем все отрицательные.

Dianchik112 1 нояб. 2020 г., 23:34:11 | 10 - 11 классы

Задайте массив из 10 элементов с помощью датчика случайных чисел?

Задайте массив из 10 элементов с помощью датчика случайных чисел.

Замените все отрицательные элементы на наименьший положительный.

Выведите на экран исходный и полученный массив.

Klublena2011 27 июн. 2020 г., 01:58:52 | 5 - 9 классы

Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран?

Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран.

1) подсчитать количество элементов в массиве, значения которых больше 3.

2) найти сумму всех отрицательных элементов массива.

3) заменить все отрицательные элементы массива их индексами.

Вывести новый массив на экран

4)найти максимальный элемент.

Александр19833891 9 апр. 2020 г., 02:33:53 | 5 - 9 классы

1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N?

1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N.

Отрицательные элементы заменить на N.

Измененный массив вывести на экран одной строкой.

2. Дан одномерный массив размерностью N, заполненный случайными числами в интервале от - 15 до 20.

Вывести на экран значения элементов массива, абсолютное значение которых > ; 10.

3. Дан одномерный массив размерностью N, заполненный случайными числами.

Каждый третий элемент массива возвести в квадрат, если элемент отрицательный.

Измененный массив вывести на экран.

На этой странице сайта размещен вопрос Заполнить массив случайными числами (положительными и отрицательными) из произвольного диапазона? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.