Вычислить среднее арифметическое отрицательных элементов вектора Q(21) p?

Информатика | 5 - 9 классы

Вычислить среднее арифметическое отрицательных элементов вектора Q(21) p.

S. через программу паскаль.

Ответить на вопрос
Ответы (1)
Martsev93 28 дек. 2020 г., 14:51:38

Const n = 21 ;

var q : array[1.

N] of integer ;

i, s, k : integer ;

begin

Randomize ;

for i : = 1 to n do

begin

q[i] : = random(51) - 10 ;

write(q[i] : 4) ;

end ;

writeln ;

k : = 0 ; s : = 0 ;

for i : = 1 to n do

if q[i]< ; 0 then begin s : = s + q[i] ; k : = k + 1 ; end ;

writeln('Среднее арифметическое отрицательных элементов = ', s / k) ;

end.

Пример : 16 - 1 - 7 5 13 11 - 2 - 10 36 19 3 34 23 29 12 28 9 39 33 16 - 6

Среднее арифметическое отрицательных элементов = - 5.

2.

Ivanivanov2014 24 нояб. 2020 г., 06:14:16 | 10 - 11 классы

Разработать паскаль - программу, вычисляющую среднее арифметическое элементов матрицы?

Разработать паскаль - программу, вычисляющую среднее арифметическое элементов матрицы.

Камла 25 мар. 2020 г., 22:04:47 | 10 - 11 классы

Составьте программу вычисления среднего арифметического отрицательных элементов массива?

Составьте программу вычисления среднего арифметического отрицательных элементов массива.

Заранее спасибо!

RotterDam 13 нояб. 2020 г., 18:48:23 | 10 - 11 классы

Ребята, девчата, тут такое затруднение?

Ребята, девчата, тут такое затруднение.

Нужна программа в паскале, только в паскале.

Условие :

Напишите программу которая вычисляет среднее арифметическое элементов таблицы А(3 * 8) .

Программа по двумерным массивам.

Marusialu 26 мар. 2020 г., 16:18:25 | 5 - 9 классы

Программа КуМир (НЕ ПАСКАЛЬ?

Программа КуМир (НЕ ПАСКАЛЬ!

КуМир!

РУССКАЯ ПРОГРАММА!

)Ввести с клавиатуры массив из 5 элементов, найти среднее арифметическое всех элементов массива.

Naka1tana 24 янв. 2020 г., 06:14:34 | 10 - 11 классы

Составить программу для нахождения среднего арифметического n элемента (паскаль)?

Составить программу для нахождения среднего арифметического n элемента (паскаль).

Olga197733 5 июн. 2020 г., 13:17:01 | 5 - 9 классы

Составьте программу вычисления среднего арифметического отрицательных элементов?

Составьте программу вычисления среднего арифметического отрицательных элементов.

Катеринка3585 11 июл. 2020 г., 02:16:45 | 5 - 9 классы

Найти среднее арифметическое отрицательных элементов массива в Паскале?

Найти среднее арифметическое отрицательных элементов массива в Паскале.

Распишите пожалуйста.

Lob2004 10 янв. 2020 г., 04:47:43 | 10 - 11 классы

Написать программы в паскале : 1?

Написать программы в паскале : 1.

Найти среднее арифметическое положительных элементов.

2. Вычислить сумму элементов, расположенных после максимального элемента.

3. Найти произведение элементов, расположенных до минимального элемента.

4. Заменить все отрицательные элементы их моделями.

Так же надо использовать массив.

AnnaR2011 17 мар. 2020 г., 20:00:07 | 10 - 11 классы

Вычислить среднее арифметическое отрицательных элементов выше главной и ниже побочной диагонали?

Вычислить среднее арифметическое отрицательных элементов выше главной и ниже побочной диагонали.

Денис333337 13 сент. 2020 г., 17:12:06 | 10 - 11 классы

Помогите пожалуйста, я должна написать 6 лабораторных работ((?

Помогите пожалуйста, я должна написать 6 лабораторных работ((.

Написать программу на Паскале.

Дана матрица.

Вычислить среднее арифметическое четных элементов главной диагонали.

Если вам необходимо получить ответ на вопрос Вычислить среднее арифметическое отрицательных элементов вектора Q(21) p?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.