Дана вещественная квадратная матрица А порядка n?

Информатика | 10 - 11 классы

Дана вещественная квадратная матрица А порядка n.

Найти среднее арифметическое среди положительных элементов матрицы, находящихся на главной и побочной диагоналях.

Выдать сообщение, если таких элементов нет.

Ответить на вопрос
Ответы (1)
Vikavikusya1 7 мая 2020 г., 22:38:17

VAR ans : Real ; n, i, j, kol : Integer ; a : Array of Array of Real ;

BEGIN Read(n) ; SetLength(a, n + 1) ; For i : = 1 to n do SetLength(a[i], n + 1) ; For i : = 1 to n do For j : = 1 to n do Read(a[i][j]) ; For i : = 1 to n do If (a[i][i] > ; 0) then begin Inc(kol) ; ans : = ans + a[i][i] ; End ; If (kol > ; 0) then begin Writeln('Ср.

Ар. с гл.

Диагонали = ', ans / kol) ; kol : = 0 ; ans : = 0 ; End Else Writeln('Элементов > ; 0 на гл.

Диагонали - нет !

') ; For i : = 1 to n do If (a[i][n - i + 1] > ; 0) then begin Inc(kol) ; ans : = ans + a[i][n - i + 1] ; End ; If (kol > ; 0) then Writeln('Ср.

Ар. с поб.

Диагонали = ', ans / kol) Else Writeln('Элементов > ; 0 на поб.

Диагонали - нет !

') ;

END.

Polinadudiy 4 июн. 2020 г., 02:46:07 | 10 - 11 классы

Дана вещественная квадратная матрица А, размерностью n * n?

Дана вещественная квадратная матрица А, размерностью n * n.

Найти сумму элементов матрицы, расположенных под главной диагональю.

Snezhana250603 28 нояб. 2020 г., 02:59:38 | 5 - 9 классы

23. Дана действительная квадратная матрица порядка n?

23. Дана действительная квадратная матрица порядка n.

Выяснить, верно ли, что наибольшее из значений элементов главной диагонали больше, чем наименьшее из значений элементов побочной диагонали.

Mkorovinary 7 сент. 2020 г., 06:13:58 | 10 - 11 классы

Написать программу для паскаля?

Написать программу для паскаля.

Дана квадратная матрица порядка n(n = 5).

Если в данной матрице a нет отрицательных элементов, то транспонировать её, иначе выдать сообщение.

Nastasyamorar 4 авг. 2020 г., 21:22:39 | 5 - 9 классы

1)Найти треть произведения элементов кратных три массива А (4, 7) водимого из блока данных2)Матрица А (К, К) формируется датчиком случайных чисел из интервала (10, 45)?

1)Найти треть произведения элементов кратных три массива А (4, 7) водимого из блока данных

2)Матрица А (К, К) формируется датчиком случайных чисел из интервала (10, 45).

Найти пятую часть произведение элементов последней строки матрицы кратных 5 и сумму положительных элементов главной диагонали.

Определить разность полученных элементов

3)Матрица А (9, 9) формируется датчиком случайных чисел из интервала (12, 55).

Найти среднее арифметическое значение нечетных по значению элементов последнего столбца матрицы и сумму элементов больших 25 главной диагонали матрицы

4)Длина матрицы А (5, 5) элементы которые формируются датчиком случайных чисел из интервала( - 20, 70) Найти среднее арифметическое значение нечетных по сравнению элементов побочной диагонали.

5)Длина матрицы А (5, 5) элементы которые формируются датчиком случайных чисел из интервала( - 40 - 10) Найти среднее арифметическое значение нечетных по сравнению элементов главной диагонали.

6)Длина матрицы С (К, К) найти половину сумы элементов побочной диагонали , больших 5 7)Длина матрицы С (5, 5)найти среднее арифметическое значение элементов диагоналей матрицы С 8)Длина матрицы С (7, 7)найти среднее арифметическое значение элементов побочной диагонали и половину суммы элементов главной диагонали матрицей С.

Kim02kim 2 февр. 2020 г., 07:37:46 | 10 - 11 классы

6 вариант?

6 вариант.

Даны две квадратные матрицы А и В размером 3х3.

Требуется найти С = В – А.

Дана вещественная матрица А(N.

M). Составить программу замены всех отрицательных элементов матрицы на элемент, имеющий максимальное значение.

Salvatore210 17 апр. 2020 г., 11:31:23 | 10 - 11 классы

Программирование C + + ?

Программирование C + + .

Дана целочисленная прямоугольная матрица.

Найти разность сумм элементов на главной и побочной диагоналях.

Zajchikova1986 2 апр. 2020 г., 15:05:57 | 10 - 11 классы

Дана квадратная матрица порядка N?

Дана квадратная матрица порядка N.

Найти произведение элементов побочных диагонали квадратной матрицы.

Yulis566 25 февр. 2020 г., 22:38:46 | 10 - 11 классы

Дана квадратная матрица а размером n * n состоящая из действительных элементов?

Дана квадратная матрица а размером n * n состоящая из действительных элементов.

Найти среднее арифметическое из всех отрицательных элементов этой матрицы.

Gill009 27 дек. 2020 г., 04:57:54 | 10 - 11 классы

Опишите на С + + алгоритм определения количества положительных элементов квадратной матрицы, превышающих по величине среднее арифметическое всех элементов главной диагонали?

Опишите на С + + алгоритм определения количества положительных элементов квадратной матрицы, превышающих по величине среднее арифметическое всех элементов главной диагонали.

KarinaAksenova 16 мар. 2020 г., 23:26:59 | 10 - 11 классы

Написать программу на С + + ?

Написать программу на С + + .

Дана целочисленная квадратная матрица произвольной размерности.

Сформировать одномерный массив, в который поместить элементы двумерной матрицы, находящиеся над побочной диагонали ; упорядочить их по возрастанию и найти их среднее арифметическое.

На этой странице сайта вы найдете ответы на вопрос Дана вещественная квадратная матрица А порядка n?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.