В массике 50 элементов , числа от - 50 до 50 , вычислить среднее арифметическое отрицательных чисел?

Информатика | 10 - 11 классы

В массике 50 элементов , числа от - 50 до 50 , вычислить среднее арифметическое отрицательных чисел.

Ответить на вопрос
Ответы (1)
Serkop 7 янв. 2020 г., 10:30:43

Const

n = 50 ;

Var

a : array[1.

N]of integer ;

k, i, s : integer ;

begin for i : = 1 to n do begin a[i] : = random(101) - 50 ; write(a[i] : 4) ; if a[i]< ; 0 then begin s : = s + a[i] ; k : = k + 1 ; end ; end ;

writeln ;

if k< ; > ; 0 then writeln(s / k)

else writeln('Нет отриц')

end.

Olga197733 5 июн. 2020 г., 13:17:01 | 5 - 9 классы

Составьте программу вычисления среднего арифметического отрицательных элементов?

Составьте программу вычисления среднего арифметического отрицательных элементов.

Drachkova2014 12 мая 2020 г., 07:57:17 | 5 - 9 классы

Вычислите среднее арифметическое двузначных элементов, у которых цифры в числе одинаковые?

Вычислите среднее арифметическое двузначных элементов, у которых цифры в числе одинаковые.

Paramonoff4 14 июн. 2020 г., 06:59:12 | 10 - 11 классы

Задана последовательность из n целых чисел?

Задана последовательность из n целых чисел.

Определить среднее арифметическое отрицательных элементов последовательности.

Написать программу в Pascal.

Tsomaksim2 18 нояб. 2020 г., 10:11:41 | 10 - 11 классы

Задано массив чисел из N элементов?

Задано массив чисел из N элементов.

Найдите среднее арифметическое элементов масиву, которые меньше числа M.

Изувита 27 нояб. 2020 г., 19:41:05 | 5 - 9 классы

Найдите среднее арифметическое отрицательных чисел из n введенных?

Найдите среднее арифметическое отрицательных чисел из n введенных.

(в паскале).

Катеринка3585 11 июл. 2020 г., 02:16:45 | 5 - 9 классы

Найти среднее арифметическое отрицательных элементов массива в Паскале?

Найти среднее арифметическое отрицательных элементов массива в Паскале.

Распишите пожалуйста.

Egor270899 28 дек. 2020 г., 14:51:34 | 5 - 9 классы

Вычислить среднее арифметическое отрицательных элементов вектора Q(21) p?

Вычислить среднее арифметическое отрицательных элементов вектора Q(21) p.

S. через программу паскаль.

AnnaR2011 17 мар. 2020 г., 20:00:07 | 10 - 11 классы

Вычислить среднее арифметическое отрицательных элементов выше главной и ниже побочной диагонали?

Вычислить среднее арифметическое отрицательных элементов выше главной и ниже побочной диагонали.

RiGa 17 февр. 2020 г., 15:40:45 | 5 - 9 классы

Дан массив из 15 чисел заполненный случайными числами из интервала [ - 20 ; 20]?

Дан массив из 15 чисел заполненный случайными числами из интервала [ - 20 ; 20].

Определить , что больше среднее арифметическое элементов стоящих на четных местах или среднее арифметическое положительных элементов массива.

Ruslanzak1 29 янв. 2020 г., 06:42:36 | 10 - 11 классы

Вычислить среднее арифметическое значение отдельно положительных и отрицательных элементов матрицы C(50, 20) и блок - схему если не сложно?

Вычислить среднее арифметическое значение отдельно положительных и отрицательных элементов матрицы C(50, 20) и блок - схему если не сложно.

Вы находитесь на странице вопроса В массике 50 элементов , числа от - 50 до 50 , вычислить среднее арифметическое отрицательных чисел? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.