Исправьте программу пожалуйста (lazarus) program Project1 ; var a, b, i, s2, s1, k : integer ; begin writeln('a и b') ; readln(a, b) ; if (a< ; > ; 0)and(b< ; > ; 0)then ; k : = a * b ; i : = ?

Информатика | 5 - 9 классы

Исправьте программу пожалуйста (lazarus) program Project1 ; var a, b, i, s2, s1, k : integer ; begin writeln('a и b') ; readln(a, b) ; if (a< ; > ; 0)and(b< ; > ; 0)then ; k : = a * b ; i : = k ; while i> ; 0 do begin s1 : = i mod a ; s2 : = i mod a ; end ; if s1 = 0 and s2 = 0 than ; writeln(k = i) ; i : = i - 1 ; end.

Ответить на вопрос
Ответы (1)
Kuuer 25 окт. 2020 г., 01:43:55

Program Project1 ; vara, b, i, s2, s1, k : integer ; beginwriteln('a и b') ; readln(a, b) ; if (a< ; > ; 0)and(b< ; > ; 0)then ; k : = a * b ; i : = k ; while (i> ; 0)dobegini : = i - 1 ; if (i mod b = 0) and (i mod a = 0) thenbreak ; end ; writeln(i) ; end.

Учени10101010101010 15 дек. 2020 г., 09:59:59 | 5 - 9 классы

Прошу вас, помогите?

Прошу вас, помогите!

Решается оценка!

Найдите ошибки в программе 1)Program z1 ; var a : integer ; begin a : = 10 ; while a< ; 5 do writeln(a) ; a : = a + 1 ; End.

2)Program z2 ; var a, s : integer ; begin a : = 1 ; s : = 0 ; while a< ; 10 do begin s : = s + a / 2 ; end ; writeln(s) ; end.

Antonharitonov0 28 янв. 2020 г., 01:46:32 | 10 - 11 классы

Помогите Срочно?

Помогите Срочно!

Чему будет равен результат выполнения программы, если ввести значения для a = 2468?

Program c22 ; var a, b : integer ; k : integer ; begin K : = 0 ; readln(a) ; while (a< ; > ; 0) do begin b : = a mod 10 ; if b mod 2 = 0 then inc(k) ; a : = a div 10 ; end ; writeln(k) ; end.

A) 9 Б)3 В)0 Г)4.

Irinakirikovam 24 мая 2020 г., 05:37:28 | 5 - 9 классы

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end?

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end.

В чём ошибка?

Дулетол3 31 окт. 2020 г., 09:13:31 | 5 - 9 классы

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; w?

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; writeln(s) end.

Sonyatoropchina 24 мар. 2020 г., 12:41:52 | 10 - 11 классы

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ]?

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ].

Вот программа : program yyy ; function prost(var x : integer) : boolean ; var k, i : integer ; t : boolean ; begin t : = true ; k : = 0 ; for i : = 1 to x do begin if x mod i = 0 then k : = k + 1 ; end ; if k = 2 then t : = true else t : = false ; prost : = t end ; var n, m, i : integer ; begin writeln('1') ; readln(n) ; writeln('2') ; readln(m) ; for i : = n to m - 1 do begin if prost(i) and prost(i + 2) then writeln(i , (i + 2)) ; end ; end.

Arlekino2106 21 авг. 2020 г., 18:55:06 | 10 - 11 классы

Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4?

Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x> ; 0 do begin L : = L + 1 If M< ; (x mod 5) then Begin M : = x mod 5 End X : = x div 5 ; End.

Writeln (L) ; write(M) ; End.

Ksusha1037 25 июн. 2020 г., 21:03:03 | 5 - 9 классы

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ?

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 then begin writeln ('утро') ; readln (d) ; if a = 12 then begin writeln ('день') ; end ; if a = 16 then begin writeln ('вечер') ; / / / if a = 21 then begin writeln ('ночь') ; / / / end ; end ;

Galina50286 13 дек. 2020 г., 16:46:22 | 5 - 9 классы

Найдите ошибки в следующих программах :Program int_r ;Var a, x : integer ;b, c : real ;Begina : = 10 ;b : = 5?

Найдите ошибки в следующих программах :

Program int_r ;

Var a, x : integer ;

b, c : real ;

Begin

a : = 10 ;

b : = 5.

2 ;

x : = b div 2 ;

c : = round(x) ;

End.

Program int_r1 ;

Var a, c : integer ;

b, d : real ;

Begin

a : = 25 ;

b : = a / 2 ;

c : = sqr(a) ;

d : = a mod 10 ;

End.

Ряжка 25 дек. 2020 г., 18:21:48 | 5 - 9 классы

Помогите пожалуйста, cрочно?

Помогите пожалуйста, cрочно!

Составить блок - схему.

Program primer6 ;

uses crt ;

x : integer ;

begin

clrscr ;

readln(x) ;

if x mod 2 = 0 then writeln ('да')

else writeln ('нет')

end.

GioZam 1 дек. 2020 г., 11:19:33 | 10 - 11 классы

Задание :Ввести массив в данную программуvarn, i, a, min : integer ;beginreadln(n) ;min : = 30001 ;for i : = 1 to n dobeginreadln(a) ;if (a mod 10 = 4) and (a < min) thenmin : = a ;end ;writeln(min)en?

Задание :

Ввести массив в данную программу

var

n, i, a, min : integer ;

begin

readln(n) ;

min : = 30001 ;

for i : = 1 to n do

begin

readln(a) ;

if (a mod 10 = 4) and (a < min) then

min : = a ;

end ;

writeln(min)

end.

На этой странице находится вопрос Исправьте программу пожалуйста (lazarus) program Project1 ; var a, b, i, s2, s1, k : integer ; begin writeln('a и b') ; readln(a, b) ; if (a&lt ; &gt ; 0)and(b&lt ; &gt ; 0)then ; k : = a * b ; i : = ?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.