Дан файл, содержащий различные даты?

Информатика | 10 - 11 классы

Дан файл, содержащий различные даты.

Каждая дата — это число, месяц и год.

Найти год с наименьшим номером.

Паскаль.

Ответить на вопрос
Ответы (1)
Ereminskaya82 15 июн. 2020 г., 21:37:21

Программа будет работать, если каждая дата записана в отдельной строке, причем число, месяц и год отделяются пробелом

var f : text ; d, m, y, min : integer ;

begin

Assign(f, 'date.

Txt') ;

Reset(f) ;

min : = 9999 ;

while not eof(f) do

begin

readln(f, d, m, y) ;

if y< ; min then min : = y ;

end ;

Close(f) ;

writeln('min = ', min) ;

end.

Natonato12 10 февр. 2020 г., 22:50:43 | 10 - 11 классы

Создать файл, в которм хранятся данные о работающих на фабрике : фамилия, имя, отчество, адрес(улица, дом, квартира) и дата поступления на работу(месяц, год)?

Создать файл, в которм хранятся данные о работающих на фабрике : фамилия, имя, отчество, адрес(улица, дом, квартира) и дата поступления на работу(месяц, год).

Во второй файл записать строки с адресами тех работников, у которых фамилия Иванов или Иваова.

Dashutamyasoed 17 авг. 2020 г., 08:19:10 | 5 - 9 классы

Паскаль?

Паскаль.

Оператор выбора.

Дано натуральное число N (N< ; 100), что означает возраст человека в годах.

Дать для этого числа наименование : "год", "года", "лет".

Khalessy 28 июл. 2020 г., 02:15:22 | 5 - 9 классы

16. В базе данных хранятся записи, содержащие информацию о датах?

16. В базе данных хранятся записи, содержащие информацию о датах.

Каждая запись содержит три поля : год (число от 1 до 2100), номер месяца (число от 1 до 12) и номер дня в месяце (число от 1 до 31).

Каждое поле записывается отдельно от других полей с помощью минимально возможного числа бит.

Определите минимальное количество бит, необходимых для кодирования одной записи.

Rawshan666 11 февр. 2020 г., 21:13:00 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста.

Паскаль авс используя дату текущего дня, вычислить следующую дату.

Сначала с помощью инструкции case проверить , является ли текущий день последним днём месяца.

Затем проверить, является ли текущий месяц днём декабрем : если нет, то номер месяца увеличить на 1, если да то номер года, а номер месяца оставить равен 1 (учесть возможность ввода високосного года(если год / 4 = 0, то год високосный)).

Кунька 2 февр. 2020 г., 18:17:01 | 10 - 11 классы

Дан файл f компоненты которого являются действительными числами, найти сумму наибольшего и наименьшего из значений компонент?

Дан файл f компоненты которого являются действительными числами, найти сумму наибольшего и наименьшего из значений компонент.

Паскаль.

Schoolboys 20 сент. 2020 г., 07:18:07 | 10 - 11 классы

Нужно сделать все это в Pascal?

Нужно сделать все это в Pascal.

Помогите пожалуйста, кто может Пусть дан массив, содержащий даты.

Каждая дата — это число, месяц, год (см.

Описание типа data в предыдущем задании).

Найти : a) год с наименьшим номером ; б) все весенние даты ; в) самую позднюю дату.

Romius2001 8 окт. 2020 г., 04:39:07 | 10 - 11 классы

Ввести в паскаль программу в каком году началась 2 мировая война нужно ввести дату?

Ввести в паскаль программу в каком году началась 2 мировая война нужно ввести дату.

Darya200290567 15 нояб. 2020 г., 20:23:25 | 5 - 9 классы

Известны год и номер месяца рождения человека, а также год и номер месяца сегодняшнего дня (январь – 1 и т?

Известны год и номер месяца рождения человека, а также год и номер месяца сегодняшнего дня (январь – 1 и т.

Д. ).

Определить возраст человека (число полных лет).

В случае совпадения указанных месяцев считать, что прошел весь год.

Паскаль.

Electronik126 25 янв. 2020 г., 00:21:45 | 10 - 11 классы

Помогите пожалуйста ?

Помогите пожалуйста !

Срочно 44 Балла ПАСКАЛЬ АБС.

NET .

Тема : Сложные типы данных.

Записи : Организовать файл, содержащий информацию о книгах.

Сведения о каждой из книг - это фамилия автора, название книги, количество страниц и год издания.

Найти название книг данного автора, изданных не позднее определённого года.

Фамилия автора и год вводятся с клавиатуры.

Kerli1 8 нояб. 2020 г., 17:13:49 | 10 - 11 классы

Напишите программу в Паскаль, которая получает номер месяца и выводит его название и время года?

Напишите программу в Паскаль, которая получает номер месяца и выводит его название и время года.

Пример : Введите номер месяца : 5 Этот месяц - май, время года - весна.

Пример : Введите номер месяца : 15 Неверный номер месяца.

На этой странице находится ответ на вопрос Дан файл, содержащий различные даты?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.