Паскаль?

Информатика | 5 - 9 классы

Паскаль.

Оператор выбора.

Дано натуральное число N (N< ; 100), что означает возраст человека в годах.

Дать для этого числа наименование : "год", "года", "лет".

Ответить на вопрос
Ответы (1)
CrocCat 17 авг. 2020 г., 08:19:16

Var

n : integer ;

s : string ;

begin

readln(n) ;

case n mod 10 of 1 : s : = ' год' ; 2.

4 : s : = ' года' ; 0, 5.

9 : s : = ' лет' ; end ;

case n mod 100 of 11.

19 : s : = ' лет' ; end ;

writeln(n, s) ;

end.

Nikker 8 сент. 2020 г., 03:45:37 | 10 - 11 классы

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ В БЕЙСИКЕ Дано целое число n (1 ≤ n ≤ 99), определяющее возраст человека (в годах)?

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ В БЕЙСИКЕ Дано целое число n (1 ≤ n ≤ 99), определяющее возраст человека (в годах).

Для этого числа напечатать фразу «мне n лет», учитывая при этом, что при некоторых значениях n слово «лет» надо заменить на слово «год» или «года».

Slipchenkoanna 7 мар. 2020 г., 11:00:09 | 10 - 11 классы

Программирование в среде кумир(бейсик и Паскаль не нужно)?

Программирование в среде кумир(бейсик и Паскаль не нужно).

Дано целое число n (1 ≤ n ≤ 99), определяющее возраст человека (в годах).

Для этого числа напечатать фразу «мне n лет», учитывая при этом, что при некоторых значениях n слово «лет» надо заменить на слово «год» или «года».

Iiiiig 25 сент. 2020 г., 03:29:27 | 10 - 11 классы

Дано натуральное число n (1n1188), определяющее возраст человека (в месяцах)?

Дано натуральное число n (1n1188), определяющее возраст человека (в месяцах).

Выразить возраст в годах и месяцах.

Например, 21 год 10 месяцев, 52 года 1 месяц, 46 лет равно и т.

Д.

AndreyAgafonov4 1 июл. 2020 г., 06:46:19 | 5 - 9 классы

Вывести возраст человека ( от 1 до 99) и вывести возраст со словом ( год, года или лет) эот через программу паскаль) помогите как ниписать в программе типо такого : program qq ; и тд?

Вывести возраст человека ( от 1 до 99) и вывести возраст со словом ( год, года или лет) эот через программу паскаль) помогите как ниписать в программе типо такого : program qq ; и тд.

Bartyshvika 15 июн. 2020 г., 21:37:18 | 10 - 11 классы

Дан файл, содержащий различные даты?

Дан файл, содержащий различные даты.

Каждая дата — это число, месяц и год.

Найти год с наименьшим номером.

Паскаль.

Darya200290567 15 нояб. 2020 г., 20:23:25 | 5 - 9 классы

Известны год и номер месяца рождения человека, а также год и номер месяца сегодняшнего дня (январь – 1 и т?

Известны год и номер месяца рождения человека, а также год и номер месяца сегодняшнего дня (январь – 1 и т.

Д. ).

Определить возраст человека (число полных лет).

В случае совпадения указанных месяцев считать, что прошел весь год.

Паскаль.

ПолиТвикс 20 авг. 2020 г., 16:52:18 | 10 - 11 классы

Помогите составить программу в Паскале?

Помогите составить программу в Паскале.

Дан возраст человека мужского пола в годах.

Вывести на экран возрастную категорию : до года - младенец, от года до 11 лет - мальчик, от 12до 15 лет - подросток, от 16 до 25 - юноша, от 26 до 50 лет - мужчина, более 60 лет - старик.

Novikova656 17 окт. 2020 г., 13:17:55 | 10 - 11 классы

Составить программу для c + + "Ввести возраст человека и вывести его вместе со словом ГОД, ГОДА, ЛЕТ(пример вам 1 год, вам 2 года, вам 55 лет)?

Составить программу для c + + "Ввести возраст человека и вывести его вместе со словом ГОД, ГОДА, ЛЕТ(пример вам 1 год, вам 2 года, вам 55 лет).

Илонка2005 24 апр. 2020 г., 03:19:32 | 10 - 11 классы

1. от пользователя вводятся три трехзначных числа, вывести из них, в состав которых входит в состав которых входит наибольшая цифра, встречающаяся в этих числах?

1. от пользователя вводятся три трехзначных числа, вывести из них, в состав которых входит в состав которых входит наибольшая цифра, встречающаяся в этих числах.

2. Дано число (1), определяющее возраст человека (в годах).

Для этого числа напечатать фразе " мне n лет".

Учитывая при этом, что при некоторых значения n слово " лет" заменяется на слово "год или года".

Naskaol 19 мар. 2020 г., 13:39:30 | 1 - 4 классы

Написать в Паскале программу : Ввести возраст человека (от 1 до 150 лет) и вывести его вместе с предыдущим словам "год", "года" или "лет"?

Написать в Паскале программу : Ввести возраст человека (от 1 до 150 лет) и вывести его вместе с предыдущим словам "год", "года" или "лет".

На этой странице вы найдете ответ на вопрос Паскаль?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.