Написать в программе Паскаль программу :Вывести сначала положительные числа из отрезка [a ; b], а потом отрицательные числа из отрезка [a ; b] и количество положительных и отрицательных чисел из отрез?

Информатика | 5 - 9 классы

Написать в программе Паскаль программу :

Вывести сначала положительные числа из отрезка [a ; b], а потом отрицательные числа из отрезка [a ; b] и количество положительных и отрицательных чисел из отрезка [a ; b].

Ответить на вопрос
Ответы (1)
Natusikkisa80 19 июн. 2020 г., 10:57:41

Var a, b, c, k : integer ;

begin

read(a, b) ;

if (a< ; 0) and (b> ; 0) then begin

for k : = 1 to b do write (k, ' ') ; for k : = 1 to a do write ( - k, ' ') ; write( - a, ' ', b) ;

end

else if (a> ; 0) and (b> ; 0) then begin

for k : = a to b do write (k, ' ') ; write (b - a) ;

end

else b : = - 1 * b ; a : = - 1 * a ; for k : = b to a do write (k, ' ') ; write (b - a) ;

end.

Lindasayfutdin1 17 окт. 2020 г., 00:46:28 | 5 - 9 классы

Программа в Паскале нужна, пожалуйста?

Программа в Паскале нужна, пожалуйста!

Даю 60 баллов!

С клавиатуры вводится последовательность из N чисел, положительных и отрицательных.

Какая сумма чисел по модулю больше, положительных или отрицательных?

Enna308 12 мая 2020 г., 23:13:28 | 5 - 9 классы

1. составить программу вывода на экран квадрата числа, если число отрицательное, и куба если число положительное?

1. составить программу вывода на экран квадрата числа, если число отрицательное, и куба если число положительное.

2. составить программу вывода на экран чисел от 1 до 50.

Программа на язеке Паскаля.

Iissrr 8 нояб. 2020 г., 13:25:41 | 10 - 11 классы

Напишите в виде программы для паскаля?

Напишите в виде программы для паскаля.

В массиве А(5) посчитать количество положительных и отрицательных элементов.

Vibornova 16 мар. 2020 г., 18:39:46 | 5 - 9 классы

Написать программу, которая выводит сумму квадратов пяти целых положительных чисел Числа (как положительные, так и отрицательные) вводятся с клавиатуры?

Написать программу, которая выводит сумму квадратов пяти целых положительных чисел Числа (как положительные, так и отрицательные) вводятся с клавиатуры.

Димке 10 окт. 2020 г., 03:51:27 | 10 - 11 классы

Написать программу : c клавиатуры последовательно вводятся числа, пока не введут 0?

Написать программу : c клавиатуры последовательно вводятся числа, пока не введут 0.

Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.

0664956447 4 авг. 2020 г., 01:37:18 | 5 - 9 классы

Написать программу которая даст таблицу Q5 * 5?

Написать программу которая даст таблицу Q5 * 5.

Каждый эелемент таблицы случайное число из отрезка [ - 30, + 30].

Вычислить сумму все отрицательных и сумму положительных элементов.

Аня1210 5 июн. 2020 г., 08:29:44 | 5 - 9 классы

Помогите пожалуйста, нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным числом?

Помогите пожалуйста, нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным числом.

Вутшы 11 окт. 2020 г., 21:05:16 | 5 - 9 классы

Написать программу для Pascal?

Написать программу для Pascal.

Вычислите сумму положительных и кол - во отрицательных чисел на отрезке, концы которого вводятся с клавиатуры.

Юляффка12 17 дек. 2020 г., 15:18:27 | 5 - 9 классы

Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел?

Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел.

Danchenko05 17 нояб. 2020 г., 15:50:16 | 10 - 11 классы

Найти разность положительных чисел и посчитать количество отрицательных чисел на отрезке [ - 10 : 3]?

Найти разность положительных чисел и посчитать количество отрицательных чисел на отрезке [ - 10 : 3].

На этой странице находится ответ на вопрос Написать в программе Паскаль программу :Вывести сначала положительные числа из отрезка [a ; b], а потом отрицательные числа из отрезка [a ; b] и количество положительных и отрицательных чисел из отрез?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.