Написать программу которая даст таблицу Q5 * 5?

Информатика | 5 - 9 классы

Написать программу которая даст таблицу Q5 * 5.

Каждый эелемент таблицы случайное число из отрезка [ - 30, + 30].

Вычислить сумму все отрицательных и сумму положительных элементов.

Ответить на вопрос
Ответы (1)
578103 4 авг. 2020 г., 01:37:24

Var a, b, i, j, p, o : integer ;

z : real ;

m : array[0.

31, 0.

31] of integer ;

begin

randomize ;

for i : = 1 to 5 do for j : = 1 to 5 do begin z : = random ; b : = random(31) ; if z< ; 0.

5 then m[i, j] : = b ; if z> ; 0.

5 then m[i, j] : = - b ; end ; for i : = 1 to 5 do for j : = 1 to 5 do begin if m[i, j]> ; 0 then p : = p + m[i, j] ; if m[i, j]< ; 0 then o : = o + m[i, j] ; end ; write(p, ' ', o) ;

end.

Мда. подумать над задачкой пришлось немного) но вот результат).

Asema198448 6 авг. 2020 г., 09:32:32 | 5 - 9 классы

Составить программу которая заполняет массив из 10 элементов случайными целыми числами из положительные, отрицательные и нулевые числа и выводит на экран?

Составить программу которая заполняет массив из 10 элементов случайными целыми числами из положительные, отрицательные и нулевые числа и выводит на экран.

Polina2250 29 июн. 2020 г., 20:50:24 | 10 - 11 классы

1. Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 ?

1. Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .

10] на 1.

2. составить программу, замены положительных элементов настоящей таблице х [1 .

10] на 0.

3. составить программу, замены отрицательного элементов настоящей таблице х [1 .

10] на их квадрат.

4. составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .

10], которые больше 10.

Vibornova 16 мар. 2020 г., 18:39:46 | 5 - 9 классы

Написать программу, которая выводит сумму квадратов пяти целых положительных чисел Числа (как положительные, так и отрицательные) вводятся с клавиатуры?

Написать программу, которая выводит сумму квадратов пяти целых положительных чисел Числа (как положительные, так и отрицательные) вводятся с клавиатуры.

VJGinger 8 авг. 2020 г., 22:37:09 | 5 - 9 классы

Пожалуйста помогите) 1) написать программу , заполняющую массив из 10 элементов числами от 10 до 1?

Пожалуйста помогите) 1) написать программу , заполняющую массив из 10 элементов числами от 10 до 1.

2)написать программу подсчитывающую количество нечетных элементов в массиве случайных чисел.

3) программа заполняет массив случайными числами от - 10 до 10 и находит сумму отрицательных и положительных элементов.

АрПлон 5 апр. 2020 г., 19:49:59 | 5 - 9 классы

Заполнить массив положительными и отрицательными числами на интервале от - 40 до 40 и найти сумму отрицательных чисел, случайным элементом под элементом 25?

Заполнить массив положительными и отрицательными числами на интервале от - 40 до 40 и найти сумму отрицательных чисел, случайным элементом под элементом 25.

Detkaclass1 13 нояб. 2020 г., 01:00:57 | 5 - 9 классы

Написать программу подсчета суммы вводимых элементов до первого отрицательно числа в Pascal?

Написать программу подсчета суммы вводимых элементов до первого отрицательно числа в Pascal.

MAXCHEBOTKOV 30 янв. 2020 г., 14:37:22 | 5 - 9 классы

Написать программу Заполнить массив из 15 элементов случайными числами ( - 20 ; 80) Посчитать сумму всех элементов массива Посчитать количество отрицательных элементов?

Написать программу Заполнить массив из 15 элементов случайными числами ( - 20 ; 80) Посчитать сумму всех элементов массива Посчитать количество отрицательных элементов.

Misspavlovaol 28 нояб. 2020 г., 15:02:26 | 10 - 11 классы

Написать программу для решения следующей задачи вычислить модуль суммы отрицательных элементов числовой последовательности?

Написать программу для решения следующей задачи вычислить модуль суммы отрицательных элементов числовой последовательности.

Вутшы 11 окт. 2020 г., 21:05:16 | 5 - 9 классы

Написать программу для Pascal?

Написать программу для Pascal.

Вычислите сумму положительных и кол - во отрицательных чисел на отрезке, концы которого вводятся с клавиатуры.

Elenakremen173 8 окт. 2020 г., 08:44:17 | 5 - 9 классы

Составьте программу, которая заполняет массив a [1?

Составьте программу, которая заполняет массив a [1.

10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму эелементов с чётными значениями и количиство элементов с нечётными значениямиъ.

Перед вами страница с вопросом Написать программу которая даст таблицу Q5 * 5?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.