Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел?

Информатика | 5 - 9 классы

Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел.

Ответить на вопрос
Ответы (1)
Ксюха228 17 дек. 2020 г., 15:18:33

Не указано сколько раз оно должно принимать значение и каким образом вообще принять.

Здесь оно 5 раз примет какие - то числа (каждоес новой строки), а потом выведет кол - во + и - .

Значение 0 оно просто пропускает.

Если все 5 чисел будут = 0, то и на выходе оно скажет, что было введено 0 значений с + и 0 значений с - .

Код (скриншот прилагается) :

var minus, plus, input, i : integer ;

begin

minus : = 0 ;

plus : = 0 ;

for i : = 0 to 4 do

begin

readln(input) ;

if input > ; 0 then plus : = plus + 1 ;

else if input < ; 0 then minus : = minus + 1 ;

end ;

writeln(plus, 'positive and', minus, 'negative numbers.

') ;

end.

Vibornova 16 мар. 2020 г., 18:39:46 | 5 - 9 классы

Написать программу, которая выводит сумму квадратов пяти целых положительных чисел Числа (как положительные, так и отрицательные) вводятся с клавиатуры?

Написать программу, которая выводит сумму квадратов пяти целых положительных чисел Числа (как положительные, так и отрицательные) вводятся с клавиатуры.

Toridddd 7 мая 2020 г., 16:38:21 | 5 - 9 классы

Помогите написать программу на Паскале?

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 6 или 11.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа по модулю не превышают 30 000.

Программа должна вывести одно число : сумму всех чисел, которые кратны 6 или 11.

Димке 10 окт. 2020 г., 03:51:27 | 10 - 11 классы

Написать программу : c клавиатуры последовательно вводятся числа, пока не введут 0?

Написать программу : c клавиатуры последовательно вводятся числа, пока не введут 0.

Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.

Гордон11111 4 авг. 2020 г., 18:14:55 | 5 - 9 классы

Написать программу Пользователь вводит 5 целых чисел, программа находит сумму всех отрицательных и произведение всех положительных чисел?

Написать программу Пользователь вводит 5 целых чисел, программа находит сумму всех отрицательных и произведение всех положительных чисел.

LiSTRaTiK 9 апр. 2020 г., 04:24:46 | 5 - 9 классы

Помогите написать программу на Паскале?

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 6 или 11.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа по модулю не превышают 30 000.

Программа должна вывести одно число : сумму всех чисел, которые кратны 6 или 11.

Moretz1337 25 авг. 2020 г., 18:49:52 | 5 - 9 классы

Привет?

Привет.

Напишите, пожалуйста, программу, которая будет вводить целые числа до тех пор, пока не будет введён нуль.

Подсчитать количество положительных и отрицательных чисел.

Аня1210 5 июн. 2020 г., 08:29:44 | 5 - 9 классы

Помогите пожалуйста, нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным числом?

Помогите пожалуйста, нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным числом.

Golovinadjuliy 6 авг. 2020 г., 10:43:44 | 10 - 11 классы

Написать программу, в которой пользователь вводит несколько чисел, программа выводит количество положительных чисел?

Написать программу, в которой пользователь вводит несколько чисел, программа выводит количество положительных чисел.

Lizik1709 6 нояб. 2020 г., 06:51:10 | 10 - 11 классы

1) Напишите программу, в которой осуществляется ввод целых чисел (пока не будет введён 0) и выведет на экран сумму положительных чисел, и произведение отрицательных введённых чисел?

1) Напишите программу, в которой осуществляется ввод целых чисел (пока не будет введён 0) и выведет на экран сумму положительных чисел, и произведение отрицательных введённых чисел.

Использовать цикл repeat.

2) Напишите программу, которая выводит на экран таблицу умножения на N, чисел от 0 до 10.

Помогите пожалуйста!

(.

Art900 15 дек. 2020 г., 17:51:32 | 5 - 9 классы

ПОМОГИТЕ ПОЖАЛУЙСТАНаписать программу, которая определяет максимальное число из введённой последовательности положительных чиселзавершение вводом 0?

ПОМОГИТЕ ПОЖАЛУЙСТА

Написать программу, которая определяет максимальное число из введённой последовательности положительных чисел

завершение вводом 0.

На этой странице сайта размещен вопрос Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.