Дан массив, состоящий из целых чисел?

Информатика | 10 - 11 классы

Дан массив, состоящий из целых чисел.

Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками.

Ответить на вопрос
Ответы (1)
Magistrtawer 30 дек. 2020 г., 00:56:40

Program Main ;

Var a : array[1.

1000]of integer ;

i, n, k : integer ;

begin

write('Введите количество элементов в массиве : ') ;

readln(n) ;

writeln('Введите массив : ') ;

for i : = 1 to n do read(a[i]) ;

writeln ;

k : = 0 ;

for i : = 1 to n - 1 do

if (a[i] = a[i + 1]) then k : = k + 1 ;

if (k> ; 0) then writeln('Есть ', k, ' пар соседних элементов с одинаковым значением') else

writeln ('Нет пар соседних элементов с одинаковым значением') ;

end.

Лизок123456 3 авг. 2020 г., 18:53:34 | 5 - 9 классы

Дан массив из 10 целых чисел от - 20 до 20 и целое число (вводится с клавиатуры)?

Дан массив из 10 целых чисел от - 20 до 20 и целое число (вводится с клавиатуры).

Напишите программу, определяющую, сколько в массиве чисел.

Angelinagavril12 20 февр. 2020 г., 07:23:54 | 5 - 9 классы

Дан массив из N целых элементов и целое число B?

Дан массив из N целых элементов и целое число B.

Написать программу, определяющую, сколько в массиве чисел, меньших В.

Risha88 8 мая 2020 г., 22:23:56 | 5 - 9 классы

Кто решит задачу?

Кто решит задачу?

Дан массив из N целых чисел.

Написать программу, определяющую, есть ли в массиве два соседних положительных элемента.

Если есть, то вывести индекс первого элемента, входящего в первую пару.

Ангелина2003ангел 8 янв. 2020 г., 15:03:48 | 5 - 9 классы

Дан одномерный массив целых чисел состоящий из 22 двух элементов посчитать количество отрицательных элементов массива, а так же количество элементов которые делятся на 9?

Дан одномерный массив целых чисел состоящий из 22 двух элементов посчитать количество отрицательных элементов массива, а так же количество элементов которые делятся на 9.

Помогите отредактировать программу.

Glebdrokin 27 янв. 2020 г., 18:50:45 | 10 - 11 классы

Напишите программу, Дан целый одномерный массив А, неотрицательных чисел, с индексами от 1 до 6?

Напишите программу, Дан целый одномерный массив А, неотрицательных чисел, с индексами от 1 до 6.

Заполнить данный массив с клавиатуры, найти и вывести наименьшую нечетную сумму двух соседних элементов массива.

Сайкаааааа 3 мар. 2020 г., 14:41:31 | 5 - 9 классы

Дан массив C который состоит из 10 целых чисел?

Дан массив C который состоит из 10 целых чисел.

Составить программу определения средне арифметической элементов данного массива.

Yankaru 28 сент. 2020 г., 03:54:42 | 10 - 11 классы

1. Вывести ряд чисел 5, 14, 41, 122, 365 учитывая, что первый элемент массива равен 2 3?

1. Вывести ряд чисел 5, 14, 41, 122, 365 учитывая, что первый элемент массива равен 2 3.

Дан целочисленный массив из 20 элементов.

Элементы массива могут принимать целые значения от - 10000 до 10000 включительно.

Напишите программу, позволяющую найти и вывести количество пар элементов, в которых сумма элементов делится на 3, но не делится на 9.

В данной задаче под парой подразумеваются два соседних элемента массива.

Соничкаа 22 авг. 2020 г., 21:51:53 | 5 - 9 классы

Срочно , напишите программуДан массив, состоящий из целых чисел?

Срочно , напишите программу

Дан массив, состоящий из целых чисел.

Нумерация элементов начинается с 0.

Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4.

). Входные данныеСначала задано число N — количество элементов в массиве (1N100).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данныеНеобходимо вывести все элементы массива с чётными номерами.

Timahau 19 дек. 2020 г., 10:57:17 | 10 - 11 классы

Написать программу в АВС Паскаль?

Написать программу в АВС Паскаль.

Дан массив целых чисел.

Найти количество пар соседних элементов, в которых одно число четное, а другое отрицательное.

Выведите также сформированный массив и все искомые пары соседних элементов.

Izgaraeva 22 нояб. 2020 г., 06:16:43 | 10 - 11 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.

Входные данные Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо единственное число - количество положительных элементов в массиве.

Java.

Вы находитесь на странице вопроса Дан массив, состоящий из целых чисел? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.