Напишите программу, Дан целый одномерный массив А, неотрицательных чисел, с индексами от 1 до 6?

Информатика | 10 - 11 классы

Напишите программу, Дан целый одномерный массив А, неотрицательных чисел, с индексами от 1 до 6.

Заполнить данный массив с клавиатуры, найти и вывести наименьшую нечетную сумму двух соседних элементов массива.

Ответить на вопрос
Ответы (1)
Ерема20152 27 янв. 2020 г., 18:50:50

Program lol ;

Const n = 6 ;

var a : array [1.

N] of integer ;

i, s : integer ;

begin

begin

for i : = 1 to n do

readln (a[i]) ;

end ;

s : = a[1] + a[2] ;

for i : = 2 to n do

begin

if s> ; (a[i] + a[i - 1]) then

s : = a[i] + a[i - 1] ;

end ;

writeln(s) ;

end.

Tabarenzeva 31 мар. 2020 г., 17:07:40 | 5 - 9 классы

Дан массив из целых чисел X[1?

Дан массив из целых чисел X[1.

5]. Заменить каждый элемент массива с нечетным номером средним арифметическим индексов соседних элементов.

Ghjkknbbv 21 дек. 2020 г., 09:04:39 | 1 - 4 классы

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами?

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами.

Требуется вывести массив на экран компьютера и найти индекс последнего по счету в массиве отрицательного элемента.

Nastena2805 2 апр. 2020 г., 04:43:43 | 10 - 11 классы

Погите пожалуйста?

Погите пожалуйста.

Нужно написать задачи на языке Паскаль.

1. С клавиатуры заполнить целочисленный одномерный массив.

Вывести неотрицательные элементы массива.

2. дан одномерный массив целых чисел.

Определить каких элементов больше, максимальных и минимальных 3.

Дан одномерный массив целых чисел.

Подсчитать количество элементов, равных заданному массиву x.

Число х вводится с клавиатуры.

Risha88 8 мая 2020 г., 22:23:56 | 5 - 9 классы

Кто решит задачу?

Кто решит задачу?

Дан массив из N целых чисел.

Написать программу, определяющую, есть ли в массиве два соседних положительных элемента.

Если есть, то вывести индекс первого элемента, входящего в первую пару.

Гастон1 13 янв. 2020 г., 14:59:19 | 10 - 11 классы

Дан одномерный массив?

Дан одномерный массив.

Найти сумму элементов массива, значение которых падает в отрезок [2 ; 5] (Массив предварительно заполнить с клавиатуры).

Wapiro 15 июн. 2020 г., 23:50:17 | 5 - 9 классы

Дан одномерный массив с индексами от 0 до 14, найти индекс минимального и максимального элементов массива(числа вводятся с клавиатуры)?

Дан одномерный массив с индексами от 0 до 14, найти индекс минимального и максимального элементов массива

(числа вводятся с клавиатуры).

IRINASTRELZ 27 нояб. 2020 г., 01:23:12 | 5 - 9 классы

PascalABC1)Дан массив целых чисел, состоящий из 8 элементов?

PascalABC

1)Дан массив целых чисел, состоящий из 8 элементов.

Заполнить его с клавиатуры.

Найти сумму элементов, имеющий нечётный индекс.

2)Сформировать одномерные массив из N элементов, где элементы массива - целые случайные числа.

Вывести индексы тех элементов, значение которых больше заданного числа A (A вводить с клавиатуры).

3)Определите, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

Gffghvd 8 окт. 2020 г., 19:16:16 | 5 - 9 классы

Дан массив А целых чисел, состоящий из 25 элементов?

Дан массив А целых чисел, состоящий из 25 элементов.

Заполнить с клавиатуры.

3)Найти элемент массива кратный 12 и его индекс.

4)Найти сумму положительных элементов, значения которых меньше 10.

5)Вывести индексы тех элементов, которых кратн.

Laszay14 2 окт. 2020 г., 14:20:12 | 5 - 9 классы

Дан массив целых чисел, состоящий из 20 элементов?

Дан массив целых чисел, состоящий из 20 элементов.

Заполнить его с клавиатуры.

Найти :

1)сумму элементов, имеющих нечетное значение ;

2)вывести индексы тех элементов, значения которых больше заданного числа А.

Serokurovavika 5 дек. 2020 г., 03:12:15 | 10 - 11 классы

Составить блок - схему и программу для решения задачи?

Составить блок - схему и программу для решения задачи.

Дан одномерный массив С, состоящий из 11 целых чисел, принадлежащих отрезку [0 ; 25].

Элементы массива вывести в строчку через пробел.

Найти количество нечетных элементов массива.

Вопрос Напишите программу, Дан целый одномерный массив А, неотрицательных чисел, с индексами от 1 до 6?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.