1. Вывести ряд чисел 5, 14, 41, 122, 365 учитывая, что первый элемент массива равен 2 3?

Информатика | 10 - 11 классы

1. Вывести ряд чисел 5, 14, 41, 122, 365 учитывая, что первый элемент массива равен 2 3.

Дан целочисленный массив из 20 элементов.

Элементы массива могут принимать целые значения от - 10000 до 10000 включительно.

Напишите программу, позволяющую найти и вывести количество пар элементов, в которых сумма элементов делится на 3, но не делится на 9.

В данной задаче под парой подразумеваются два соседних элемента массива.

Ответить на вопрос
Ответы (1)
Natalyazamar 28 сент. 2020 г., 03:54:43

/ / PascalABC.

NET 3.

1, сборка 1192 от 07.

03. 2016

begin SeqGen(ReadInteger('Кол - во = '), 2, x - > ; 3 * x - 1).

Println

end.

Тестовое решение :

Кол - во = 10

2 5 14 41 122 365 1094 3281 9842 29525 / / PascalABC.

NET 3.

1, сборка 1192 от 07.

03. 2016

begin var a : = ArrRandom(20, - 10000, 10000) ; a.

Println ; Writeln('Кол - во пар : ', a.

Pairwise.

Where(x - > ; ((x.

Item1 + x.

Item2) mod 3 = 0) and ((x.

Item1 + x.

Item2) mod 9< ; > ; 0)).

Println.

Count)

end.

Тестовое решение : - 1932 - 9879 3600 - 6873 6098 - 308 - 3663 3180 257 4339 - 778 - 1245 - 9361 - 7036 - 2972 5592 4844 87 - 980 - 4458

( - 1932, - 9879) ( - 9879, 3600) (3600, - 6873) (6098, - 308) ( - 3663, 3180) (257, 4339) (4339, - 778)

Кол - во пар : 7.

Alsuska18 11 апр. 2020 г., 04:10:32 | 5 - 9 классы

Дан целочисленный массив из 20 элементов элементы могут принимать значения - 1000 до 1000 позволяет найти и вывести минимальные значения среди элементов массива которые имеют четные значения и не деля?

Дан целочисленный массив из 20 элементов элементы могут принимать значения - 1000 до 1000 позволяет найти и вывести минимальные значения среди элементов массива которые имеют четные значения и не делятся на 3.

Risha88 8 мая 2020 г., 22:23:56 | 5 - 9 классы

Кто решит задачу?

Кто решит задачу?

Дан массив из N целых чисел.

Написать программу, определяющую, есть ли в массиве два соседних положительных элемента.

Если есть, то вывести индекс первого элемента, входящего в первую пару.

Danikdzhafarow 12 мая 2020 г., 12:38:49 | 10 - 11 классы

Дан массив А из 20 элементов?

Дан массив А из 20 элементов.

Найти сумму первых 10 элементов массива и следующих 10 элементов массива.

Результат вывести на печать.

Bog100 12 мая 2020 г., 16:05:02 | 5 - 9 классы

Дан целочисленный массив из 30 элементов?

Дан целочисленный массив из 30 элементов.

Элементы массива могут принимать значения от 0 до 1000.

Напишите программу, позволяющую найти и вывести количество элементов массива, кратных трём, запись которых заканчивается цифрой 1.

Паскаль АБС.

4yBAK4 28 окт. 2020 г., 14:55:27 | 5 - 9 классы

Дан целочисленный массив из 10 элементов?

Дан целочисленный массив из 10 элементов.

Элементы массива могут принимать целые значения от 0 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти и вывести номер первого элемента массива, который делится на 3.

Гарантируется, что в исходном массиве есть хотя бы один такой элемент.

Программу я написал, но выводит все значения, а мне нужно первое.

DaryverRUZ 8 нояб. 2020 г., 18:37:35 | 10 - 11 классы

№1. Дан массив из 30 - ти элементов?

№1. Дан массив из 30 - ти элементов.

Каждый элемент может принимать целочисленные значения от - 100 до 100.

Напишите программу, которая позволит подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива.

№2. Дан массив из 40 элементов.

Каждый элемент может принимать целочисленные значения от 0 до 200.

Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива.

Эльвиркин1 18 авг. 2020 г., 17:18:38 | 5 - 9 классы

Ребят помогите пожалуйста решить задачу по Паскалю?

Ребят помогите пожалуйста решить задачу по Паскалю.

Дан целочисленный массив из 30 элементов, элементы массива могут принимать значения от 0 до 100.

Напишите эффективную программу которая позволит найти и вывести на печать сумму элементов делющихся на 5 без остатка.

Известно, что в массиве есть хотябы один элемент делящийся на 5 без остатка.

Elenashmeleva1 14 апр. 2020 г., 00:10:59 | 5 - 9 классы

Дан целочисленный массив из 50 элементов?

Дан целочисленный массив из 50 элементов.

Элементы массива могут приннимать целые значения от 0 до 1000.

Найти и вывести номер элемента массива, имеющего максимальное значение среди элементов массива, которые больше, чем 4 и меньше , чем 9.

Гарантируется , что в исходном массиве есть хотя бы один такой элемент.

На паскале , помогите пожалуйста.

Sidorovakatyus 23 нояб. 2020 г., 14:56:40 | 5 - 9 классы

Дан целочисленный массив из 20 элементов?

Дан целочисленный массив из 20 элементов.

Элементы массива могут принимать целые значения от –10 000 до 10 000 включительно.

Опишите на одном из языков программирования алгоритм, позволяющий найти и вывести количество пар элементов массива, в которых сумма элементов делится на 2, но не делится на 4.

В данной задаче под парой подразумеваются два соседних элемента массива.

GrafAleksandr1 7 дек. 2020 г., 19:21:13 | 10 - 11 классы

Дан целочисленный массив из 20 элементов?

Дан целочисленный массив из 20 элементов.

Элементы массива могут принимать целые значения от 0 до 10000 включительно.

Опишите алгоритм, позволяющий найти и вывести максимальное значение среди трёхзначных элементов массива, не делящихся на 7.

Если в исходном массиве нет элемента, значение которого является трёхзначным числом и при этом кратно 7, то вывести сообщение «Не найдено».

На языке PHP.

Вы перешли к вопросу 1. Вывести ряд чисел 5, 14, 41, 122, 365 учитывая, что первый элемент массива равен 2 3?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.