Дан массив из N целых элементов и целое число B?

Информатика | 5 - 9 классы

Дан массив из N целых элементов и целое число B.

Написать программу, определяющую, сколько в массиве чисел, меньших В.

Ответить на вопрос
Ответы (1)
2nein 20 февр. 2020 г., 07:24:00

Program Task ;

Const N = 10 ;

Var a : Array [1.

N] of Integer ;

i, B, count : Integer ;

Begin Write('B = ') ; ReadLn(B) ; WriteLn('Введите ', N, ' элементов через пробел') ; For i : = 1 To N Do Begin Read(a[i]) ; If a[i] < ; B Then count : = count + 1 ; End ; WriteLn('Количество элементов, меньших ', B, ' равно', count) ; ReadLn ;

End.

Лизок123456 3 авг. 2020 г., 18:53:34 | 5 - 9 классы

Дан массив из 10 целых чисел от - 20 до 20 и целое число (вводится с клавиатуры)?

Дан массив из 10 целых чисел от - 20 до 20 и целое число (вводится с клавиатуры).

Напишите программу, определяющую, сколько в массиве чисел.

Olya06 20 нояб. 2020 г., 13:41:50 | 5 - 9 классы

Помогите написать программу на С + + ?

Помогите написать программу на С + + .

Дан массив, состоящий из целых чисел.

Известно, что числа упорядочены по неубыванию (то есть каждый следующий элемент не меньше предыдущего).

Напишите программу, которая определит количество различных чисел в этом массиве.

Входные данные Сначала задано число N — количество элементов в массиве (1N100).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо вывести единственное число - количество различных чисел в массиве.

Примеры входные данные 5 1 1 1 1 1 выходные данные 1.

Natashahanali 2 мая 2020 г., 09:45:38 | 10 - 11 классы

Дан массив из n целых элементов и целое число b?

Дан массив из n целых элементов и целое число b.

Сколько раз в массиве встречается число b?

Ariname 14 мая 2020 г., 07:02:43 | 5 - 9 классы

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива?

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел, найти количество отрицательных элементов массива.

3. Дан массив целых чисел, найти количество чётных чисел в массиве.

Arsenchinhalin 9 февр. 2020 г., 22:22:51 | 5 - 9 классы

Дан массив целых чисел?

Дан массив целых чисел.

Найти сумму элементов массива, больших данного числа А

C + +.

Risha88 8 мая 2020 г., 22:23:56 | 5 - 9 классы

Кто решит задачу?

Кто решит задачу?

Дан массив из N целых чисел.

Написать программу, определяющую, есть ли в массиве два соседних положительных элемента.

Если есть, то вывести индекс первого элемента, входящего в первую пару.

Shkololo228339 21 апр. 2020 г., 13:14:36 | 10 - 11 классы

Задан массив из 10 целых чисел?

Задан массив из 10 целых чисел.

Написать программу которая находт - сумму всех элементов массива - колличество чётных и нечётных элементов массива.

Artur1106 30 дек. 2020 г., 00:56:34 | 10 - 11 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками.

Aylovat40 16 окт. 2020 г., 08:55:54 | 10 - 11 классы

Дан одномерный массив из 12 чисел?

Дан одномерный массив из 12 чисел.

Элементами массива являются целые числа.

Найти максимальный элемент указанного массива.

Izgaraeva 22 нояб. 2020 г., 06:16:43 | 10 - 11 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.

Входные данные Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо единственное число - количество положительных элементов в массиве.

Java.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Дан массив из N целых элементов и целое число B?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.