Текст программы решения квадратного уравнения в среде Turbo Pascal 7?

Информатика | 10 - 11 классы

Текст программы решения квадратного уравнения в среде Turbo Pascal 7.

Сам вообще не соображаю.

Помогите, пожалуйста.

Ответить на вопрос
Ответы (1)
Дашкаиванчик 4 сент. 2020 г., 10:27:30

Program Sq2 ;

Var A, B, C, D, X, X1, X2 : Real ;

Begin

Writeln ('Введите коэффициенты уравнения (A, B, C) ') ;

readln(a, b, c) ;

If A = 0 Then

If B = 0 Then

If C = 0 Then Writeln('X - любое число')

Else Writeln('Корней нет!

')

Else

Begin

X : = - C / B ;

Writeln('X = ', X : 8 : 3) ;

End

Else

Begin

D : = B * B - 4 * A * C ;

If D< ; 0 Then Writeln ('Корней нет!

')

Else

Begin

X1 : = ( - B + SQRT(D)) / 2 / A ;

X2 : = ( - B - SQRT(D)) / 2 / A ;

Writeln ('X1 = ', X1 : 8 : 3, ' X2 = ', X2 : 8 : 3) ;

End ;

End ;

End.

Решение не мое, так как на составления данного кода, не хватило бы времени.

Aleksandra1604 5 июл. 2020 г., 02:05:21 | 5 - 9 классы

Среда turbo pascal?

Среда turbo pascal.

Нужен алгоритм решения неполного квадратного уравнения y = ax ^ 2 + c.

Ostashuk40 4 апр. 2020 г., 13:38:31 | 5 - 9 классы

Решение через Turbo Pascal?

Решение через Turbo Pascal.

45прпрпрп 18 окт. 2020 г., 05:51:35 | 5 - 9 классы

Напишите программы в Turbo Pascal?

Напишите программы в Turbo Pascal.

MrSuperFlash 16 нояб. 2020 г., 10:28:48 | 1 - 4 классы

Напишите программу в Turbo Pascal?

Напишите программу в Turbo Pascal.

Спасибо!

Katjulka 24 мар. 2020 г., 07:48:20 | 5 - 9 классы

Напишите пожалуйста программу на Turbo pascal :Найти частное двух целых чисел вводимых с клавиатуры?

Напишите пожалуйста программу на Turbo pascal :

Найти частное двух целых чисел вводимых с клавиатуры.

СМАЙЛИ 24 февр. 2020 г., 20:55:10 | 10 - 11 классы

Написать программу, которая выводит изображенный ниже узор?

Написать программу, которая выводит изображенный ниже узор.

Turbo Pascal.

89178426960 17 июл. 2020 г., 05:34:04 | 5 - 9 классы

Помогите составить программу очень срочно?

Помогите составить программу очень срочно!

Pascal TURBO.

Kristinazhyrav 28 авг. 2020 г., 12:30:12 | 10 - 11 классы

Решение в turbo pascal?

Решение в turbo pascal!

Itrofimoff 1 авг. 2020 г., 03:40:26 | 1 - 4 классы

Структура программы на языке turbo pascal?

Структура программы на языке turbo pascal.

Ptyika17 30 дек. 2020 г., 05:22:55 | 5 - 9 классы

Turbo Pascal?

Turbo Pascal.

Составить программу.

Вычислить значение функции :

Вы находитесь на странице вопроса Текст программы решения квадратного уравнения в среде Turbo Pascal 7? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.