Помогите?

Информатика | 10 - 11 классы

Помогите!

Переменная А вводится с помощью описания : var A : set of char ; напишите функцию, которая возвращает количество символов в множестве А.

(МОЖНО ИСПОЛЬЗОВАТЬ STRING!

).

Ответить на вопрос
Ответы (1)
Ktaushev82 7 сент. 2020 г., 13:27:28

Type S = set of char ;

function VS(p : S) : integer ;

var i, n : integer ;

begin for i : = 0 to 255 do if chr(i) in p then n : = n + 1 ; VS : = n

end ;

var m : S ;

begin m : = ['П', 'р', 'и', 'в', 'е', 'т', ' ', '1', '2', '5', 'H', 'e', 'l', 'o'] ; Writeln('Количество символов в множестве - ', VS(m))

end.

Тестовое решение :

Количество символов в множестве - 14.

Karimdilnaz 24 мая 2020 г., 04:41:54 | 10 - 11 классы

(Char)?

(Char).

Пользователь вводит текст, признаком конца которого явля­ется точка.

Вывести на экран весь исходный текст, заменив в нем все заглавные буквы на прописные .

(малые на большие) (не использовать string)

Выручайте ребята срочно нужно!

Делаем в Pascal ABC.

Amarasov1 27 мар. 2020 г., 12:12:57 | 10 - 11 классы

(Char)?

(Char).

Пользователь вводит символ.

Вывести на экран символ, последующий за ним в таблице кодов ASCII.

Laisrem13 8 дек. 2020 г., 23:51:41 | 10 - 11 классы

Pascal abc Написать программу, которая бы вводила с клавиатуры два символа и выводила на экран тот, код которого больше (использовать операцию сравнения символов)?

Pascal abc Написать программу, которая бы вводила с клавиатуры два символа и выводила на экран тот, код которого больше (использовать операцию сравнения символов).

Alfiya001 24 сент. 2020 г., 07:03:19 | 10 - 11 классы

Как преобразовать символ char в переменную int на языке с (не с + + )?

Как преобразовать символ char в переменную int на языке с (не с + + )?

Например char c ; int x ; чтобы 'c' = x ; Спасибо заранее.

Acevinok 24 нояб. 2020 г., 17:51:44 | 5 - 9 классы

Наибольшее количество символов которые можно использовать в имени файла?

Наибольшее количество символов которые можно использовать в имени файла.

Natatalia09 16 авг. 2020 г., 18:13:27 | 10 - 11 классы

Даны следующие описания переменных : var A, B : set of char ; x : char ;Переменной B присвоить множество, полученное из A : а) добавлением элемента x ; б) удалением элемента x?

Даны следующие описания переменных : var A, B : set of char ; x : char ;

Переменной B присвоить множество, полученное из A : а) добавлением элемента x ; б) удалением элемента x.

Ася122 20 июн. 2020 г., 03:00:39 | 5 - 9 классы

Какой вариант описывает переменную символьного типа?

Какой вариант описывает переменную символьного типа?

1) var y : integer 2) var y : char 3) var y : boolean 4) var y : real.

GIRL99love 5 мая 2020 г., 20:10:13 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составте программу которая : подсчитывает количество вхождений заданного символа.

GlebovichPolinka 22 дек. 2020 г., 15:42:26 | 10 - 11 классы

Pascal abc Написать программу, которая вводит с клавиатуры строку и выводит на экран символ, код которого в два раза больше, чем количество символов в исходной строке (использовать функции Length и ch?

Pascal abc Написать программу, которая вводит с клавиатуры строку и выводит на экран символ, код которого в два раза больше, чем количество символов в исходной строке (использовать функции Length и chr).

Птздочс 17 мар. 2020 г., 04:53:17 | 10 - 11 классы

Написать функцию, которая возвращает символ строки с самой высокой частотой встречаемости?

Написать функцию, которая возвращает символ строки с самой высокой частотой встречаемости.

Прототип функции char function_name (char * s).

Проверить работу функции на строке, введенной с клавиатуры.

Реализовать вывод результата.

На этой странице вы найдете ответ на вопрос Помогите?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.