Написать исходный код в Pascal - е?

Информатика | 5 - 9 классы

Написать исходный код в Pascal - е.

Решить задачу по обработке строковых данных с использованием подпрограмм : В строке, среди знаков могут встречаться открывающие и закрывающие скобки.

Проверить с помощью подпрограммы равенство числа открывающихся скобок числу закрывающихся.

Ответить на вопрос
Ответы (1)
Footbol5 1 февр. 2020 г., 03:47:21

Var str : string ; i, n9, n0 : integer ;

begin readln(str) ; for i : = 1 to Length(str) do if str[i] = '(' then n9 : = n9 + 1 else if str[i] = ')' then n0 : = n0 + 1 ; if n9 = n0 then writeln('Число открывающихся скобок равно числу закрывающихся') else writeln('Число открывающихся скобок неравно числу закрывающихся') ;

end.

Sayaghanverdi 18 окт. 2020 г., 14:07:32 | 10 - 11 классы

Написать программу на Pacal задачи : 1?

Написать программу на Pacal задачи : 1.

Дано два ненулевых числа проверить истинность высказывания "числа имеют разные знаки".

2. Дано два целых числа проверить истинность высказывания " оба числа четные".

Maksimusmineev33rus 29 апр. 2020 г., 10:26:11 | 10 - 11 классы

ПОМОГИТЕ РЕШИТЬ ЧЕРЕЗ ПОДПРОГРАММУ И БЕЗ "рандома" Дано : массивы А(8), В(11)?

ПОМОГИТЕ РЕШИТЬ ЧЕРЕЗ ПОДПРОГРАММУ И БЕЗ "рандома" Дано : массивы А(8), В(11).

Определить в каком массиве отрицательное число встречается раньше.

Номер первого отрицательного элемента в массиве находить в подпрограмме.

Bors73 1 мая 2020 г., 14:40:11 | 5 - 9 классы

Как открываются и закрываются документы и программы?

Как открываются и закрываются документы и программы?

ПОЛНЫЙ ОТВЕТ, ПОЖАЛУЙСТА : ).

Rita33r 17 мар. 2020 г., 04:03:37 | 10 - 11 классы

Задан фрагмент текста?

Задан фрагмент текста.

Проверить, имеется ли в нем баланс открывающих и закрывающих круглых скобок.

Рекомендации : должно существовать взаимно однозначное соответствие открывающих и закрывающих скобок, при котором открывающая скобка всегда предшествует соответствующей.

Zagorodnyaya85 15 мая 2020 г., 03:01:48 | 5 - 9 классы

Срочно?

Срочно!

Создать программу!

Тема "организация подпрограмм через функцию" задача дан параллепипед с измерениями а, b, c.

Составить программу для нахождения площади полной поверхности, используя подпрограмму нахождения площади прямоугольника.

Misha21211993 29 июн. 2020 г., 13:05:16 | 5 - 9 классы

2. Для чего используются подпрограммы?

2. Для чего используются подпрограммы?

Екатерина784 28 июн. 2020 г., 05:49:50 | 5 - 9 классы

Составить подпрограмму которая вводит с клавиатуры три числа находит наибольшее из них выводит его на экран?

Составить подпрограмму которая вводит с клавиатуры три числа находит наибольшее из них выводит его на экран.

Enjegilmanova 22 мая 2020 г., 04:54:16 | 10 - 11 классы

Кому не сложно помочь с PascalABC?

Кому не сложно помочь с PascalABC?

Дана строка.

Некоторые из слов взяты в круглые скобки.

Написать программу, выводящую исходную строку без скобок.

Каринка0Ясинская 17 сент. 2020 г., 11:09:46 | 5 - 9 классы

Написать подпрограмму, которая ищет а четырехзначном числе минимальную четную цифру?

Написать подпрограмму, которая ищет а четырехзначном числе минимальную четную цифру.

Если таких цифр нет, то вернуть - 1.

Требования к подпрограмме : Процедура должна называться "search" и иметь два параметра : первый - четырехзначное натуральное число.

Второй - результат работы подпрограммы.

(Паскаль абц (Pascal abc)).

Vahf 11 дек. 2020 г., 23:51:04 | 10 - 11 классы

Используя подпрограмму - функцию написать алгоритм решения задачи : Написать функцию, которая находит сумму цифр целого числа?

Используя подпрограмму - функцию написать алгоритм решения задачи : Написать функцию, которая находит сумму цифр целого числа.

На этой странице сайта размещен вопрос Написать исходный код в Pascal - е? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.