Задан фрагмент текста?

Информатика | 10 - 11 классы

Задан фрагмент текста.

Проверить, имеется ли в нем баланс открывающих и закрывающих круглых скобок.

Рекомендации : должно существовать взаимно однозначное соответствие открывающих и закрывающих скобок, при котором открывающая скобка всегда предшествует соответствующей.

Ответить на вопрос
Ответы (1)
Jодуванчик 17 мар. 2020 г., 04:03:41

Var s : string ; i, n : integer ;

Begin read(s) ; for i : = 1 to length(s) do begin if s[i] = "(" then n = n + 1 ; if s[i] = ")" then n = n - 1 ; if n< ; 0 thenbegin Write("нет баланса") ; halt ; end ; Write("есть баланс") ;

End.

Tagir10112002 1 сент. 2020 г., 16:04:17 | 5 - 9 классы

Объясните, почему не получается открыть файл html в виде сайта, а открывается текст, который был вбит в текстовом редакторе?

Объясните, почему не получается открыть файл html в виде сайта, а открывается текст, который был вбит в текстовом редакторе?

Damelenkow 5 янв. 2020 г., 00:01:50 | 10 - 11 классы

Объекты двух классов в отношении взаимного однозначного соответствия?

Объекты двух классов в отношении взаимного однозначного соответствия.

Nastyamotygina 19 окт. 2020 г., 10:21:19 | 10 - 11 классы

Установите соответствие между двумерным массивом и фрагментом алгоритма его задающим, представленным на алгоритмическом языке?

Установите соответствие между двумерным массивом и фрагментом алгоритма его задающим, представленным на алгоритмическом языке.

Bors73 1 мая 2020 г., 14:40:11 | 5 - 9 классы

Как открываются и закрываются документы и программы?

Как открываются и закрываются документы и программы?

ПОЛНЫЙ ОТВЕТ, ПОЖАЛУЙСТА : ).

Катюша25022001 1 февр. 2020 г., 03:47:19 | 5 - 9 классы

Написать исходный код в Pascal - е?

Написать исходный код в Pascal - е.

Решить задачу по обработке строковых данных с использованием подпрограмм : В строке, среди знаков могут встречаться открывающие и закрывающие скобки.

Проверить с помощью подпрограммы равенство числа открывающихся скобок числу закрывающихся.

Leowr 24 авг. 2020 г., 00:37:38 | 5 - 9 классы

1. Дана строка символов?

1. Дана строка символов.

Напечатать новый текст, удалив из старого символы, находящиеся внутри круглых скобок.

Скобки тоже удалить.

Подсчитать количество удалённых символов.

Предполагается, что внутри каждой пары скобок других скобок нет 2.

Начертите блок - схему и напишите паскаль - программу для решения следующей задачи : «Ввести текст длиной до 254 символов.

Вывести на экран слова, начинающиеся с заглавной буквы.

Количество таких слов также вывести на экран».

Нужна полностью написанная программа.

Enjegilmanova 22 мая 2020 г., 04:54:16 | 10 - 11 классы

Кому не сложно помочь с PascalABC?

Кому не сложно помочь с PascalABC?

Дана строка.

Некоторые из слов взяты в круглые скобки.

Написать программу, выводящую исходную строку без скобок.

Vovashostka 22 сент. 2020 г., 22:43:21 | 5 - 9 классы

Почему моя презентация, недавно созданная, не открывается, а пишет, что это файл, а хотя презентация?

Почему моя презентация, недавно созданная, не открывается, а пишет, что это файл, а хотя презентация?

Что делать?

Annavsevolodova 30 авг. 2020 г., 01:08:58 | 5 - 9 классы

Ответьте на вопросы пожалуйста?

Ответьте на вопросы пожалуйста!

1. Укажите лишнее среди объектов Рабочего стола.

А. Панель инструментов.

В. Значки объектов.

C. Панель задач.

D. Кнопка Пуск.

2. Область экрана, где можно увидеть часы, называется :

А.

Рабочий стол.

В. Панель задач.

С. Главное меню.

D. Значки объектов.

3. Для выключения компьютера достаточно :

А.

Выбрать соответствующую команду в Главном меню.

В. Нажать кнопку выключения на системном блоке компьютера.

С. Воспользоваться значком мой компьютер.

D. Использовать языковую панель.

4. Для вызова Главного меню надо :

А.

Открыть Мой компьютер.

В. Нажать кнопку Пуск.

С. Открыть Панель задач.

D. Открыть Корзину.

5. Команда Документы Главного меню :

А.

Открываем Библеотеку Музыка.

В. Позволяем провести поиск файлов.

С. Открываем Библеотеку Изображения.

D. Открываем Библеотеку Документы.

6. Команда Изображения Главного меню :

А.

Открываем Библеотеку Музыка.

В. Открываем Библеотеку Документы.

С. Открываем Библеотеку Изображения.

D. Позволяет провести поиск файлов.

7. Команда Панель управления Главного меню :

А.

Настраивает параметры компьютера.

В. Позволяем провести поиск файлов.

С. Открываем Библеотеку Изображения.

D. Выводит окно для настройки принтера.

Danka1806 24 окт. 2020 г., 03:14:09 | 1 - 4 классы

Как сделать, чтоб при нажатии на ссылку, открывалось другое окно(HTML)?

Как сделать, чтоб при нажатии на ссылку, открывалось другое окно(HTML)?

На странице вопроса Задан фрагмент текста? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.