С клавиатуры вводится три строки вида Фамилия пробел Имя пробел Рост?

Информатика | 5 - 9 классы

С клавиатуры вводится три строки вида Фамилия пробел Имя пробел Рост.

Определить фамилию и имя самого высокого человека d pascal abc.

Ответить на вопрос
Ответы (1)
Лизааааааашпвосв 11 янв. 2020 г., 12:56:46

Type str = array [1.

100] of char ;

var maxs, tmps : str ;

count, max, tmp, ctmp : integer ;

procedure reads (var s : str ; var len, val : integer) ;

var

b : boolean ;

c : char ;

i : integer ;

begin

i : = 0 ; b : = false ;

repeat read (c) ; if not b or (c < ; > ; ' ') then

begin if c = ' ' then b : = true ; inc (i) ; s[i] : = c ; c : = '1' ; end ;

until b and (c = ' ') ; len : = i ;

readln (val) ;

end ;

begin

assign (input, 'input.

Txt') ; reset (input) ; reads (maxs, count, max) ;

while not eof do

begin

reads (tmps, ctmp, tmp) ; if tmp > ; max then

begin

max : = tmp ;

count : = ctmp ;

maxs : = tmps ; end ;

end ;

for tmp : = 1 to count do write (maxs[tmp]) ;

end.

Orehov10 3 нояб. 2020 г., 14:16:58 | 5 - 9 классы

Помогите составить программу по информатике в Pascal ABC?

Помогите составить программу по информатике в Pascal ABC.

Задание 1.

С клавиатуры одной строковой вводят имя и фамилию.

Составьте программу, которая : а) определяет, есть ли в определенной строке заданный символ ; б) копирует в новую строку имя и выводит его ; в) выводит сначала фамилию, а затем имя.

Задание 2.

Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на.

123tyi 17 июл. 2020 г., 13:12:03 | 10 - 11 классы

Помогите плз сделать домашку по информатике))) с клавиатуры одной строкой вводят имя и фамилию?

Помогите плз сделать домашку по информатике))) с клавиатуры одной строкой вводят имя и фамилию.

Составьте программу, которая : а) определяет, есть ли во введенной строке заданный символ б) копирует в новую строку имя и выводит его в) выводит сначала фамилию, а затем имя.

Vikusiy 28 сент. 2020 г., 20:56:30 | 10 - 11 классы

С клавиатуры одной строкой вводят имя и фамилию?

С клавиатуры одной строкой вводят имя и фамилию.

Составьте программу, которая выводит сначала фамилию, а потом имя.

ПНПУКН55444 8 авг. 2020 г., 11:51:31 | 10 - 11 классы

С клавиатуру вводится строка?

С клавиатуру вводится строка.

Определить в ней количество пробелов.

Angelika7070 30 окт. 2020 г., 20:32:41 | 10 - 11 классы

На вход подается строка имеющая вид : ФАМИЛИЯ ИМЯ БАЛЛ1 БАЛЛ 2 ФАМИЛИЯ ИМЯ?

На вход подается строка имеющая вид : ФАМИЛИЯ ИМЯ БАЛЛ1 БАЛЛ 2 ФАМИЛИЯ ИМЯ.

Где балл1 и балл2 - баллы предметов.

Надо написать программу, показывающую имена и фамилии ненабравших мин.

Балла - 30.

Еваника 10 мар. 2020 г., 08:55:01 | 5 - 9 классы

С клавиатуры вводится строка состоящая из букв, знака пробела и циифр?

С клавиатуры вводится строка состоящая из букв, знака пробела и циифр.

Определите количество цифр в этой строке.

Оксана54321 16 июл. 2020 г., 16:21:41 | 10 - 11 классы

Тема - обработка символьных величин на Паскале?

Тема - обработка символьных величин на Паскале.

Ввести свою фамилию, имя и отчество как одно текстовое данное, используя пробел как разделитель.

Вывести на экран - фамилию ; - имя ; - фамилию и инициалы.

Не понимаю, если я даже и начну выводить фамилию, как сделать так.

Чтобы выделялось только до пробела?

Ведь фамилии у всех разные.

А программа должна быть универсальной для всех фамилий (т.

Е. фамилия вводится с клавиатуры).

СинийШар 15 янв. 2020 г., 00:09:44 | 10 - 11 классы

Составьте программу которая находит позицию пробела в строке s состоящей из двух слов разделенных пробелом?

Составьте программу которая находит позицию пробела в строке s состоящей из двух слов разделенных пробелом.

Строка вводится с клавиатуры.

Alagoryachkina 26 авг. 2020 г., 04:58:51 | 5 - 9 классы

Как создать программу в VBA которой в блоке ввода данных будет вводиться фамилия и имя , а в блоке вывода фраза " Приветствую , Фамилия Имя"?

Как создать программу в VBA которой в блоке ввода данных будет вводиться фамилия и имя , а в блоке вывода фраза " Приветствую , Фамилия Имя".

Где вместо фамилии и имя введенные данные .

Dadonovaarina 23 дек. 2020 г., 07:48:20 | 5 - 9 классы

Напишите программу на питоне, пожалуйстаПрограмма получает на вход строку в формате "Фамилия, Отчество Имя"?

Напишите программу на питоне, пожалуйста

Программа получает на вход строку в формате "Фамилия, Отчество Имя".

Фамилия от отчества отделяется запятой и пробелом.

Отчество от имени отделяется пробелом.

Напишите программы, которая выводит строку в формате "Фамилия Имя Отчество" разделяемые пробелом.

На этой странице сайта вы найдете ответы на вопрос С клавиатуры вводится три строки вида Фамилия пробел Имя пробел Рост?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.