Помогите написать программу на PascalABCNET ВХОДНЫЕ ДАННЫЕ Дано целое число A и целое неотрицательное число i?

Информатика | 10 - 11 классы

Помогите написать программу на PascalABCNET ВХОДНЫЕ ДАННЫЕ Дано целое число A и целое неотрицательное число i.

ВЫХОДНЫЕ ДАННЫЕ Выведите значение i - ого бита числа A (0 или 1).

Ответить на вопрос
Ответы (1)
Рыльцева 4 янв. 2020 г., 23:06:03

Function Dec2Bin(n : longint) : string ;

{ Перевод натурального десятичного n в систему счисления по основанию 2 }

var s : string ;

begin s : = '' ; while n > ; 0 do begin if Odd(n) then s : = '1' + s else s : = '0' + s ; n : = n div 2 end ; Dec2Bin : = s ;

end ;

var A : longint ; i, k : integer ; s : string ;

begin Write('Введите натуральное число А : ') ; Read(A) ; Write('Введите номер бита i (счет с 1 справа налево) : ') ; Read(i) ; s : = Dec2Bin(A) ; k : = Length(s) ; if (i> ; 0) and (i< ; = k) then Writeln('Значение бита : ', s[k + 1 - i]) else Writeln('Неверный номер бита')

end.

Тестовое решение :

Введите натуральное число А : 37

Введите номер бита i (счет с 1 справа налево) : 5

Значение бита : 0.

Www1955 6 дек. 2020 г., 22:51:23 | 5 - 9 классы

Даны два натуральных числа n и m?

Даны два натуральных числа n и m.

Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число.

Входные данные Вводятся два числа.

Выходные данные Выведите ответ на задачу.

(Примеры : входные данные - 2, 8.

Выходные - 1).

P. S.

Решить надо в Паскаль АБЦ!

Halmetova2000 3 мар. 2020 г., 05:26:02 | 5 - 9 классы

Решить в Паскаль АБЦ?

Решить в Паскаль АБЦ!

Даны два натуральных числа n и m.

Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число.

"Входные данные" Вводятся два числа.

"Выходные данные" Выведите ответ на задачу.

(Примеры : входные - 2, 8.

Выходные - 1).

DimaDey 13 февр. 2020 г., 02:59:01 | 5 - 9 классы

Выведите число, поданное на ввод?

Выведите число, поданное на ввод.

ВХОДНЫЕ ДАННЫЕ Одно целое положительное число, не превышающее 1000.

Одно целое положительное число, не превышающее 1000.

ВЫХОДНЫЕ ДАННЫЕ Выведите то же самое число.

На языке С.

Schura97 3 июл. 2020 г., 10:20:09 | 10 - 11 классы

Помогите написать программу на PascalABCNET ВХОДНЫЕ ДАННЫЕ Задано натуральное число N?

Помогите написать программу на PascalABCNET ВХОДНЫЕ ДАННЫЕ Задано натуральное число N.

ВЫХОДНЫЕ ДАННЫЕ Определите количество нулей в его записи.

Ilililililil 19 окт. 2020 г., 06:29:49 | 5 - 9 классы

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ?

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ!

25баллов Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

Входные данные Задано единственное целое число N Выходные данные Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Примеры входные данные 15 выходные данные 1 4 9.

Gramotey2281 9 окт. 2020 г., 07:16:58 | 5 - 9 классы

Задана последовательность неотрицательных целых чисел?

Задана последовательность неотрицательных целых чисел.

Требуется определить длину последовательности, завершающуюся первым встретившимся нолем (число 0 не входит в последовательность).

Входные данные Входной файл INPUT.

TXT содержит последовательность неотрицательных целых чисел, не превышающих значения 100.

Гарантируется, что во входных данных не более 100 чисел и среди них есть хотя бы одно число 0.

Выходные данные В выходной файл OUTPUT.

TXT выведите целое число – длину последовательности.

Пожалуйста решите, на C + + или на Pascal.

Delkup 2 сент. 2020 г., 23:37:51 | 5 - 9 классы

Напишите программу, которая считывает два целых числа a и b и выводит наибольшее значение из них?

Напишите программу, которая считывает два целых числа a и b и выводит наибольшее значение из них.

Числа — целые от 1 до 1000.

При решении задачи можно пользоваться только целочисленными арифметическими операциями + , - , * , / / , %, = .

Нельзя пользоваться нелинейными конструкциями : ветвлениями, циклами, функциями вычисления модуля, извлечения квадратного корня.

Использование функции max запрещено!

Входные данные Вводятся два целых числа a и b.

Выходные данные Выведите ответ на задачу.

Примеры входные данные 8 5 выходные данные 8 входные данные 5 8 выходные данные 8 входные данные 5 5 выходные данные 5 Заранее спасибо.

: - ).

Kisaa00101 10 нояб. 2020 г., 04:12:57 | 5 - 9 классы

Даны два целых числа от 1 до 1 000 000 000?

Даны два целых числа от 1 до 1 000 000 000.

Найти сумму этих чисел.

Входные данные : два целых числа.

Выходные данные : целое число.

На Паскале.

ТАРАНТУЛ2004 25 дек. 2020 г., 10:54:01 | 5 - 9 классы

Напишите программу в Boland Pascal?

Напишите программу в Boland Pascal.

ЗАДАНО ТРЕХЗНАЧное числою напечатать в обратном порядке .

Входные данные Целое трехзначное число.

Выходные данные Целое трехзначное число напечатать в обратном порядке Пример входных данных423 .

Пример выходных данных 324.

12345678164 29 нояб. 2020 г., 12:16:09 | 5 - 9 классы

Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке?

Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке.

Последовательность завершается числом 0, при считывании которого программа должна закончить свою работу и вывести количество членов последовательности (не считая завершающего числа 0).

Числа, следующие за числом 0, считывать не нужно.

Входные данные

Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит).

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

1

7

9

0

5

выходные данные

3.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Помогите написать программу на PascalABCNET ВХОДНЫЕ ДАННЫЕ Дано целое число A и целое неотрицательное число i?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.