Составить программу которая копирует из строки заданный символ и подсчитывает число его вхождений (, )?

Информатика | 10 - 11 классы

Составить программу которая копирует из строки заданный символ и подсчитывает число его вхождений (, ).

Ответить на вопрос
Ответы (1)
Bekky 2 апр. 2020 г., 12:19:30

/ / Huh, if my Master wants.

Var s, s1, s2 : string ;

begin ;

write('String : ') ;

readln(s) ;

write('Substring : ') ;

readln(s1) ;

if length(s1)< ; > ; 1 then exit ;

while pos(s1, s)< ; > ; 0 do

begin ;

s2 : = s2 + s[pos(s1, s)] ;

delete(s, pos(s1, s), 1) ;

end ;

write('Result : ', length(s2)) ;

end.

Orehov10 3 нояб. 2020 г., 14:16:58 | 5 - 9 классы

Помогите составить программу по информатике в Pascal ABC?

Помогите составить программу по информатике в Pascal ABC.

Задание 1.

С клавиатуры одной строковой вводят имя и фамилию.

Составьте программу, которая : а) определяет, есть ли в определенной строке заданный символ ; б) копирует в новую строку имя и выводит его ; в) выводит сначала фамилию, а затем имя.

Задание 2.

Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на.

123tyi 17 июл. 2020 г., 13:12:03 | 10 - 11 классы

Помогите плз сделать домашку по информатике))) с клавиатуры одной строкой вводят имя и фамилию?

Помогите плз сделать домашку по информатике))) с клавиатуры одной строкой вводят имя и фамилию.

Составьте программу, которая : а) определяет, есть ли во введенной строке заданный символ б) копирует в новую строку имя и выводит его в) выводит сначала фамилию, а затем имя.

Masia123456789 15 окт. 2020 г., 20:40:44 | 5 - 9 классы

Срочно нужна помощь?

Срочно нужна помощь!

1. С клавиатуры вводят слово и символ.

Составть программу, которая :

а) проверяет, есть ли в этом слове заданный символ ;

б) определяет позицию заданного символа ;

в) подсчитывает количество вхождений заданного символа.

2. С клавиатуры вводят строку и слово.

Составть программу, которая :

а) определяет позицию заданного слова ;

б) удаляет заданное слово ;

в) вставляет в строку заданное слово.

3. Составть программу, которая :

а) из строки "Волга, Днепр, Неман, Енисей" удаляет названия рек, не протекающих по территории Беларуси ;

б) из строки "Брест, Бобруйск, Витебск, Гомель, Мозырь, Могилев" удаляет названия городов, не являющихся областными центрами.

4. Составть программу, которая :

а) в строке "край озер" добавляет слова "лесов и рек" ;

б) в строке "я учусь в школе" заменить слова "в школе" на "в 10 - ом классе".

5. Составть программу, которая переставляет на первое место :

а) в строке "моя родина Беларусь" слово "Беларусь" ; б) в строке "люблю цябе мой родны кут" слова "мой родны кут".

Vikaviking 12 янв. 2020 г., 10:53:41 | 10 - 11 классы

Cтроки?

Cтроки.

Паскаль.

1. Задано слово - последовательность произвольных символов.

Сделать программу, в которой составляется слово перевертыш к данному ( символы записываются в обратной последовательности.

) 2. Дана символьная строка.

Слово - последовательность символов между пробелами, не содержащая пробелы внутри себя.

Составить программу, в которой выводились бы все слова, в которых есть заданный символ.

Katyabulanova 18 нояб. 2020 г., 20:22:27 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составить программу, которая : а)проверяет есть ли в этом слове заданный символ б)определяет позицию заданного символа в)подсчитывает количество вхождений заданного символа.

GIRL99love 5 мая 2020 г., 20:10:13 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составте программу которая : подсчитывает количество вхождений заданного символа.

Оскана 7 мая 2020 г., 12:16:13 | 10 - 11 классы

Составить программу, которая считает количество вхождений буквы а в заданном тексте?

Составить программу, которая считает количество вхождений буквы а в заданном тексте.

В паскель.

Nikiton0200 28 нояб. 2020 г., 13:18:54 | 5 - 9 классы

Дана строка ?

Дана строка .

Написать программу, которая подсчитывает количество символов "?

" (pascal abc) помогите пожалуйста!

Golden6 3 окт. 2020 г., 07:48:36 | 10 - 11 классы

Составить программу которая удаляет из заданной строки заданное слово паскаль?

Составить программу которая удаляет из заданной строки заданное слово паскаль.

Veronika123000 27 апр. 2020 г., 23:41:03 | 10 - 11 классы

Pascal?

Pascal.

Напишите программу , которая из заданной строки удаляет числа.

На этой странице находится ответ на вопрос Составить программу которая копирует из строки заданный символ и подсчитывает число его вхождений (, )?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.