Срочно нужна помощь?

Информатика | 5 - 9 классы

Срочно нужна помощь!

1. С клавиатуры вводят слово и символ.

Составть программу, которая :

а) проверяет, есть ли в этом слове заданный символ ;

б) определяет позицию заданного символа ;

в) подсчитывает количество вхождений заданного символа.

2. С клавиатуры вводят строку и слово.

Составть программу, которая :

а) определяет позицию заданного слова ;

б) удаляет заданное слово ;

в) вставляет в строку заданное слово.

3. Составть программу, которая :

а) из строки "Волга, Днепр, Неман, Енисей" удаляет названия рек, не протекающих по территории Беларуси ;

б) из строки "Брест, Бобруйск, Витебск, Гомель, Мозырь, Могилев" удаляет названия городов, не являющихся областными центрами.

4. Составть программу, которая :

а) в строке "край озер" добавляет слова "лесов и рек" ;

б) в строке "я учусь в школе" заменить слова "в школе" на "в 10 - ом классе".

5. Составть программу, которая переставляет на первое место :

а) в строке "моя родина Беларусь" слово "Беларусь" ; б) в строке "люблю цябе мой родны кут" слова "мой родны кут".

Ответить на вопрос
Ответы (1)
Averilia123 15 окт. 2020 г., 20:40:48

Программа №4

Program str999 ; Uses CRT ; Var s : String ; Begin Writeln('Введіте фразу') ; read(s) ; if (s = 'край озер') then writeln ('Край озер лесов и рек') ; if (s = 'Я учусь в школе') then writeln ('Я учусь в 10 - м классе') end.

Задание №5

Program p_1 ; Uses CRT ; Var s : String ; Begin Writeln('Введите фразу') ; read(s) ; if (s = 'моя родина Беларусь') then writeln ('Беларусь моя родина') ; if (s = 'люблю цябе мой родны кут') then writeln ('мой родны кут люблю цябе')

end.

Hazeevar79 20 дек. 2020 г., 12:41:51 | 10 - 11 классы

С клавиатуры вводится строка?

С клавиатуры вводится строка.

С новой строки вводится буква.

Составьте программу подсчета количества заданных букв в заданной строке.

Определить, является ли длина введенного слова числом, кратным трем.

Определить, заканчивается ли введенное слово гласной буквой.

Rudywade 13 янв. 2020 г., 14:58:31 | 10 - 11 классы

Заданы М строк слов, которые вводятся с клавиатуры?

Заданы М строк слов, которые вводятся с клавиатуры.

Подсчитать количество гласных букв в каждой из заданных строк.

Zarina97zaza 20 апр. 2020 г., 18:38:56 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составьте программу, которая : проверяет, есть ли в этом слове заданный символ.

Ketymailcom 14 июн. 2020 г., 00:15:58 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составьте программу, которая определяет позицию заданного символа.

Идиото 4 апр. 2020 г., 08:03:45 | 10 - 11 классы

1. С клавиатуры вводится слово, распечатать все его буквы через пробел?

1. С клавиатуры вводится слово, распечатать все его буквы через пробел.

(после последней буквы пробела быть не должно).

2. Написать программу, которая удаляет первое слово из строки введенной с клавиатуры и вместо него вставляет заданное.

Katyabulanova 18 нояб. 2020 г., 20:22:27 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составить программу, которая : а)проверяет есть ли в этом слове заданный символ б)определяет позицию заданного символа в)подсчитывает количество вхождений заданного символа.

GIRL99love 5 мая 2020 г., 20:10:13 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составте программу которая : подсчитывает количество вхождений заданного символа.

Nohchi958795 2 апр. 2020 г., 12:19:25 | 10 - 11 классы

Составить программу которая копирует из строки заданный символ и подсчитывает число его вхождений (, )?

Составить программу которая копирует из строки заданный символ и подсчитывает число его вхождений (, ).

Golden6 3 окт. 2020 г., 07:48:36 | 10 - 11 классы

Составить программу которая удаляет из заданной строки заданное слово паскаль?

Составить программу которая удаляет из заданной строки заданное слово паскаль.

Veronika123000 27 апр. 2020 г., 23:41:03 | 10 - 11 классы

Pascal?

Pascal.

Напишите программу , которая из заданной строки удаляет числа.

Вопрос Срочно нужна помощь?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.