Даны два одномерных массива из целых чисел разной размерности?

Информатика | 5 - 9 классы

Даны два одномерных массива из целых чисел разной размерности.

Найти целую часть среднего арифметического элементов каждого массива и их сумму.

Помогите написать программу в паскале.

Ответить на вопрос
Ответы (1)
Orangeboxw31 6 янв. 2020 г., 02:17:06

Const

n = 5 ; m = 7 ;

var

a : array[1.

N]of integer ;

b : array[1.

M]of integer ;

s, s2 : real ;

i : integer ;

begin for i : = 1 to n do begin a[i] : = random(50) ; write(a[i] : 4) ; s : = s + a[i] ; end ;

writeln ;

writeln(' : ', trunc(s / n)) ;

for i : = 1 to m do begin b[i] : = random(70) ; write(b[i] : 4) ; s2 : = s2 + b[i] ; end ;

writeln ;

writeln(' : ', trunc(s2 / m)) ;

writeln ;

writeln('s : ', trunc(s / n) + trunc(s2 / m)) ;

end.

IlyaBro 31 авг. 2020 г., 11:07:49 | 10 - 11 классы

Даны два одномерных массива из целых чисел, разной размерности?

Даны два одномерных массива из целых чисел, разной размерности.

Найти целую часть среднего арифмитического элементов каждого массива и их сумму.

Миньон4 2 янв. 2020 г., 08:46:10 | 10 - 11 классы

Дан массив всех целых чисел ?

Дан массив всех целых чисел .

Найти сумму элементов в массиве.

(Паскаль).

Ariname 14 мая 2020 г., 07:02:43 | 5 - 9 классы

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива?

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел, найти количество отрицательных элементов массива.

3. Дан массив целых чисел, найти количество чётных чисел в массиве.

Kerik612 28 сент. 2020 г., 08:08:23 | 10 - 11 классы

1) Найти сумму отрицательных элементов массива целых чисел?

1) Найти сумму отрицательных элементов массива целых чисел.

Размерность массива 10 .

Заполнение массива осуществить случайными числами от - 20 до 20 .

2) Найдите сумму чётных элементов массива целых чисел.

Размерность массива 20.

Заполнения массива осуществляется случайными числами от 15 до 25 .

Sofia20077115 19 апр. 2020 г., 14:45:18 | 5 - 9 классы

Для массива из 10 целых чисел?

Для массива из 10 целых чисел.

Найти сумму всех элементов, среднее арифметическое, наибольшее и наименьшее значение.

Диана200356 19 янв. 2020 г., 19:36:48 | 5 - 9 классы

Одномерные массивы?

Одномерные массивы.

Дан массив натуральных чисел, состоящий из n элементов.

Найти сумму элементов массива, кратных данному числу К.

(паскаль).

Krimordvinova8 29 янв. 2020 г., 05:06:08 | 10 - 11 классы

Найти среднее арифметическое элементов одномерного массива А10?

Найти среднее арифметическое элементов одномерного массива А10.

Составить программу.

Ovsyanikovanas 28 мар. 2020 г., 18:53:34 | 5 - 9 классы

Дан одномерный массив чисел?

Дан одномерный массив чисел.

Определить среднее арифметическое элементов массива.

Aylovat40 16 окт. 2020 г., 08:55:54 | 10 - 11 классы

Дан одномерный массив из 12 чисел?

Дан одномерный массив из 12 чисел.

Элементами массива являются целые числа.

Найти максимальный элемент указанного массива.

Turenko80 10 сент. 2020 г., 16:57:05 | 5 - 9 классы

Найти среднее арифметическое элементов целого массива кол - во элементов в массиве 8?

Найти среднее арифметическое элементов целого массива кол - во элементов в массиве 8.

Если вам необходимо получить ответ на вопрос Даны два одномерных массива из целых чисел разной размерности?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.