Найти все делители для заданного числа n?

Информатика | 10 - 11 классы

Найти все делители для заданного числа n.

Паскаль.

Ответить на вопрос
Ответы (1)
Bakharevam 12 июн. 2020 г., 22:25:37

Uses crt ;

var i, n, m : integer ;

begin

read(n) ;

m : = n ;

i : = 1 ;

while i< ; = m do

begin

if n mod i = 0 then

begin

write(i, ' ') ;

m : = (n div i) ;

end ;

i : = i + 1 ;

end ;

write(n) ;

end.

Azzar26 14 февр. 2020 г., 14:56:07 | 10 - 11 классы

Найдите произведение трёх чисел вводимых с клавиатуры при условии , что они больше заданного числа ( найти по программе паскаль )?

Найдите произведение трёх чисел вводимых с клавиатуры при условии , что они больше заданного числа ( найти по программе паскаль ).

Samitatokova 20 июл. 2020 г., 02:00:27 | 5 - 9 классы

Даны два числа?

Даны два числа.

Найти их наибольший общий делитель.

(Паскаль).

Mivan98 16 янв. 2020 г., 11:56:23 | 5 - 9 классы

Помогите решить задачу по ИВТ на языке паскаль?

Помогите решить задачу по ИВТ на языке паскаль.

Задано 3 числа найти наибольшее из них.

123mr 18 мар. 2020 г., 14:38:29 | 10 - 11 классы

Надо составить программу в паскале, в которой надо найти процент от заданного числа?

Надо составить программу в паскале, в которой надо найти процент от заданного числа.

Vavavalavaltos 17 сент. 2020 г., 04:43:46 | 10 - 11 классы

Помогите написать программы в паскаль, пожалуйста?

Помогите написать программы в паскаль, пожалуйста!

1. Дано число х.

Найти и вывести на экран все его делители и их сумму.

2. В промежутке от 1 до n вывести все числа, сумма делителей которых равна самому числу.

CatiCatX 22 окт. 2020 г., 23:16:34 | 5 - 9 классы

Как задать в Паскале, что переменная может быть любым числом?

Как задать в Паскале, что переменная может быть любым числом.

Preydadavid 21 сент. 2020 г., 21:18:24 | 10 - 11 классы

Найти все делители натурального числа n?

Найти все делители натурального числа n.

Решить через процедуру и функцию в паскале, помогите плиз.

Halyavin991 29 мар. 2020 г., 09:13:03 | 5 - 9 классы

Задано целое число?

Задано целое число.

Из данного числа сделать число - перевертыш на паскале.

Mur4ik313 23 июн. 2020 г., 08:38:00 | 5 - 9 классы

Дано натуральное число : а)получить все его делители б)найти сумму его делителей в)найти сумму его четных делителей г)определить количество его нечетных делителей е)определить количество его делителей?

Дано натуральное число : а)получить все его делители б)найти сумму его делителей в)найти сумму его четных делителей г)определить количество его нечетных делителей е)определить количество его делителей.

Сколько из них четных?

Ж)найти количество его делителей, больших d" На ТУРБО ПАСКАЛЕ СРОЧНО!

Vlad16101 16 мая 2020 г., 01:06:56 | 10 - 11 классы

Как в Паскале задать случайное число?

Как в Паскале задать случайное число?

Вопрос Найти все делители для заданного числа n?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.