Дано натуральное число : а)получить все его делители б)найти сумму его делителей в)найти сумму его четных делителей г)определить количество его нечетных делителей е)определить количество его делителей?

Информатика | 5 - 9 классы

Дано натуральное число : а)получить все его делители б)найти сумму его делителей в)найти сумму его четных делителей г)определить количество его нечетных делителей е)определить количество его делителей.

Сколько из них четных?

Ж)найти количество его делителей, больших d" На ТУРБО ПАСКАЛЕ СРОЧНО!

Ответить на вопрос
Ответы (1)
Илюсик 23 июн. 2020 г., 08:38:07

Var a, b, c, d, i, f, g, h, n : integer ;

begin

writeln('введите число') ;

readln(a) ;

g : = 0 ;

c : = 0 ;

d : = 0 ;

i : = 0 ;

f : = 0 ;

writeln('введите число для сравнения') ;

readln(h) ;

for b : = a downto 1 do begin

if a mod b = 0 then writeln('его делитель = = > ; ', b) ;

if a mod b = 0 then c : = b + c ;

if a mod b = 0 then if b mod 2 = 0 then d : = d + b ;

if a mod b = 0 then if b mod 2 < ; > ; 0 then i : = i + 1 ;

if a mod b = 0 then f : = f + 1 ;

if a mod b = 0 then if b mod 2 = 0 then g : = g + 1 ; i

f a mod b = 0 then if b> ; h then n : = n + 1 ;

end ;

writeln('сумма его делителей = = > ; ', c) ;

writeln('сумма его чётных делителей = = > ; ', d) ;

writeln('количество нечётных делителей = = > ; ', i) ;

writeln('количество чётных делителей = = > ; ', g) ;

writeln('количество делителей = = > ; ', f) ;

writeln('количество делителей больших b = = > ; ', n) ;

end.

Nastya132000 1 сент. 2020 г., 01:35:08 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Определить количество его нечетных делителей.

Написать программу паскаль).

Пустой 15 мар. 2020 г., 10:32:37 | 5 - 9 классы

Найти количество делителей натурального числа А, больших К?

Найти количество делителей натурального числа А, больших К.

(А и К вводятся с клавиатуры, K< ; = A).

Код должен быть написан на языке Паскаля (Pascal).

Vavavalavaltos 17 сент. 2020 г., 04:43:46 | 10 - 11 классы

Помогите написать программы в паскаль, пожалуйста?

Помогите написать программы в паскаль, пожалуйста!

1. Дано число х.

Найти и вывести на экран все его делители и их сумму.

2. В промежутке от 1 до n вывести все числа, сумма делителей которых равна самому числу.

Kiborg113 9 авг. 2020 г., 01:39:35 | 5 - 9 классы

Найти количество делителей натурального числа?

Найти количество делителей натурального числа.

Сколько из них четных?

Решить в Turbo Pascal, без массивов.

Срочно, ПОЖАЛУЙСТА.

Нежданка 5 июн. 2020 г., 23:48:41 | 10 - 11 классы

Дано натуральное число, подсчитать общее количество его делителей?

Дано натуральное число, подсчитать общее количество его делителей.

Помогите пожалуйста.

Pascal.

Mikki01 26 июн. 2020 г., 06:52:56 | 5 - 9 классы

Найти кол - во нечетных делителей числа больших К?

Найти кол - во нечетных делителей числа больших К.

Помогите.

Denizqamzaeva 28 дек. 2020 г., 13:57:24 | 5 - 9 классы

Найти сумму делителей данного натурального числа?

Найти сумму делителей данного натурального числа.

Prishchepa 10 авг. 2020 г., 22:27:07 | 10 - 11 классы

3. Дано натуральное число?

3. Дано натуральное число.

Найти сумму его четных делителей и количество этих делителей.

Random73 12 февр. 2020 г., 02:06:22 | 10 - 11 классы

Плииииизз Составить программу с помощью процедуры?

Плииииизз Составить программу с помощью процедуры.

Дано число, найти все его делители и подсчитать их количество.

Tanyaturyanskay 9 нояб. 2020 г., 14:59:26 | 5 - 9 классы

Срочно нужна помощь?

Срочно нужна помощь!

Borland Pascal

Задача :

С клавиатуры вводится целое число.

Найти его :

1) делители

2)сумму делителей

3)четные делители

4)нечетные делители

5)делитель больше заданного

Абсолютно ничего не понимаю, желательно начать прямо с program и тд, короче абсолютно все то, что должно появится на экране.

Тут надо с For, If.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Дано натуральное число : а)получить все его делители б)найти сумму его делителей в)найти сумму его четных делителей г)определить количество его нечетных делителей е)определить количество его делителей?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.