Поменять местами минимальный и первый элементы массива?

Информатика | 5 - 9 классы

Поменять местами минимальный и первый элементы массива.

Ответить на вопрос
Ответы (1)
Lia1503 26 мар. 2020 г., 15:00:21

Program a1 ;

var y : array[1.

14] of integer ; k, s1, s2 : byte ; minY, maxY, m : integer ;

begin

writeln('Vvedite massiv Y : ') ; {просим ввести массив}

for k : = 1 to 14 do read(y[k]) ; {записываем массив}

s1 : = 0 ; s2 : = 0 ; {счётчики на 0}

minY : = y[1] ; {присваиваем первому значению минимум.

}

for k : = 2 to 14 do begin if y[k] < ; minY then degin minY : = y[k] ; s1 : = s1 + 1 ; end ; {если есть меньше, то присваиваем}

maxY : = y[1] ; {присваиваем второму значению максимум.

> ; < ; }

for k : = 2 to 14 do begin if y[k] > ; maxY then degin maxY : = y[k] ; s2 : = s2 + 1 ; end ; {если есть больше, то присваиваем}

m : = y[s1] ; {используя переменную m меняем местами элементы}

y[s1] : = y[s2] ;

y[s2] : = m ;

writeln('Novyi massiv : ') ;

for k : = 1 to 14 do write(y[k], ' ') ; {выводим новый массив}

readln

end.

Spectorsin 28 июл. 2020 г., 23:16:56 | 5 - 9 классы

Составить программу в массиве с N числами поменять местами максимальное и минимальное значения?

Составить программу в массиве с N числами поменять местами максимальное и минимальное значения.

Katyahey 17 нояб. 2020 г., 17:52:13 | 10 - 11 классы

В массиве А(N) поменяйте местами первый отрицательный и минимальный элементы?

В массиве А(N) поменяйте местами первый отрицательный и минимальный элементы.

Kunsaule13 10 нояб. 2020 г., 02:35:41 | 10 - 11 классы

Найти среднее арифмитическое элементов массива из 10 элементов и записать его на место минимального элемента?

Найти среднее арифмитическое элементов массива из 10 элементов и записать его на место минимального элемента.

(с + + ).

Елизаветаа654 26 февр. 2020 г., 21:17:46 | 5 - 9 классы

Дан массив целых чисел?

Дан массив целых чисел.

Поменять местами первый максимальный (если таковых несколько) и последний минимальный (если таковых несколько) по значению элементы массива.

Число элементов в массиве не более 10 - ти Pascal.

Дулат2002 8 сент. 2020 г., 00:15:16 | 5 - 9 классы

Составить программу в массиве с N числами поменять местами максимальное и минимальное значения?

Составить программу в массиве с N числами поменять местами максимальное и минимальное значения.

Olgapirog163 19 мар. 2020 г., 06:29:50 | 10 - 11 классы

Помогите пожалуйста : записать чётные положительные элементы целочисленных массивов X и Y в массив Z?

Помогите пожалуйста : записать чётные положительные элементы целочисленных массивов X и Y в массив Z.

Поменять минимальный и максимальный элементы массива Z.

Вывести элементы массива Z в четверичной системе счисления .

Gaben345 24 дек. 2020 г., 08:36:03 | 10 - 11 классы

. Поменять местами минимальные и максимальные элементы?

. Поменять местами минимальные и максимальные элементы.

Natalla17 17 авг. 2020 г., 18:29:55 | 5 - 9 классы

В заданном одномерном массиве поменять местами соседние элементы?

В заданном одномерном массиве поменять местами соседние элементы.

(паскаль).

Coolalena200 17 окт. 2020 г., 17:57:45 | 10 - 11 классы

Помогите решить задачи в Pascal 1?

Помогите решить задачи в Pascal 1.

Поменять местами максимальный и минимальный элемент массива.

2. Вывести четные числа среди положительных элементов 3.

Напечатать сумму и номера положительных элементов после первого нулевого элемента.

Cat200235 10 июл. 2020 г., 02:03:00 | 5 - 9 классы

Дано : Массивы А(10), В(15)?

Дано : Массивы А(10), В(15).

Поменять местами их первые положительные элементы .

Для нахождения первого положительного элемента и его номера в массиве использовать подпрограмму.

Сделать в паскале.

Вы открыли страницу вопроса Поменять местами минимальный и первый элементы массива?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.