Задан одномерный массив А(N) (N< ; = 60)?

Информатика | 10 - 11 классы

Задан одномерный массив А(N) (N< ; = 60).

На место минимального элемента массива записать сумму последних К элементов массива.

Если А[1]> ; = 0, то умножить все элементы этого массива на квадрат минимального элемента данного вектора, а если А[1]< ; 0, то умножить все элементы на квадрат максимального элемента вектора.

Полученный массив распечатать.

Значение К вводится пользователем.

Ответить на вопрос
Ответы (1)
Lorekss 13 мар. 2020 г., 18:31:09

Var

A : array[1.

60] of integer ;

k, i, MIN, ind, MAX, SUM : integer ;

begin

SUM : = 0 ;

readln(k) ;

randomize ;

writeln('Исходный массив : ') ;

for i : = 1 to 60 do begin A[i] : = random(15) - 5 ; Writeln('A[', i, '] = ', A[i]) ; end ;

MIN : = 32600 ;

MAX : = - 32600 ;

for i : = 1 to 60 do / / Ищем минимальный элемент begin if a[i]< ; MIN then MIN : = a[i] ; ind : = i ; end ;

for i : = 1 to 60 do / / Ищем максимальный элемент if a[i]> ; MAX then MAX : = a[i] ;

for i : = 60 downto 60 - k do / / Сумма последних kэлементов SUM : = SUM + a[i] ;

A[ind] : = SUM ;

if A[1]> ; = 0 then

for i : = 1 to 60 do begin A[i] : = A[i] * sqr(MIN) ; Writeln('A[', i, '] = ', A[i]) ; end

else for i : = 1 to 60 do begin A[i] : = A[i] * sqr(MAX) ; Writeln('A[', i, '] = ', A[i]) ; end ;

end.

Furmanov76 25 июл. 2020 г., 23:57:32 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста.

Вот задача : Дан одномерный массив, состоящий из 10 элементов.

Определить минимальный элемент этого массива.

Olegkudarbekov 12 июл. 2020 г., 05:41:52 | 5 - 9 классы

Дан одновременный массив, состоящий из 10 эллементов?

Дан одновременный массив, состоящий из 10 эллементов.

Пользователь вводит элементы массива.

Ввести массив на экран в строку.

Найти минимальный элемент массива.

Ниже приведен рекомендованный вид экрана во время выполнения программы : Вывод минимального элемента массива Ввод элементов массива Введите 1 элемент массива : 1 Введите 2 элемент массива : 2 Введите 3 элемент массива : 3 и т.

Д. до 10.

Satusa 22 февр. 2020 г., 01:25:13 | 10 - 11 классы

Сформулируйте массив содержащий 15 элементов, с помощью датчика случайных чисел?

Сформулируйте массив содержащий 15 элементов, с помощью датчика случайных чисел.

Получите новый массив, каждый элемент которого равен квадрату соответствующего элемента исходного массива.

В полученном массиве определите насколько максимальный элемент исходного массива отличается от минимального элемента нового массива.

Выведите на экран исходные и полученные результаты.

Наташа678 5 мар. 2020 г., 15:48:56 | 5 - 9 классы

Дан массив с 50 элементами?

Дан массив с 50 элементами.

Найти максимальный элемент массива.

Используйте для ввода элементов массива функцию Random(x).

Kunsaule13 10 нояб. 2020 г., 02:35:41 | 10 - 11 классы

Найти среднее арифмитическое элементов массива из 10 элементов и записать его на место минимального элемента?

Найти среднее арифмитическое элементов массива из 10 элементов и записать его на место минимального элемента.

(с + + ).

Настя2005 3 янв. 2020 г., 06:37:14 | 5 - 9 классы

Дан одномерный массив, состоящий из вещественных элементов?

Дан одномерный массив, состоящий из вещественных элементов.

Найти сумму элементов массива, расположенных до последнего положительного элемента.

Катюшащенок 21 нояб. 2020 г., 01:23:06 | 10 - 11 классы

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элемен?

Помогите написать программу В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [ - 10 ; 10]), вычислить произведение элементов массива, расположенных между максимальным и минимальным элементами.

Сформировать из этих элементов новый массив.

Tamiktlekov 1 авг. 2020 г., 09:24:08 | 10 - 11 классы

Дан массив А(n)?

Дан массив А(n).

Уменьшить все его элементы на минимальный элемент массива.

Тёмапарамик 29 авг. 2020 г., 17:53:18 | 5 - 9 классы

Помогите?

Помогите!

Людиии!

1. Дан массив из 10 элементов.

Напечатать Все неотрицательные элементы массива.

2. Дан массив из 10 элементов.

Определить Минимальный элемент массива.

Osya00 4 дек. 2020 г., 15:10:44 | 10 - 11 классы

В одномерном массиве из 10 элементов определить местоположение минимального и максимального элементов?

В одномерном массиве из 10 элементов определить местоположение минимального и максимального элементов.

Обнулить элементы, стоящие между ними , а также вывести полученный массив.

Перед вами страница с вопросом Задан одномерный массив А(N) (N&lt ; = 60)?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.