Найти максимальный из элементов, имеющих четный индекс?

Информатика | 10 - 11 классы

Найти максимальный из элементов, имеющих четный индекс.

Пример : массив 7 2 6 5 4 4 10 3 9 элементы с четными индексами 2 5 4 3 максимальный из них 5.

Паскаль АВС.

Ответить на вопрос
Ответы (1)
137973232 23 июн. 2020 г., 03:41:34

Const n = 15 ;

var x : array[1.

N] of integer ; i, max : integer ;

begin Randomize ; Write('Элементы массива : ') ; for i : = 1 to n do begin x[i] : = Random(20) ; Write(x[i] : 3) end ; max : = x[2] ; i : = 4 ; while i < ; = n do begin if max < ; x[i] then max : = x[i] ; i : = i + 2 end ; Writeln ; Writeln('Max = ', max)

end.

Тестовое решение :

Элементы массива : 17 12 18 12 11 14 18 19 16 16 9 13 7 3 13

Max = 19.

Een929 11 июн. 2020 г., 12:23:29 | 10 - 11 классы

Паскаль?

Паскаль.

Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и четные, и нечетные элементы).

Marriza 15 дек. 2020 г., 00:03:17 | 5 - 9 классы

Дан массив состоящий из 6 - ти элементов : а)найти максимальный элемент массива б)найти сумму четных элементов и произведение не четных элементов?

Дан массив состоящий из 6 - ти элементов : а)найти максимальный элемент массива б)найти сумму четных элементов и произведение не четных элементов.

Top99 11 мая 2020 г., 13:38:51 | 5 - 9 классы

Как вывести элементы с четными значенииями и четными индексами в паскале?

Как вывести элементы с четными значенииями и четными индексами в паскале?

Klimova14355 7 янв. 2020 г., 18:01:34 | 10 - 11 классы

Дан массив из 10 целых чисел найти произведение элементов массива с четными индексами?

Дан массив из 10 целых чисел найти произведение элементов массива с четными индексами.

Полина2045 4 сент. 2020 г., 15:02:31 | 5 - 9 классы

Составте программу которая заполняет массив а 1?

Составте программу которая заполняет массив а 1.

10 случайными целыми числами в диапазоне от 0 до 10 и находит максимальный элемент массива среди элементов с четными индексами.

Vitaly198703 11 сент. 2020 г., 05:36:00 | 10 - 11 классы

Ввести два целочисленныхмассива − по 10 элементов в каждом?

Ввести два целочисленныхмассива − по 10 элементов в каждом.

Сформировать новый массив, на четных местах которого будут элементы с нечетными индексами из первого массива, а нанечетных – с четными индексами из второго.

Написать программу на паскале.

Wapiro 15 июн. 2020 г., 23:50:17 | 5 - 9 классы

Дан одномерный массив с индексами от 0 до 14, найти индекс минимального и максимального элементов массива(числа вводятся с клавиатуры)?

Дан одномерный массив с индексами от 0 до 14, найти индекс минимального и максимального элементов массива

(числа вводятся с клавиатуры).

Diana98n 10 июн. 2020 г., 21:33:13 | 10 - 11 классы

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс?

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс.

Заменить все четные элементы значением максимального элемента.

Полученный массив вывести на экран.

Verfil53 13 февр. 2020 г., 05:20:42 | 5 - 9 классы

Дан массив?

Дан массив.

Определить : индекс минимального и индекс максимального элементов.

Chernjva 25 сент. 2020 г., 14:17:19 | 5 - 9 классы

Задан массив из семи элементов?

Задан массив из семи элементов.

Найти сумму максимального и минимального элементов и их индексы.

На этой странице находится вопрос Найти максимальный из элементов, имеющих четный индекс?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.