Паскаль?

Информатика | 10 - 11 классы

Паскаль.

Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и четные, и нечетные элементы).

Ответить на вопрос
Ответы (1)
SlavaGeyman 11 июн. 2020 г., 12:23:32

Var i, maxk, maxd, r : integer ; a : array[1.

30] of integer ;

begin

for i : = 1 to 30 do a[i] : = random(100) ;

maxk : = 0 ;

maxd : = 0 ;

for i : = 1 to 30 do

begin if (a[i] mod 2 = 0) and (a[i]> ; maxk) then maxk : = a[i] ; if (a[i] mod 2 < ; > ; 0) and (a[i]> ; maxd) then maxd : = a[i] ;

end ;

r : = maxk - maxd ;

writeln(r) ;

end.

Fiksator3780 11 дек. 2020 г., 11:00:21 | 10 - 11 классы

Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов?

Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов.

Известно, что в массиве есть хотя бы один нечетный элемент.

Hatashaprudhik 4 авг. 2020 г., 01:37:25 | 10 - 11 классы

Дан целочисленный одномерный массив из n - элементов?

Дан целочисленный одномерный массив из n - элементов.

Вывести на экран четные элементы стоящие на нечетных массивов через паскаль.

Настя631прдлвптррии 2 июн. 2020 г., 15:30:58 | 5 - 9 классы

1) Удвоить все элементы массива?

1) Удвоить все элементы массива.

2)Найти сумму элементов двух массивов одинаковой размерности.

4) Найти Минимальные элементы массива и его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива 7) Определить количество максимальных элементов массива P.

S Ребят, все в паскале.

Заранее спасибо = *.

Настя122004 1 мар. 2020 г., 21:25:50 | 5 - 9 классы

Напишите пожалуйста программу, которая находит максимальный и минимальный из элементов массива с четными положительными значениями?

Напишите пожалуйста программу, которая находит максимальный и минимальный из элементов массива с четными положительными значениями.

Если в массиве нет элементов с четными положительными значениями, нужно вывести сообщение об этом.

С объяснением!

Виленочка 26 июл. 2020 г., 07:34:27 | 10 - 11 классы

Найти максимальный элемент одномерного массива среди элементов с четными номерами?

Найти максимальный элемент одномерного массива среди элементов с четными номерами.

(начертить схему).

Mmp7272 2 сент. 2020 г., 23:19:54 | 10 - 11 классы

Все четные положительные элементы целочисленного массива уменьшить вдвое, все нечетные положительные увеличить на 2, а у всех остальных поменять знак?

Все четные положительные элементы целочисленного массива уменьшить вдвое, все нечетные положительные увеличить на 2, а у всех остальных поменять знак.

Катя20045 21 апр. 2020 г., 14:50:56 | 5 - 9 классы

В линейном массиве определить минимальный элемент из элементов массива, имеющих нечетные номера?

В линейном массиве определить минимальный элемент из элементов массива, имеющих нечетные номера.

Elenashmeleva1 14 апр. 2020 г., 00:10:59 | 5 - 9 классы

Дан целочисленный массив из 50 элементов?

Дан целочисленный массив из 50 элементов.

Элементы массива могут приннимать целые значения от 0 до 1000.

Найти и вывести номер элемента массива, имеющего максимальное значение среди элементов массива, которые больше, чем 4 и меньше , чем 9.

Гарантируется , что в исходном массиве есть хотя бы один такой элемент.

На паскале , помогите пожалуйста.

Hsmjh 3 февр. 2020 г., 20:38:40 | 5 - 9 классы

Дан целочисленный массив X(N, M) ?

Дан целочисленный массив X(N, M) .

Среди нечетных строк массива найти сумму четных элементов.

666Виктория666 8 сент. 2020 г., 14:33:42 | 10 - 11 классы

В целочисленных массива X(N) найти номера и значение, максимального четного и минимально нечетного элементов массива?

В целочисленных массива X(N) найти номера и значение, максимального четного и минимально нечетного элементов массива.

На языке СИ .

Если вам необходимо получить ответ на вопрос Паскаль?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.