Дано число n?

Информатика | 5 - 9 классы

Дано число n.

С начала суток прошло n минут.

Определите, сколько часов и минут будут показывать электронные часы в этот момент.

Входные данные Вводится число n - целое, положительное, не превышает 107.

Выходные данные Программа должна вывести два числа : количество часов (от 0 до 23) и количество минут (от 0 до 59).

Учтите, что число n может быть больше, чем количество минут в сутках.

Ответить на вопрос
Ответы (1)
Слев 24 мар. 2020 г., 22:21:01

/ / Pascal ABC.

NET Версия 2.

2 Сборка 790

var n, h, m : integer ;

begin ;

readln(n) ;

if (n< ; 0) or (n> ; 107) then exit ; / / странное ограничение

h : = n div 60 ;

m : = n mod 60 ;

while h> ; = 24 do

h : = h - 24 ;

writeln(h, ' : ', m) ;

end.

Пример ввода :

106

Пример вывода :

1 : 46.

Zvezdochkina01 20 окт. 2020 г., 16:33:48 | 5 - 9 классы

Написать программу подсчета количества часов, минут и секунд в данном числе суток?

Написать программу подсчета количества часов, минут и секунд в данном числе суток.

Напишите на C + +.

Rome341 21 янв. 2020 г., 05:39:56 | 10 - 11 классы

Помогите пожалуйста написать алгоритм к этой задаче : Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество ми?

Помогите пожалуйста написать алгоритм к этой задаче : Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд.

Количество минут и секунд при необходимости дополняются до двузначного числа нулями.

С начала суток прошло n секунд.

Выведите, что покажут часы.

Barselona93 28 окт. 2020 г., 13:35:53 | 5 - 9 классы

Ограничения [Время : 1000ms, Память : 128MB, Сложность : 2%] Задана продолжительность некоторого события в секундах целым числом?

Ограничения [Время : 1000ms, Память : 128MB, Сложность : 2%] Задана продолжительность некоторого события в секундах целым числом.

Считая, что в одном часе 60 минут, а в минуте 60 секунд, определить продолжительность события в часах, минутах и секундах.

Входные данные : Во входном потоке задано единственное натуральное число T (T < ; 10000000) Выходные данные : Вывести три натуральных числа через пробел : часов, минут, секунд Пример входного файла (input.

Txt) : 3666.

Magda233 27 июн. 2020 г., 04:06:50 | 10 - 11 классы

Дано число n?

Дано число n.

С начала суток прошло n минут.

Определите, сколько часов и минут будут показывать электронные часы в этот момент.

Программа должна вывести два числа : количество часов (от 0 до 23) и количество минут (от 0 до 59).

Учтите, что число n может быть больше, чем количество минут в сутках.

Пример Ввод Вывод 150 2 30.

DimaDey 13 февр. 2020 г., 02:59:01 | 5 - 9 классы

Выведите число, поданное на ввод?

Выведите число, поданное на ввод.

ВХОДНЫЕ ДАННЫЕ Одно целое положительное число, не превышающее 1000.

Одно целое положительное число, не превышающее 1000.

ВЫХОДНЫЕ ДАННЫЕ Выведите то же самое число.

На языке С.

Lstava 29 авг. 2020 г., 16:10:38 | 10 - 11 классы

Написать программу с процедурой подсчет кол - во часов, минут, секунд в данном числе суток входные данные число суток?

Написать программу с процедурой подсчет кол - во часов, минут, секунд в данном числе суток входные данные число суток.

Кристина1309 2 янв. 2020 г., 13:51:03 | 5 - 9 классы

PASCAL ABC?

PASCAL ABC!

Составьте программу подсчета количества часов, минут и секунд в данном количестве суток.

Количество суток вводится с клавиатуры.

20051049 30 дек. 2020 г., 00:17:07 | 5 - 9 классы

Для тех, кто знает Python?

Для тех, кто знает Python!

Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд.

Количество минут и секунд при необходимости дополняются до двузначного числа нулями.

С начала суток прошло n секунд.

Выведите, что покажут часы.

Самое главное - как сделать, чтобы всегда выводилось двузначное количество минут и секунд?

Misha13Misha13 11 июн. 2020 г., 14:04:04 | 5 - 9 классы

Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд?

Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд.

Количество минут и секунд при необходимости дополняются до двузначного числа нулями.

С начала суток прошло n секунд.

Выведите, что покажут часы.

Входные данные Вводится целое число n.

Выходные данные Выведите ответ на задачу, соблюдая требуемый формат.

Примеры Входные данные 3602 Выходные данные 1 : 00 : 02 Входные данные 129700 Выходные данные 12 : 01 : 40.

Arsentimur 12 окт. 2020 г., 11:41:26 | 5 - 9 классы

JAVA Дано число n?

JAVA Дано число n.

С начала суток прошло n минут.

Определите, сколько часов и минут будут показывать электронные часы в этот момент.

Программа должна вывести два числа : количество часов (от 0 до 23) и количество минут (от 0 до 59).

Учтите, что число n может быть больше, чем количество минут в сутках.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Дано число n?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.