Дана матрица Z(3?

Информатика | 1 - 4 классы

Дана матрица Z(3.

3) заменить все на нули все её элементы, расположенные на главной диагонали.

Преобразованную и исходную матрицу вывести по строкам.

Ответить на вопрос
Ответы (1)
Rodion10m 27 июл. 2020 г., 08:57:28

Vara, b, i, min, j, sum : longint ;

m : array[1.

3, 1.

3] of longint ;

begin

for i : = 1 to 3 do

for j : = 1 to 3 do

read(m[i, j]) ;

for i : = 1 to 3 do

m[i, i] : = 0 ;

for i : = 1 to 3 do

begin

writeln ;

for j : = 1 to 3 do

write(m[i, j], ' ') ;

end ;

end.

Shukyur 25 апр. 2020 г., 03:12:33 | 10 - 11 классы

Помогите пожалуйста В каждой строке матрицы F(k, k) элемент, лежащий на главной диагонали, если это простое число, заменить суммой ранее расположенных элементов?

Помогите пожалуйста В каждой строке матрицы F(k, k) элемент, лежащий на главной диагонали, если это простое число, заменить суммой ранее расположенных элементов.

(решить в паскале).

Kiryashonok1 1 июл. 2020 г., 00:45:12 | 10 - 11 классы

Дана целочисленная квадратная матрица?

Дана целочисленная квадратная матрица.

Найти число строк, сумма элементов которых равна сумме элементов главной диагонали данной матрицы.

Нужна на языке си.

Dima1210 19 мар. 2020 г., 23:23:16 | 10 - 11 классы

Помогите люди))?

Помогите люди)).

Дана квадратная целочисленная матрица размера 4х4.

Заменить нулями элементы матрицы, лежащие на главной диагонали.

В bordland paskal .

Задача на двумерный массив.

Swag556789 19 мар. 2020 г., 10:10:06 | 10 - 11 классы

7. Ввести вещественную матрицу размером m * n?

7. Ввести вещественную матрицу размером m * n.

Вывести индексы тех строк, в которых есть хотя бы одно значение, дробная часть которого меньше 0.

55, или сообщение об отсутствии в матрице таких значений.

8. Ввести квадратную матрицу порядка n.

Вычислить произведение элементов, расположенных на главной диагонали.

Сформировать одномерный массив из элементов исходной матрицы, расположенных ниже главной диагонали и больших произведения ее элементов.

Вывести полученный массив или сообщение об отсутствии таких элементов.

9. Дан одномерный целочисленный массив размерностью N.

Сформировать новый массив из элементов исходного, расположенных до первого отрицательного элемента и большего первого элемента исходного массива.

Если такие элементы отсутствуют, то выдать об этом сообщение.

Metelkinakristina 19 нояб. 2020 г., 08:56:07 | 10 - 11 классы

Дана квадратная матрица действительных чисел?

Дана квадратная матрица действительных чисел.

Найти сумму модулей элементов , расположенных выше главной диагонали.

Yyyyulya 7 нояб. 2020 г., 18:44:21 | 10 - 11 классы

Дана матрица К(3, 3), найти минимальный элемент массива в строке с индексом 3 и заменить этим значением все элементы главной диагонали?

Дана матрица К(3, 3), найти минимальный элемент массива в строке с индексом 3 и заменить этим значением все элементы главной диагонали.

Коля2004 21 мар. 2020 г., 13:08:48 | 1 - 4 классы

Дана матрица А(3, 3)?

Дана матрица А(3, 3).

В строках с отрицательным элементом на главной диагонали найти суммы всех элементов.

Вывести номера строк, суммы, а так же матрицу А по строкам.

Паскаль.

IvanWein 14 сент. 2020 г., 17:25:44 | 10 - 11 классы

Написать программу для следующей задачи : в матрице А(8, 8) все отрицательные элементы, стоящие на главной диагонали и ниже нее, заменить нулями?

Написать программу для следующей задачи : в матрице А(8, 8) все отрицательные элементы, стоящие на главной диагонали и ниже нее, заменить нулями.

Gnusarkovru 10 мая 2020 г., 21:05:37 | 10 - 11 классы

Дана квадратная матрица А порядка N, состоящая из натуральных чисел?

Дана квадратная матрица А порядка N, состоящая из натуральных чисел.

Если сумма индексов каких - либо двух элементов матрицы, расположенных ниже главной диагонали, равна минимальному элементу для всей матрицы, то вывести на экран сообщение "Да", иначе - сообщение "Нет" Помогите пожалуйста(( Язык С + +.

Умникус2015 21 сент. 2020 г., 13:21:12 | 10 - 11 классы

Заданы матрица порядка n и число k?

Заданы матрица порядка n и число k.

Разделить элементы k - й строки на диагональный элемент, расположенный в этой строке.

Исходную и полученную матрицы вывести на экран.

Вы открыли страницу вопроса Дана матрица Z(3?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 1 - 4 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.