Дана матрица А(3, 3)?

Информатика | 1 - 4 классы

Дана матрица А(3, 3).

В строках с отрицательным элементом на главной диагонали найти суммы всех элементов.

Вывести номера строк, суммы, а так же матрицу А по строкам.

Паскаль.

Ответить на вопрос
Ответы (1)
Катюха065 21 мар. 2020 г., 13:08:53

Vara, b, i, min, j, sum : longint ;

m : array[1.

3, 1.

3] of longint ;

begin

for i : = 1 to 3 do

for j : = 1 to 3 do

read(m[i, j]) ;

for i : = 1 to 3 do

if m[i, i]< ; 0 then

begin

for j : = 1 to 3 do

sum : = sum + m[i, j] ;

writeln(i, ' ', sum) ;

sum : = 0 ;

end ;

for i : = 1 to 3 do

begin

writeln ;

for j : = 1 to 3 do

write(m[i, j], ' ') ;

end ;

end.

Netkiks 11 мар. 2020 г., 19:07:23 | 10 - 11 классы

Найдите сумму элементов четных и сумму нечетных строк матрицы А(n, m)?

Найдите сумму элементов четных и сумму нечетных строк матрицы А(n, m).

Irina03081958 16 нояб. 2020 г., 00:07:51 | 10 - 11 классы

Задача на c + + Дана целочисленная матрица?

Задача на c + + Дана целочисленная матрица.

Определить : А) номер первой из строк, содержащей хотя бы один положительный элемент Б) характеристику каждой строки матрицы.

Характеристикой строки матрицы называется сумма ее отрицательных элементов.

Kiryashonok1 1 июл. 2020 г., 00:45:12 | 10 - 11 классы

Дана целочисленная квадратная матрица?

Дана целочисленная квадратная матрица.

Найти число строк, сумма элементов которых равна сумме элементов главной диагонали данной матрицы.

Нужна на языке си.

AnanaskaZzZ 26 нояб. 2020 г., 05:34:45 | 10 - 11 классы

Дана матрица раз мерности NxM?

Дана матрица раз мерности NxM.

В каждой строке матрицы посчитать количество отрицательных элементов.

АНДРИЕВСКИЙ 27 июл. 2020 г., 08:57:22 | 1 - 4 классы

Дана матрица Z(3?

Дана матрица Z(3.

3) заменить все на нули все её элементы, расположенные на главной диагонали.

Преобразованную и исходную матрицу вывести по строкам.

Yyyyulya 7 нояб. 2020 г., 18:44:21 | 10 - 11 классы

Дана матрица К(3, 3), найти минимальный элемент массива в строке с индексом 3 и заменить этим значением все элементы главной диагонали?

Дана матрица К(3, 3), найти минимальный элемент массива в строке с индексом 3 и заменить этим значением все элементы главной диагонали.

Namakiti10 18 янв. 2020 г., 12:47:30 | 10 - 11 классы

Дана матрица L(3, 3), найти и вывести номера строк?

Дана матрица L(3, 3), найти и вывести номера строк.

, эле­менты которых одинаковы.

Вывести матрицу L по строкам.

Lenaishim 27 окт. 2020 г., 15:05:16 | 10 - 11 классы

Задача по информатике (Паскаль)Пожалуйста помогите сделать задание в паскале?

Задача по информатике (Паскаль)

Пожалуйста помогите сделать задание в паскале.

Дана матрица А(3.

3)

1) Найти число отрицательных элементов под главной диагональю.

2) Найти сумму элементов первой строки по формуле.

3) Поменять местами элемент третей строки и первого столбца на S.

Kovaleva8431492 17 мая 2020 г., 06:07:21 | 10 - 11 классы

Дана прямоугольная матрица?

Дана прямоугольная матрица.

Найти строку с наибольшей и наименьшей суммой элементов.

Вывести на печать найденные строки и суммы их элементов.

Jktyrfltvxer 27 мая 2020 г., 11:01:36 | 10 - 11 классы

В матрице D(m, n) определить общую сумму всех элементов матрицы, найти сумму элементов в строках и доли в % этих сумм от общей суммы?

В матрице D(m, n) определить общую сумму всех элементов матрицы, найти сумму элементов в строках и доли в % этих сумм от общей суммы.

Написать программу в VBA.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Дана матрица А(3, 3)?. По уровню сложности вопрос рассчитан на учащихся 1 - 4 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.