В квадратной матрице найти сумму минимального и максимального элементов главной диагонали?

Информатика | 10 - 11 классы

В квадратной матрице найти сумму минимального и максимального элементов главной диагонали.

Ответить на вопрос
Ответы (1)
Erikdav 30 дек. 2020 г., 11:27:57

Const N = 10 ;

Var

A : array[1.

N, 1.

N] of integer

i, min, max, j : integer ;

Begin

Randomize ;

For i : = 1 to n do begin

For j : = 1 to n do begin

A[i, j] : = random(50) ;

Write(a[i, j] : 4) ;

End ;

Writeln ;

End ;

Writeln ;

Max : = a[1, 1] ; min : = a[1, 1] ;

For i : = 1 to n do begin

If a[i, i] > ; max then max : = a[i, i] ;

If a[i, i] < ; min then min : = a[i, i] ;

End ;

Write(max, ' ', min) ;

End.

Ila2904 29 сент. 2020 г., 23:03:04 | 10 - 11 классы

Ввести двумерный массив 4х4, найти произведение элементов главной диагонали матрицы, а так же сумму элементов подобных диагоналей?

Ввести двумерный массив 4х4, найти произведение элементов главной диагонали матрицы, а так же сумму элементов подобных диагоналей.

Megagalicberov 15 дек. 2020 г., 03:32:59 | 5 - 9 классы

Нужна программа 1)Найти максимальный и минимальный элемент матрицы 2)найти сумму диагональных элементов всё это в одной программе (паскаль)?

Нужна программа 1)Найти максимальный и минимальный элемент матрицы 2)найти сумму диагональных элементов всё это в одной программе (паскаль).

Kiryashonok1 1 июл. 2020 г., 00:45:12 | 10 - 11 классы

Дана целочисленная квадратная матрица?

Дана целочисленная квадратная матрица.

Найти число строк, сумма элементов которых равна сумме элементов главной диагонали данной матрицы.

Нужна на языке си.

Yarima 12 окт. 2020 г., 14:59:23 | 10 - 11 классы

Дана целочисленная квадратная матрица найти сумму элементов, стоящих выше главной диагонали на языке Turbo Pascal?

Дана целочисленная квадратная матрица найти сумму элементов, стоящих выше главной диагонали на языке Turbo Pascal.

Alsunya91 17 июн. 2020 г., 06:45:17 | 10 - 11 классы

Помогите написать программу в pascal'e?

Помогите написать программу в pascal'e.

Если матрица квадратная, то поменять местами минимальный и максимальный элементы побочной диагонали.

В противном случае - заменить элементы четных строк нулями.

Metelkinakristina 19 нояб. 2020 г., 08:56:07 | 10 - 11 классы

Дана квадратная матрица действительных чисел?

Дана квадратная матрица действительных чисел.

Найти сумму модулей элементов , расположенных выше главной диагонали.

Yyyyulya 7 нояб. 2020 г., 18:44:21 | 10 - 11 классы

Дана матрица К(3, 3), найти минимальный элемент массива в строке с индексом 3 и заменить этим значением все элементы главной диагонали?

Дана матрица К(3, 3), найти минимальный элемент массива в строке с индексом 3 и заменить этим значением все элементы главной диагонали.

Коля2004 21 мар. 2020 г., 13:08:48 | 1 - 4 классы

Дана матрица А(3, 3)?

Дана матрица А(3, 3).

В строках с отрицательным элементом на главной диагонали найти суммы всех элементов.

Вывести номера строк, суммы, а так же матрицу А по строкам.

Паскаль.

Zajchikova1986 2 апр. 2020 г., 15:05:57 | 10 - 11 классы

Дана квадратная матрица порядка N?

Дана квадратная матрица порядка N.

Найти произведение элементов побочных диагонали квадратной матрицы.

Лыоадыо 13 сент. 2020 г., 02:44:29 | 5 - 9 классы

С + + ?

С + + .

Определить максимальный элемент матрицы на главной диагонали и сумму элементов этой диагонали.

Размер матрицы вводить с клавиатуры, элементы, а также результат, разместить в памяти динамически.

На этой странице вы найдете ответ на вопрос В квадратной матрице найти сумму минимального и максимального элементов главной диагонали?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.