Написать программу с исаользованием функции?

Информатика | 5 - 9 классы

Написать программу с исаользованием функции.

Дано N целых чисел.

Подсчитеть количество чисел, в записи которых нет цифры 8.

Ответить на вопрос
Ответы (1)
Dema133779 16 апр. 2020 г., 09:03:33

Var

A : Array[1.

100] of Word ;

N, Max_S, i, I_max : Byte ;

Function Sum_of_figures(p : Word) : Byte ;

var

d : Word ;

S, j : Byte ;

begin

d : = 10000 ;

S : = 0 ;

For j : = 1 to 5 do

begin

S : = S + (p div d) ;

p : = p mod d ;

d : = d div 10 ;

end ;

Sum_of_figures : = S ;

end ;

Begin

Randomize ;

Write('N = ') ;

Readln(N) ;

Writeln ;

Writeln('Initial array : ') ;

For i : = 1 to N do

begin

A[i] : = Random(65535) ;

Write(A[i] : 8) ;

end ;

Writeln ;

Writeln ;

Writeln('Sums of figures : ') ;

Max_S : = 0 ;

For i : = 1 to N do

begin

Write(Sum_of_figures(A[i]) : 8) ;

If Sum_of_figures(A[i])> ; Max_S then

begin

Max_S : = Sum_of_figures(A[i]) ;

I_max : = i ;

end ;

end ;

Writeln ;

Writeln ;

Writeln('Maximal sum of figures (', Max_S, ') has the element N', I_max, ' equal to ', A[I_max]) ;

Readln ;

End.

Kravika2010 27 июл. 2020 г., 11:59:17 | 5 - 9 классы

Написать программу, которая вычисляет сумму первых n целых положительных чисел?

Написать программу, которая вычисляет сумму первых n целых положительных чисел.

Количество суммируемых чисел должно вводиться во время работы программы.

Написать ее с помощью цикла for.

To. do.

СаяраАхмедова16 20 мар. 2020 г., 03:08:41 | 5 - 9 классы

Помогите решить пожалуйста даю 20 баллов?

Помогите решить пожалуйста даю 20 баллов!

Дано целое число N (0< ; = N< ; = 9).

Написать программу, вычисляющую сумму всех двузначных чисел(в записи которых нет цифры N) Даны целые числа A и B.

Написать программу, подсчитывающую сумму двузначных чисел, у которых либо первая цифра равна A, либо вторая цифра равна B.

Написать программу, определяющую количество трехзначных натуральных чисел, сумма цифр которых равна заданному числу N Все через While.

Viktoriuakr 27 июл. 2020 г., 23:03:20 | 10 - 11 классы

Составить программу, определяющую, в каком из данных 5 чисел количество цифр больше?

Составить программу, определяющую, в каком из данных 5 чисел количество цифр больше.

Нахождение количество цифр числа оформить в виде функции

Решение на паскале, написать программу.

Golovinadjuliy 6 авг. 2020 г., 10:43:44 | 10 - 11 классы

Написать программу, в которой пользователь вводит несколько чисел, программа выводит количество положительных чисел?

Написать программу, в которой пользователь вводит несколько чисел, программа выводит количество положительных чисел.

Юляффка12 17 дек. 2020 г., 15:18:27 | 5 - 9 классы

Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел?

Написать программу в которой вводятся целые числа и подсчёт количества введённых положительных и отрицательных чисел.

75281 13 июн. 2020 г., 10:59:13 | 10 - 11 классы

Написать программу, которая вводит с клавиатуры одномерный массив из пяти целых чисел и выводит количество ненулевых элементов?

Написать программу, которая вводит с клавиатуры одномерный массив из пяти целых чисел и выводит количество ненулевых элементов.

Hikkishima 25 сент. 2020 г., 17:35:36 | 5 - 9 классы

Pascal?

Pascal.

ABC Дано случайное количество чисел, узнать сколько совершенных чисел в этом ряду (написать программу).

Мигка1 9 мар. 2020 г., 17:58:22 | 5 - 9 классы

Написать функцию, подсчитывающую количество цифр целого числа?

Написать функцию, подсчитывающую количество цифр целого числа.

Используя ее, определить, в каком из двух данных чисел больше цифр.

Ole4ka2la 22 нояб. 2020 г., 14:06:13 | 10 - 11 классы

Даны целые числа a, b, c?

Даны целые числа a, b, c.

Написать программу, подсчитывающую сумму тех из данных чисел, которые больше нуля.

Роберт4567 15 дек. 2020 г., 15:05:17 | 5 - 9 классы

Написать программу, которая обеспечивает ввод последовательности чисел?

Написать программу, которая обеспечивает ввод последовательности чисел.

Количество чисел в последовательности неизвестно.

Программа должна находить количество чисел, которое кратно 3 и заканчивается на 6.

На этой странице сайта размещен вопрос Написать программу с исаользованием функции? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.