Помогите решить пожалуйста даю 20 баллов?

Информатика | 5 - 9 классы

Помогите решить пожалуйста даю 20 баллов!

Дано целое число N (0< ; = N< ; = 9).

Написать программу, вычисляющую сумму всех двузначных чисел(в записи которых нет цифры N) Даны целые числа A и B.

Написать программу, подсчитывающую сумму двузначных чисел, у которых либо первая цифра равна A, либо вторая цифра равна B.

Написать программу, определяющую количество трехзначных натуральных чисел, сумма цифр которых равна заданному числу N Все через While.

Ответить на вопрос
Ответы (1)
Arma60 20 мар. 2020 г., 03:08:43

Program tak ;

var a, b, c, N : integer ;

beginwriteln('введите число N (0< ; = N< ; = 9) ') ;

readln(N) ;

b : = 0 ;

for a : = 99 downto 10 do begin if (N < ; > ; a div 10) and (N < ; > ; a div 10) then b : = a + b ;

end ;

writeln(b) ;

end.

Эт первая

program tak2 ;

var a, b, c, d : integer ;

beginwriteln('введите два числа') ;

readln(a, b) ;

d : = 0 ;

for c : = 99 downto 10 do begin if (a = c div 10) or (b = c mod 10) then d : = c + d ; end ;

writeln(d) ;

end.

Эт вторая.

Dinisvik 3 июл. 2020 г., 01:56:18 | 5 - 9 классы

Написать программу в Паскале, которая вычислит все двузначные числа, сумма цифр которых равна 12?

Написать программу в Паскале, которая вычислит все двузначные числа, сумма цифр которых равна 12.

Только , как можно проще.

Алгоритм вычисления пожалуйста пришлите.

KanekiKeH 29 февр. 2020 г., 09:42:36 | 10 - 11 классы

Дано целое двузначное число?

Дано целое двузначное число.

Составить программу которая определяет входит ли в него цифра 4.

Keyyt 15 нояб. 2020 г., 18:29:11 | 10 - 11 классы

Даю 15 баллов?

Даю 15 баллов!

Напишите программу в паскале Дано целое трехзначное число N и целое число k.

Написать программу, подсчитывающую сумму тех цифр числа N, которые больше k.

Nastenkasergee 11 сент. 2020 г., 21:40:15 | 10 - 11 классы

Программу на Си?

Программу на Си.

Найти все трехзначные числа, сумма цифр которых равна данному целому числу.

Ksysha4411 15 дек. 2020 г., 03:33:50 | 5 - 9 классы

Дано целое трехзначное число N, значение которого вводится с клавиатуры?

Дано целое трехзначное число N, значение которого вводится с клавиатуры.

Написать программу, которая выводит на экран true , если сумма каких - либо двух цифр числа N равна третьей цифре, false в противном случае.

Помогите пожалуйста!

Dasha999922 2 сент. 2020 г., 16:30:56 | 5 - 9 классы

Написать программу в паскаль?

Написать программу в паскаль.

Из всех двузначных чисел вывести на экран те из них, сумма цифр которых равна А.

(А вводится с клавиатуры).

Керим1 11 авг. 2020 г., 21:30:24 | 10 - 11 классы

Написать программу которая выводит все двузначные числа у которых сумма цифр равна числу введенных с клавиатуры?

Написать программу которая выводит все двузначные числа у которых сумма цифр равна числу введенных с клавиатуры.

Pinilopa1 28 февр. 2020 г., 11:46:17 | 1 - 4 классы

Даны целое трехзначное число N и цедое число k?

Даны целое трехзначное число N и цедое число k.

Написать программу, подсчитывающую сумму цифр числа N, которые больше k.

Egor200114 5 янв. 2020 г., 18:50:16 | 10 - 11 классы

Помогите, всё что сможете?

Помогите, всё что сможете!

5) С помощью repeat напишите программу, которая требует у вас пароль, например 111.

Если пароль правильный, то заполняет все строки экрана сообщением «Молодец».

Если после пятой попытки пароль все равно неверен, выходит из программы.

(2 балла) 21) Составьте программу вычисления степени числа A с натуральным показателем N.

Записать варианты программы со всеми видами циклов : while, repeat, for.

(3 балла) 27) Составьте программу, которая выводит полную запись десятичного числа 42 * 4 * , в которой пропущены две цифры (обозначены * ), если известно, что данное число кратно 72.

(4 балла) 1) Найти все двузначные числа, сумма цифр которых не меняется при умножении числа на 2, 3, 4, 5, 6, 7, 8, 9.

2) Найти все трехзначные числа, сумма цифр которых равна данному целому числу.

3) Найти все трехзначные числа, средняя цифра которых равна сумме первой и второй цифр.

4) Найти все трехзначные числа, которые можно представить разностью между квадратом числа, образованного первыми двумя цифрами и квадратом третьей цифры.

5) Найти все двузначные числа, сумма квадратов цифр которых делится на 17.

6) Найти все трехзначные числа, представимые в виде сумм факториалов своих цифр.

7) Найти двузначное число, обладающее тем свойством, что куб суммы его цифр равен квадрату самого числа.

8) Найти двузначное число, равное утроенному произведению его цифр.

9) В каких двузначных числах удвоенная сумма цифр равна их произведению?

10) Можно ли заданное натуральное число М представить в виде суммы квадратов двух натуральных чисел?

Написать программу решения этой задачи.

Vksolopova 6 мар. 2020 г., 16:16:29 | 10 - 11 классы

Даны два целых двузначных числа?

Даны два целых двузначных числа.

Верное ли, что все цифры первого числа больше соответствующих цифр второго числа?

Написать программу для Pascal.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Помогите решить пожалуйста даю 20 баллов?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.