Составить программу в паскале, в которой : а) неотрицательные числа заменить sqr, а отрицательные заменить числом 12345?

Информатика | 5 - 9 классы

Составить программу в паскале, в которой : а) неотрицательные числа заменить sqr, а отрицательные заменить числом 12345.

Б) Подсчитать и вывести отрицательные элементы массива.

Ответить на вопрос
Ответы (1)
Salakhova2003 15 июл. 2020 г., 09:30:44

FPC IDE 2.

6. 0

var a, b : array[1.

10] of integer ; i, k, z : integer ;

begin z : = 1 ;

for i : = 1 to 10 do

begin

a[i] : = random(25) - 15 ;

if a[i]> ; 0 then a[i] : = sqr(a[i]) ;

if a[i]< ; 0 then begin b[z] : = a[i] ; a[i] : = 12345 ; inc(k) ; inc(z) ; end ;

end ;

for i : = 1 to 10 do

writeln('a[', i, '] = ', a[i]) ;

writeln('Kol - vo otricatelnux : ', z - 1) ;

for i : = 1 to z - 1 do writeln('Otricatelnie elementy : ', b[i]) ;

readln ;

end.

Cmki 17 окт. 2020 г., 09:31:05 | 10 - 11 классы

Написать программу подсчёта числа отрицательных элементов массива?

Написать программу подсчёта числа отрицательных элементов массива.

Марта221 11 сент. 2020 г., 01:42:13 | 10 - 11 классы

Заполнить двумерный массив случайными числами?

Заполнить двумерный массив случайными числами.

Размерность массива и диапазон генерации вводятся с клавиатуры.

Составить программу, которая вычисляет сумму всех элементов массива.

Затем организовать новый массив В, в котором заменить отрицательные элементы исходного массива на 1, а значения остальных элементов оставить без изменения.

Подсчитать количество замен.

Poshelyuznaya 24 окт. 2020 г., 14:08:45 | 10 - 11 классы

Здравствуйте?

Здравствуйте.

Помогите написать программу на языке Бейсик.

Дан массив А из 20 элементов.

Заменить отрицательные элементы массива на среднее арифметическое элементов массива.

Результат вывести на печать.

Спасибо.

Klublena2011 27 июн. 2020 г., 01:58:52 | 5 - 9 классы

Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран?

Создать массив из 12 элементов на промежутке [ - 8 ; 10] вынести строчку на экран.

1) подсчитать количество элементов в массиве, значения которых больше 3.

2) найти сумму всех отрицательных элементов массива.

3) заменить все отрицательные элементы массива их индексами.

Вывести новый массив на экран

4)найти максимальный элемент.

Mishincom77 6 мар. 2020 г., 08:39:19 | 10 - 11 классы

В массиве все положительные элементы увеличить в 2 раза, а все отрицательные заменить на 7?

В массиве все положительные элементы увеличить в 2 раза, а все отрицательные заменить на 7.

Вывести на экран исходный и преобразованный массивы.

Девочка1997 20 мар. 2020 г., 03:22:50 | 10 - 11 классы

Заменить в массиве первый отрицательный элемент нулем?

Заменить в массиве первый отрицательный элемент нулем.

Lenagosa 1 мая 2020 г., 08:00:24 | 5 - 9 классы

Найти и вывести на экран сумму нечётных элементов массива и количество отрицательных?

Найти и вывести на экран сумму нечётных элементов массива и количество отрицательных.

Паскаль.

Помогите483 1 февр. 2020 г., 08:08:46 | 10 - 11 классы

В одномерном массиве из 10 действительных чисел заменить все отрицательные элементы, противоположными им числами и вывести новый массив?

В одномерном массиве из 10 действительных чисел заменить все отрицательные элементы, противоположными им числами и вывести новый массив.

Elvirazhambyl 18 июн. 2020 г., 01:38:27 | 10 - 11 классы

Дано n чисел?

Дано n чисел.

Замените все отрицательные числа их модулями.

Язык программирования Паскаль.

Запишите с помощью массивов.

Ellinka21 21 мар. 2020 г., 23:25:03 | 10 - 11 классы

Дан числовой массив А состоящий из n элементов если отношение числа положительных элементов к числу отрицательных более 2, то все отрицательные элементы этого массива замените на 1, а положительные ум?

Дан числовой массив А состоящий из n элементов если отношение числа положительных элементов к числу отрицательных более 2, то все отрицательные элементы этого массива замените на 1, а положительные умножьте на максимальный элемент.

На этой странице вы найдете ответ на вопрос Составить программу в паскале, в которой : а) неотрицательные числа заменить sqr, а отрицательные заменить числом 12345?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.